Return to Level1Techs.com

Bad GPU performance on inital boot


#1

When I boot my pc (Windows 10) after it is off/in sleep mode the performance of my GPU is way worse than it is should be. Only after rebooting it (OS reboot, not shut down and start with power button) usually the performance is as expected but sometimes it takes two or three reboots before it works well. It has been this way for quite a while, even after multiple driver wipes (with DDU) and updates.

Specs:

  • GTX 770 MSI gaming version
  • i5 4670K overclocked a bit
  • Mobo: Gigabyte GA Z97X Gaming 3
  • PSU: Corsair CS650M
    Driver: 390.65

Heaven scores (1080p high 4xAA normal tesselation)
when performing well:
1418 (56 fps)
when performing poorly:
683 (27 fps and very choppy/stuttery)

The weird thing is that the GPU/CPU usage/temps/(v)ram usage/GPU boost clock etc. seem to be pretty much exactly the same in both states. Does anyone have any idea what could be causing this?


#2

When it is performing poorly, is it being recognized in the Nvidia control panel?


#3

Check to see if the Nvidia drivers are installed. I have problems with windows 10 reinstalling there driver over the nvidia one.

You can also try setting the windows power setting to high performance mode.


#4

The card is being recognized the same in all situations and the drivers are installed and the power settings were already in high performance mode (both windows and nvidia). Thanks for the suggestions though guys.


#5

Have you checked how it clocks when its not doing well

nvm

Cant find answer if there is option to disable iGPU, try that :man_shrugging:

and countering these "Do I need graphics card"s leads me to 4chan /g/


#6

Have you checked if you’re running the latest BIOS update for your motherboard? There’s a newer driver for your GTX 770 at https://www.geforce.com/drivers (390.77). You should try that as well.

You can also try disabling Fast Boot in your BIOS (it’s enabled by default). It should be in the “Boot” section of the Advanced Menu. I know it sounds counterintuitive, but sometimes it causes issues and if that doesn’t help, you can just re-enable it again.

If nothing else works, maybe you can use Hibernate instead of Sleep until -hopefully- either Microsoft or Nvidia fix the problem with an update :crossed_fingers:


#7

Never had to do it myself but it sounds like the actual firmware on the GPU to me. Theres a way to reflash it in situ and JAYZTWOCENTS did a video on a similar problem a few weeks ago on a 780


#8

Only GPU weirdness I have ever had would be random blackscreens, which got fixed by reflashing the same mobo bios with usb stick

What do you mean by similar problem, or did he have same problem?


#9

I tried disabling IGPU but that didn’t seem to change anything. Fast boot mode was already disabled and setting it to enabled/utra-fast mode also didn’t change anything. When turning it on after making it hibernate while performance is good results in the same bad performance that happens on initial boot. Also tried the new GPU drivers but no luck, not that I expected it to change anything as the problem has persisted through many driver versions. Flashed my BIOS and that also didn’t seem to make any difference -_- I guess I could try flashing the rom but I don’t want to brick my card.


#10

Flash the rom. go see the jayztwocents video. I’m telling you it sounds just like the 780 he had to reflash


#11

I’ve watched Jay’s video and his problem was different, that card caused the CPU to get pinned to 100% and did so consistently, I only get less performance than expected on inital boot so IDK if it’s worth risking my card just to maybe fix this. :\


#12

I flashed my gpu bios to the most recent version and the flashing worked fine but it doesn’t seem to have done anything to fix the problem :frowning:


#13

Have you turned off fast startup in Windows control panel?
This may help make the issue more repeatable, because after every shutdown/power off, when booting up the drivers etc will all be reloaded. If fast startup is on (it defaults to on), a shutdown/power on is similar to resuming from sleep/hibernate.

image


#14

Fast startup was on but turning it off didn’t seem to change anything.


#15

its a known bug on 7XX nvidia driver. No fix is available. Do not put your pc to sleep. (some pascal gpu’s are also affected.)


#16

I never put my pc to sleep, the problem is that the performance is bad on initial boot and is only good after rebooting (through OS).


#17

So I got an RX Vega 56 to replace my 770 thinking it should solve my issue on top of being a nice upgrade but to my great disappointment the exact same issue happens with this card. The only thing that is slightly different is that performance is reduced more than it was with the 770.
After this I’ve tried the following things:

  • Clean windows 10 install
  • Clearing CMOS
  • Changing all the BIOS settings that seem like they could have anything to do with it (one by one)
  • Disabled PCIE power saving in power settings
  • Swapped RAM dimms around in the slots/ tried each one separately
  • Put GPU in second PCIE slot (8x PCIE 3)

But none of it made any difference :frowning:
Does anyone have any other ideas to try?


#18

Looks like the 770 was probably fine, as the issue persisted with the new Vega card. Sounds like an issue with CPU, mobo, ram, or PSU.

I like to start with the simple stuff. Two things to look at. First, what is your CPU temp at idle?

Second, because it is easy as well. Go ahead and run memtest if you havent already.

If memtest passes and CPU temps are normal, it is time to dig a little deeper.


#19

At idle CPU temps are about 30C (when ambient is ~19C)
At full load (while playing JC3 which pins CPU at 100%) they get up to low 50s
I ran memtest and it found 0 errors


#20

So this does not appear to be an overheating CPU or bad memory module.

At this point the easiest thing to do is swap components, if you have access to them.

Do you have another PSU you can try?

Also, since the 4670k also has integrated graphics, you can remove the GPU entirely and run integrated graphics and see if the problem persists.

If it works on the integrated graphics, I would suspect a possible power delivery issue.