Bad CD rips

I’m ripping my new CDs and the output .wav files have this annoying popping/ static noise sporadically, I have used every ripping software under the sun but the issue persists.

I’ve used 2 different CD drives(a new pioneer bdr-2213 and my existing asus dvd drive), new sata cables, even a new motherboard(ROG STRIX B650E-F GAMING WIFI and MAG X670E TOMAHAWK WIFI).

using EAC and dBpoweramp with AccurateRip shows different CRC values on every rip. None of my key disks which I’ve previously ripped just fine will rip without static. I know the issue is not my cds since they play everywhere else just fine. my audio setup plays sound from all other sources like spotify and youtube music just fine.

the only things that have changed since ripping my key disks for the first time are my cpu/mobo/ram (ryzen 1800x → ryzen 7900x) and the switch to windows 11.

windows shows my cdrom drivers for both as version 10.0.22621.1 from 6/21/2006, which doesn’t seem correct but I can’t find a more up to date driver.

anyone else have a similar problem with win11 or am5? pls help me debug i’m at my wits end

I’ve actually not tried to rip anything on my current Windows 10 and 11 machines.

The last time I ripped any CD Audio was when I created a Windows XP VM and ripped via the optical drive passed through.

The app was Winamp, because it whips the llamas ass :stuck_out_tongue:

Have you updated your amd system drivers?

yeah, newest bios on both mobos as well, IDE ATA/ATAPI drivers are also from 2006?

Does it also occur using Cyanrip? GitHub - cyanreg/cyanrip: Bule-ish CD ripper
Don’t forget to set drive offset correctly.
What drive do you have?

cyanrip windows builds don’t seem to be doing anything

using a pioneer bdr-213M which i got this week thinking that the Asus HL-DT-STDVDRAM GH24NS95 I’ve had for 10 years was dying or something

I’d probably look at the dpc latency checker just to see if any drivers are causing buffer underruns, I’d also be cleaning the laser diodes etc

Does the issue persist of you try to rip a cd in Linux?

I haven’t had a chance to install linux on this system but i’ll give it a shot in the morning and update

just use a live image I reckon

1 Like

just made a quick ubuntu image and played the CD and the static was still there, didn’t try to get a rip however

So lets posit this, assuming the source media and drive is good:

  • recording may get corrupted during transit to processing
  • or data gets corrupted while being processed
  • final data gets corrupted while being saved

Second variant eliminates the optical drive. Third variant is unlikely to match described issues.

However two other quick checks are still relevant:

  • do dpc latency check, this operation is latency sensitive as it can get
  • perform memtest on platform, especially if you use oc memory

AM5 platform can get unstable quicky with expo memory profiles and MCR enabled.

Newer bioses fixed the issue, but if you didnt update and use EXPO, well you might be suprised how bad it can get.

Speaking from personal experience here regarding the memory OC, it was really insidious.

I ran dpc latency check and found it sitting ~1500μs. I’m currently running latencymon while ripping to see what processes could be at fault and found HDAudBus.sys with the highest ISR time 40.710μs and highest ISR total 0.000107%. I’m going to run memtest while I run some errands and report back.

Thanks for your help

likely your recording at a higher bitrate than the cd was sampled at…
try 24 or 16 bit 48k or 44k

This, try 16 bit 44.1KHz assuming that’s the bitrate of the CD’s and don’t upsample.
Also check if there’s a difference if you’re converting the file to a FLAC instead of WAV, somehow some software has issues with wavs for whatever reason.

I’ve had good results with this app on both windows and linux:
https://www.freac.org/

People are still ripping CDs in 2023?!! My last rip was more than 10 years ago. Not that I don’t want to rip. It’s really personal. I think I lost the appetite for music in general…

CDs…the Red Book… IS always 44.1kHz and 16-bit. If you run into issue, what you could try is always try to rip at lower speeds, preferably 1X, 2X etc…instead of 20X…24X or whatever.

My last rip software was XLD on MacOS.

Yep, because it feels nice to have copies that you actually own in an age where everything is streamed from 15 different platforms.

4 Likes

and no monthly subscription or removal of content!

Are you using the same settings between the two installs. For example

1 Like

Exactly what does that mean?

thanks everyone for the help, I’ve resolved the issue by getting an external 5.25 drive enclosure. I’m now getting clean rips, verified with AccurateRip in dBpoweramp. The issue was not with any of my rip settings.
Its definitely a hardware issue somewhere in my build. but I’m far too busy right now to investigate it further. At first I thought it was an issue with the chipset in my previous motherboard, but now that I’ve swapped it out I’m suspecting my CPU or RAM. this is also my second kit of RAM in this system since the first one was very unstable(free GSkill kit from microcenter bundled with cpu + mobo), so I’m starting to suspect my CPU may be a bad silicon lottery pick(Bad memory controller + bad chipset connection).

Anyone know of some tests I can do to rule out my CPU?
maybe this’ll get fixed with more BIOS updates?
I guess this is what people mean when they talk about early adopter pains.

2 Likes