Return to Level1Techs.com

AX370-GAMING K7 and sound issues (ALC1220)

helpdesk

#1

AX370-GAMING K7
Kubuntu 17.10
4.14.3 kernel

So I recently got this board. Everything seems to work fine from what I can tell, except some problems with the on-board sound codec. I can get sound from the rear line-out, but nothing from the front panel. Everything is hooked up right and works as intended under Windows.
Already checked under alsamixer and all the channels are active with volume at 100%. PA is also configured correctly.
Anyone has this board running under Linux or has experienced similar issues with this particular sound codec?


#2

The Realtek ALC1220, works flawlessly on Manjaro 4.14.3 (Front Panel tested) Is the front panel setting enabled in bios?


#3

I have not seen a front panel setting in BIOS, just the usual option to disable/enable the codec. Maybe I missed it, but then, it works fine under W10.
I should mention this particular board has “dual sound codecs”, I assume one for the rear and another separate one for the front. Don’t know it that’s part of the issue here (the second codec not being initialized/used).


#4

According to http://www.gigabyte.us/Motherboard/GA-AX370-Gaming-K7-rev-10#kf

It has Dual ALC 1220 with Front & Rear 120dB SNR HD Audio with Dual Smart Headphone Amps

It’s the same codec, if it’s not enabled by bios or supported by the operating system i guess it won’t work. Linux is most likely coded in traditional ways, (To work on most motherboards) expecting newer motherboard related technologies to work out-of-the-box is pretty optimistic, nothing wrong in being that though :smiley:

Dual codecs and whatnot are supported under MS10, which i doubt it is under Linux. (Drivers and all that)

There should be such a setting in bios, it may be called something similar like HD Audio, FPA, AC97 etc. Or you could try disabling it instead, to see if that fixes the issue


#5

Wouldn’t the codecs simply be seen as two separate sound devices? I’m no kernel dev, so don’t know.


#6

On windows yes. Linux most likely wouldn’t recognize the second codec at all, depending on where it’s placed on the motherboard, is my guess. You should be able to tell, through either the Terminal (Google for the Terminal Command) Or possibly in the settings of the operating system. On Manjaro it’s called Manjaro Settings Manager > Hardware Configuration > Show All Devices


#7

Then it may not be worth it to troubleshoot. I may just “wait it out” or put back my old Xonar DX. Over the weekend I will try to get it to work again or see if it’s properly detected.


#8

I have the same motherboard and problem. Even with updates over the last month. Linux reads both codecs as one and causes a major issue with sound redirection. I started using a USB dac and that will have intermittent issue with the microphone not working.


#9

Yes, the kernel detects both codecs and loads separate modules, but sound redirection does not work (neither do you have a tickable option in alsamixer like on some cards). Went back to the Xonar DX. The integrated codec is rather noisy if you use the pack panel anyway.


#10

You’re correct, while using windows during testing there’s a good amount of static. And I’ve also thought about going to a sound card. It just seem bad to be using a sound card, because Linux can not separate. I do hope there’s a kernel patch soon for this because more motherboards are going this route.


#11

Dual sound codecs? I think only GB is doing it right now. Most higher end boards I have seen just use one single condec and a separate amp for the front panel. On AMD boards at least, don’t know on the Intel side of things. Still, silly that Linux can’t use them both. Dual integrated NICs are not a problem, so why would dual sound codecs be? I mean, you can already have multiple sound devices in your computer and Linux has no problem. It should eventually get sorted out I guess.


#12

I believe MSI is using dual codecs also. There’s actually a patch within Linux for dual codecs. It’s just not working on the AMD boards. https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/sound/pci/hda/patch_realtek.c?h=v4.13&id=fa16b69f1299004b60b625f181143500a246e5cb


#13

Maybe you could try to install a newer kernel with Ukuu.
Maybe that might fix the dual audio codecs not being detected sepperatelly.


#14

I know I’ve tried a secondary kernel and edit the patch. But no luck.


#15

Still not working with the 4.15 kernel. Oh well. Thankfully DP audio works properly (ish) now with amdgpu and Polaris chips, so I can have both my speakers and headphones plugged in at the same time.


#16

So coming back to this. I came upon this little write-up detailing a fix:

https://frdmtoplay.com/gigabyte-front-panel-audio-with-linux/

Don’t have time to try it out until the weekend. From what I can tell it seems to be a Pulseaudio issue.


#17

Holy crap guys, it works! Seems to be a PA issue where it does not recognize the sink corresponding to the front panel. All devices are listed with aplay -l, but like in the write-up, PA only sees the rear output in regards to the integrated sound chip. Loading the missing sink with the given PA command makes the correct number of sinks appear (rear and front). Then it was as easy as loading up Kubuntu’s PA Volume Control GUI, play some sound file, and move the audio stream to the new device and done. Don’t worry, all sound streams get directed to the new output after that. I did note that the front output shows up as a separate sound device in Kubuntu’s sound configuration.
Unfortunately I have to do this every time I log in or reboot. I have not tried the mic port yet.

Edit: Front MIC also works. You just have to load the proper module into PA.


#18

Thanks Melcar,

I haven’t tried it yet. I’ll see if I can get it up and running tonight. I’ll let you know my results also.


#19

I cant believe something so simple was the cause. Both headphones and mic working. Thanks again, you saved me a trip to Microcenter for a sound card.


#20

Glad it worked.
Question for you. How is the integrated sound on your board? I get some weird feedback noise under certain conditions, like some GPU operations (moving/resizing windows, with some games) and sometimes with heavy LAN traffic. Happens on both rear and front outputs. My Xonar DX is dead silent in comparison. Using the Xonar again due to this.