Return to Level1Techs.com

AX370-GAMING K7 and sound issues (ALC1220)

helpdesk

#21

I tested the suggested commands, but the microphone didn’t work. What do you mean by “the proper module”?
By using this command I’m now able to use the front panel output from “pavucontrol”

pacmd load-module module-alsa-sink device=hw:1,4

But I’m still not able to use the rear microphone, nor the front microphone. They show up. They also show correctly when I plug and unplug them, but they are muted (not literally, the mute button is not pushed. but they don’t pic any sound and there is no activity in the graphical bar at all. they act as muted, but they are not).
Could you point me in the right direction? How did you make them work?

Thank you


#22

To load the mic, you need the command

pacmd load-module-alsa-source device=hw#,#

Replace “#” with whatever your device id is. For inputs use the “arecord -l” command.

Now, if even your rear input is not working, then the problem may be something else. Have you checked alsamixer to see if nothing is muted? Also, keep in mind that this board has separate audio-in and mic rear ports. This had me off guard for a bit. Make sure your mic is plugged into the correct one.


#23

Hi, I’m having the exact same problem and I’ve done a lot of debugging–disabling all the automatic module loaders so that I could load in sources and sinks myself, especially. I followed your instructions and ran pacmd load-module module-alsa-source device=hw:#,# where #,# was my device id, and when I did so (after disabling everything else) the microphone showed up in my sound settings, as it has before. But still, the microphone was “ghost muted”. This happens with all microphones I plug into any mic jack.


#24

Thanks. I did exactly that, but it looks there is some other problem. I now see there is another user that found the bug, which at least comforts me a little bit. At least I’m not the only one.
Just out of curiosity, can you describe your setup?
I’m using kernel 4.15.13 + Ubuntu 17.10 x64. And it doesn’t work for me. Maybe you have something different?


#25

Hi, I was having the same problem then I found this, which said that there is a dobble mute in alsamixer, if there are line underneath the volume bar it is still muted(comment 10 if you are wondering). You can mute/unmute by selecting it and clicking spacebar. @whizzball1, maybe this is also your problem


#26

Yes, this was also my problem. I happened to upgrade to kernel 4.17rc3, and enabled this card for testing again. To my surprise they were muted in alsamixer, but not in Pulseaudio, so I just used alsamixer, unmuted the mic, and now everything is working again.
THANK YOU.


#27

Here’s what’s going on, the fixup renames it HDAudio-Gigabyte-ALC1220DualCodecs so it will load the ucm file through Pulseaudio from package alsa-lib in /usr/share/alsa/ucm/HDAudio-Gigabyte-ALC1220DualCodecs/
Problem is HiFi.conf is refering to cdev “hw:PCH” <- that’s Intel shenanigans
if you find all occurrences of PCH and replace it with Genereric, eg: cdev “hw:Generic” then before the device Nr like this: cdev “hw:Generic,4” | cdev “hw:Generic,0”

Front ports and Line will work again, but you will most likely have to create more profiles in the HDAudio-Gigabyte-ALC1220DualCodecs.conf if you need Digital profiles etc. This needs a if Intel/PCH else AMD/Generic fix to stick tho’ :stuck_out_tongue: