Return to Level1Techs.com

Attention amd vfio users do not update your bios

linux
motherboard
#1

Error: unknown pci header type ‘127’

This has been occurring to people who updated their BIOS on AMD motherboards. This happened to me across different linux distros (fresh installs) AND motherboards AND GPUs (tested with both 980 ti and rx580). I basically bricked an MSI x470 Gaming Plus trying to force my BIOS to revert to an earlier version to fix the problem, then I was stupid enough to update my BIOS on the brand new Asrock x470 Taichi that I bought to replace it, and the SAME EXACT error occurs on a completely different setup.

This is both a warning and starter thread to see who else is experiencing it and if anyone has any fixes for this, PLEASE share. It looks like the major vendors are locking down their recent BIOS updates for some reason. I was not allowed by the BIOS to revert on both the MSI AND the Asrock motherboard.

3 Likes

Encountering the AMD reset bug, any fixes? (RX 590)
QEMU VM being paused on startup
#2

so to clarify, you updated BIOS and could not roll back?

I’d RMA the board if that’s the case.

Have you contacted support about the issue? It could be a bug.

1 Like

#3

Yes, on both MSI and Asrock mobos. They’re practicing this universally now it looks like.

0 Likes

#4

As above, could be a bug in the part of the BIOS contributed by AMD. Maybe not intentional, but due to it being AMD code shipped to the vendor, common across all of them…

Also, which BIOS versions for both boards?

edit:
checking release notes for most recent BIOS for my x470 taichi:

Improve add-on VGA compatibility with Raven processors.

Could be a bug related to that.

First bios from April for the Taichi also included updated AGESA which could also be bugged?

0 Likes

#5

IDK it’s the same exact error / problem as the MSI board. Maybe they have the same feature “improvements” in their bios updates.

0 Likes

#6

I’m not going to RMA the Asrock board yet. I’m definitely RMA’ing the MSI board since I bricked it. But I definitely just need a working motherboard for now. I’m gonna called Asrock on Friday and see if I can get them to help me revert the BIOS and report back here for anyone who is interested.

1 Like

#7

I had some issues updating my BIOS on an Asrock x370. It was pre 3.30, and bugged out when I updated it to 3.30 (bridge bios) and then 4.something, but it did allow me to downgrade, then worked when I tried again.
So I was able to update to, and past the 3.something bridge bios.
I used VFIO on it before and after.
The UEFI wouldn’t boot any of the operating systems I had installed, but a fresh install and that worked too…
So maybe try again?

0 Likes

#8

The issue affects all fresh installs of any linux distro and both AMD GPUs and NVIDIA GPUs, and evidently more than one AMD motherboard manufacturer. I’ve spent many many hours trying to resolve this issue. if you go to the Asrock Taichi x470 support page, then the BIOS download page, you’ll see the last four versions say “users will be unable to rollback”. That bit is intentional.

0 Likes

#9

Hmm. Maybe the lack of downgrade is due to Ryzen 3000 specific features (for coming launch) and allowing downgrade could potentially end up with a user with a board that won’t work with their CPU, if they were to say, get a board with BIOS 3.x on it, a Ryzen 3000 and then try to downgrade it.

0 Likes

#10

agesa 0072 I think? there’s a quirk for this though. known bug:

https://clbin.com/GGnxm

get used to compiling your own kernels buddy

0 Likes

#11

Where do you get the error message?

I have a x470 taichi since yesterday. I updated it to Bios version 3.20 and i don´t see that error in my System logs.

I am passing through a Sapphire Nitro + Vega 64.
I disabled “ROM BAR” in virt-manager.

Edit: So i got the error some time after i shut down my windows VM.

1 Like

#12

sorry I’m not used to putting my own bits of code in the kernel. Whereabouts do I put this bit of code exactly?

0 Likes

#13

It’s a diff, the hint is here:

diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c

It is in your kernel souce directory, then drivers/pci/quirks.c

I’d suggest just waiting for a new kernel release that fixes it unless you’re keen on hacking kernel source and recompiling.

I used to compile custom kernels all the time back in the day but now can’t be bothered since about 2004. I’m not trying to fit linux on a 486 with 4MB RAM any more (and almost everything can be made a module now)… so not sure how much of a pain in the balls/time sink it is these days.

0 Likes

#14

the last AMD agesa based issue took almost a year to correct IIRC, if he already uses vfio that may not be an option. no idea if this patch is even on their radar atm

0 Likes

#15

this is for sure on the radar. I feel confident about MSI and Gigabyte having a workable solution before launch, but that might be same bios version with two agesas… not sure. I’m working on it now though.

2 Likes

#16

good to know. I’ve been putting out fires in various vfio hobby channels for a while now on this one, and it’s been very frustrating for quite a few newcomers.

“oh, just compile a custom kernel” just isn’t an acceptable answer for a lot of people.

4 Likes

#17

I’m perfectly happy compiling my own kernel if it fixes this problem. Thank you very much for the information! I will figure it out. I always do.

0 Likes

#18

OK, I think I’ve done everything correctly to setup a patched compilation of the kernel (using arch). Do I need to alter that code you posted at all to in regards to those PCI-E addresses at the bottom to match my own? Or do they encompass all of my x16 slots? ./lsiommu.sh shows my card to be something that looks different from that patch, but it’s also formatted differently, so I’m not sure.

0 Likes

#19

Sorry mate i’m not sure what the code does and i don’t run VFIO at the moment.

That diff shows the differences between two files under two different folders.

Other than that don’t have the time/inclination to investigate myself, sorry.

0 Likes

#20

Can you show me where you found that patch at least? I need to read a bit more before I boot into this kernel. I’ve found similar looking patches with a google search, but not that particular version.

0 Likes