Return to Level1Techs.com

ASUS Zenith x399 Owners Thread

amd

#1

First thread, please forgive/inform me if I do anything wrong.

Made a lot of posts regarding my experiences with the ASUS ROG Zenith Extreme motherboard. Figured I would make a thread to consolidate information.


#2

Downloading UEFI version 1003 now. Personally, I wish consumers had more resources to verify such important downloads. I understand that the downloads are almost certainly signed by ASUS and the UEFI validates this, but I still wish there was more information available to the consumer to be involved in the process.

So in that spirit here is simply the output of sha256sum in linux

53be90a98ca43640a07f89f59b4acd94735184699807f98b42463c846d045427 ROG-ZENITH-EXTREME-ASUS-1003.zip
7d317915eab6c017c8d00b1484b5ce5cae6175ff675514ca43efb2a26cdd17a7 ROG-ZENITH-EXTREME-ASUS-1003.CAP

Edit: adding some terms I used when googling for the subject: checksum, BIOS, Agesa 1.0.0.5, validate, hash, bios update, uefi update


#3

Helpful Threads for Prospective Buyers and Owners

ECC Memory:

https://forum.level1techs.com/t/interested-in-iommu-ecc-on-the-asus-rog-zenith-extreme-tr-board/118730

VFIO Gaming / GPU passthrough / Gaming in Windows in Linux

https://level1techs.com/article/ryzen-gpu-passthrough-setup-guide-fedora-26-windows-gaming-linux

https://forum.level1techs.com/t/threadripper-reset-fixes/

  • still necessary for me to passthrough a nvidia pascal gpu
  • Doesn’t fix Vega reset bug for me unfortunately, still must reboot host everytime to pass Rx Vega 64 to different VM

#4

Do we have more threads like those? We should. Threadripper is not straight forward platform at best so we need more reports regarding ECC, IOMMU, pci-e bifurcation, SR-IOV etc. on X399 boards. I’m stalking tech support of ASRock, Gigabyte, Asus and AMD for few days already and the worst part is that when they say “No” it basically means “Maybe” they’re just afraid to be quoted on that if something won’t work. Ugh…

I remember some posts about problems with DIMM.2 and PCI-E passthrough compatibilty on this board Could someone confirm?


#5

if you guys are interested in the vrm specs of your boards,
i did a over view on that a while back.


#6

Hey pretty big update:
Just upgraded to Fedora 28 with kernel 4.16.7-200.fc27.x86_64 and I no longer need to use a custom compiled kernel for the reset bug!

I upgraded from an existing Fedora 27, probably why my kernel version still includes f27 in it :man_shrugging:

AMD Vega reset bug still in full effect, but it was that way with the compiled kernel as well.


#7

My dimm.2 was very touchy to say the least. Trouble shoot memory errors without dimm.2 card installed. Threw memory errors on POST when installed in a way that felt proper, that is pushed in all the way and with the latch shut.

Eventually got it to work by installing it in a way where I pushed it in, but not all the way in, and then closed the latch as much as I could. Not the best description, but its the best I can think of right now.

Can confirm PCIE passthrough troubles. For NVIDIA cards I needed to use @wendell’s threadripper reset fixes Kernel patch (linked above). Only today with F28 upgrade and above mentioned kernel could I run NVIDIA card right without patch.

If you need help with it lmk I’ve worked through a lot of issues. One thing of note: I had to define a fake vendor ID using Fedora which I’ve read a couple places is thought to be only an Ubuntu issue.

AMD card (Vega 64 and 56) worked for me out the box. Even with the reset patch, they still have reset problems. Must confirm vfio has the card at boot and can only boot a VM using it once. To switch VMs or reset VM, you must reset the host.

Edit: Idk if using @ for every mention of Wendell on here is polite on rude so someone let me know so I don’t overspam him haha


#8

Is anyone able to verify whether this motherboard supports SR-IOV? I’m not sure if there’s any command to check that without SR-IOV capable card so I believe it may not be easy to verify… Maybe @wendell or someone else happen to have some SR-IOV network card like Intel X710 laying around and could check that?


#9

Hey this probably applies to the whole x399 platform. Apologies if already posted.

I just found out today through some tinkering a trick to improve virtual machine cpu usage with libvirt.

For high VCPU count virtual machines:
I’ve been getting the best performance with setting sockets: 2, cores to whatever, and threads to 1.

This may have to do with the fact that TR is 2 cpu dies with infinity fabric. I’m no hardware expert, but this is my anecdotal experience. Using just a 1900x personally.

Anyone else have a similar or different experience with socket count and ThreadRipper / x399 platform / EPYC platform?


#10

If you want wendells opinion or help on some questions,
then its fine to tag him with an @.
if you do that once in the said post then its basiclly fine.
Wenn he has the time, he will probablly try to answer.
But it may take some time for his response, because he’s pretty busy.

But from what i gather on the topic is that there is still allot to,
be improved wenn it comes pci-e passtrough and iommu groupings for Threadripper.
There are several topics arround on the matter, especially for Ryzen.
I personally also believe that TR definitelly also suffers a littlebit from latency issues like Ryzen1.
With Ryzen + allot of the latency issues seems to have been improved over Ryzen.
So yeah maybe we might see some new TR sku’s in near future who knows?


#11

Could you post UEFI photo or tell what PCI-E switch modes are available on Zenith Extreme on individual slots? I’m talking about pci-e bifurcation x4/x4/x4/x4, that U2 trick with bottom pci-e being bifurcated to x4/x4 etc. Basically what are available PCI-E switch modes for each slot on this board.


#12

I’m sorry I didn’t reply sooner. Did you forsure it out?

I don’t know much about PCI bifurcation at all. What screen shots would help you out? Just of UEFI options in general?
@lapsio


#13

Nope. I don’t know where it is exactly but I saw this UEFI screen for split of second on D8auer video about this ultra NVME RAID. It’s equivalent of this page in ASRock boards:

Now ASRock x399 motherboards also support 2*8 mode and support those 3 modes on both x16 slots. I don’t know about Zenith Extreme but it’s particularly interesting to me because I think I saw something like ability to bifurcate most of slots on Zenith, not only x16 ones. Thus asking.

I’d like to see which slots are allowed for bifurcation on Zenith and in which modes.


#14

Hello guys,
I have a theadripper 1950x with asus zenith extreme with lastest bios (1003) and I can’t make it work SR-iov with an intel x520-da2 interface.
Also I try to passthought a radeon 7700 and itd fails too.
I test this with esxi and also with Ubuntu 18.04.
Do I need to downgrade the bios?
Is there any trick with zenith extreme?

Thanks in advance
Hernan


#15

@lapsio

Is this what you’re looking for? Straight from the manual:

Slot Layout:

BIOS option which enables X8 for Slot-6 but disabled U.2:
ROG%20Zenith%20Extreme%20PCIeX8-X4_4


#16

@Asgaroth Not really I’m talking about splitting PCIEX16_1 or PCIEX16_3 into four or eight PCIE x4 slots using riser like Asus Hyper M.2 or Supermicro pci-e risers. So that in the end with M.2 -> pcie x4 adapters you can have 14 pcie slots on single motherboard.

Essentially I’m wondering whether I can connect this:


To only one pci-e x16 or both and connect 8 GPUs, 3 netowork cards and RAID controller to single motherboard.

I’m building virtualization host but I can’t afford SR-IOV GPU like NVidia GRID so I’ll have to use physical GPU for every VM.


#17

Hey I realize this is super late, but even with most recent UEFI, I do not see such options for PCIE bifurcation. I looked under AMD/PBS, just like in your asrock bios picture, and saw no such options.

There is one option that looks similar: for one slot you can choose “x4” or “4x4” mode (wtf?). Pretty sure this is meant to be the option for choose x8 or x4 for the last slot. It can change bandwidth because if you use the USB-C you need to run it in x4 mode.

Sorry man :confused:

Just curious did you ever proceed with your build? Why not just use an asrock x399 board if you know it has the feature in question?


#18

Hey quickie update on my experiences with this board for just over a year.

The Good:
Pretty frequent UEFI updates, with good groupings, compared to many other gen 1 boards. Also except for bifurication, there is a healthy multitude of UEFI config options. I think they may have made one a while back that lets you split the ethernet connection into many virtual ones, not sure exactly.

In one of the UEFI updates a while back, ASUS made separate PCIE groups for various USB ports. There are two separate groups of USB 3.0, and USB 3.1 port on the motherboard has its own group as well I believe.

This is really cool as it lets me use a cheap usb switch (you could also use Wendell’s KVM switch) to switch peripherals quickly between VMs, without using up any PCIE slots for usb cards.

I would post the actual groupings ( I have PCIE ARI support enabled in UEFI), but my computer is currently disassembled. Which leads me to…

The bad

I have posted before about how flakey the Dimm.2 slot is. So I finally said enough is enough and decided to install my one m.2 ssd in the onboard slot, under the logo plate.

TLDR; don’t count on reliably using any m.2 with this board. The screws on the logo plate are cheap, and have threadlock adhesive on them. Which I did no know before attempting to unscrew them. The manual also does not specify what screwdriver to use at all, beyond phillips. This is a documented problem over at ASUS’s forum.

So now I have a hopeless stripped screw preventing me from accessing the one reliable m.2 slot.

***TLDR; Pretty good software support is negated by the fact that the hardware itself seems rushed and poorly executed for a high end board in hindsight ***


#19

Zenith owner here! While I mostly love the board, I was wondering if others had flakey ram slots on the IO shield side of the board. Now, I did get my board as an “AS IS” return, and have no major complaints, and will likely get a new board in a year or so, especially if I get more ram. More like, when I get more ram. Got the board for $175, so I don’t feel bad, even if the board is a little faulty.

Currently using two sticks of off brand hynix ecc ram. They mostly run great at 2666. I have had them at 2933 also, and I thought they ran fine. But when I go into the bios and change ram timings, even to looser ones, there is a good chance the slots near the IO shield drop the ram. It just up and dissapears. No matter what, in the 4 slots nearest the IO shield. The 4 other slots are rock solid. To get the stick back usually takes many tries at reseating the ram. Sometimes the post fails, ans sometimes It will boot to the OS, but one stick is gone. However usually it fails to pass post.

I am wondering if it is a CPU seating problem now though. While reseating the ram, I inevitably at least touch the heatsink, so that could change the contact with an important pin?

Once the ram is detected and it boots all the way into the OS, there is no problem at all. It stays rock solid, and I get no indication that a whole stick of ram drops out.

This has not been a major problem, once the system detects the ram, and boots, all is good. But it does hinder my ability to find the best possible performance of my machine, as even a good ram setting may not detect properly. So it is hard to know if 2933 is actually stable with a certain setting or if I give up too soon on the many reseatings of ram sticks.


#20

That’s annoying :worried:

What voltage are you running? I had some issues with a flakey dimm slot, and upping the voltage has basically gotten rid of it.

I have heard reseating the CPU can go a long ways with memory problems on this board as well.