Asus Pro WS WRX80E-SAGE SE WIFI - no longer able to access IPMI portal

Hello if anyone has experience with ASUS’ ASMB9-iKVM I would appreciate some input. When i first put this workstation together I was able to access IPMI via url in various web browsers. I was able to login and access all IPMI utilities.

Unfortunately, I am no longer able to access via browser. I am however able to ping the IPMI BMC on the network. I can also see the IPMI BMC listed as connected through my Unifi UDM.

I have tried dynamic and static addresses, no difference. I have also tried a warm reset for the BMC. Any recommendations on how to completely flash the BMC?

Thanks for any suggestions.

Two quick things.
The BMC does NOT have a dedicated LAN port which means it has to somehow serve on the X550. On most other boards, there are settings for that. It might be possible that ASUS fucked that up and you can set it to something that won’t work. There should be an option in the BIOS to see the BMC / remoteManagement Network settings and update those. It is here where you would be able to set the mode on other Boards.
The sharing of ports also means for me that you might not be pinging the BMC but your WS instead.

Another thing to notice, there is a Switch and a LED on the Board for the BMC. What is that LED doing? It should be blinking in 1s intervals. IF it isn’t, the BMC isn’t running and hence, can’t serve an ipmi.
LED is number 29 on the Boardoverview.
BMC Switch, number 13 under the sata ports, DISABLES or ENABLES the BMC. If you flipped that, that would explain everything.

ipmitool would be another tool to use to look into from the WS side.
No idea what exactly to do with that right now, but there are tools to connect to the BMC from the WS Side you can use to further figure out whats going on.

1 Like

After a few days trying, I finally solve the same problem.

  1. Dynamic and Static addresse are not the keypoint, I also use UniFi UDM to find the dynamic IP and set the Static IP in the UEFI/BIOS;
  2. If you find the right IP, type it in the browser address box like this https://...:443 or https://.../#login

Because ASMB9-iKVM does not support http login by default.

I have the same problem with IPMI. And nothing works from the start to restore access to BMC. I can see it working on the network with IP and and blinking green LED on mobo. However, no luck in accessing BMC. I head that someone was able to restore access by updating/flashing firmware. I do have LED showing error in BMC (the bottom amber LED is on). Anybody knows commands in linux for flashing using Yaflsh or Yafuflash? Or any other way to flash BMC.

Me too – spent yesterday on this. I have to use wifi (no easy access to router), but got to BMC via cat 6 LAN cable plugged directly from old Win10 PC to ASUS WRX80e. Set (compatible) static ip addresses for ethernet on both old and new machines, and logged into BMC as expected. Noted that the firmware was still 1.10.0 (Dec 25, 2020). Set fan profiles, and all was good. So I shut down, unplugged, waited a few minutes, then restarted, hoping to log back in and update the firmware.

As others report, I could not log back in to the BMC. But (some time later…) I did get back in, and updated the firmware to 1.11.0. What may have helped was disabling the wifi connection on my old Windows pc, from which I was trying to log in? Maybe this forced the browser to wake up the ethernet socket physically connected to the ASUS WRX80e? Anyway, happy to report that the 7 BMC fan control zones are working perfectly.

I noticed that there is a new BMC firmware as of 7/1.
Version 1.13.0
2021/07/01 30.5 MBytes

BMC FW V1.13.0

What is the way to update this.
The iKVM has a firmware update, and the files come with a set of batch files.
The info I found on the web shows web based upload.

I was able to access the BMC with firefox until yesterday, but now only Edge works, strange. Firefox just keeps reloading the page after a glimpse of the UI.

Never mind, I guess.
I did the BMC firmware update through the web once, and it did not work.
There were some strange messages about hardware issues afterwards so I powercycled the whole thing.
Tried the firmware again and it behaved just like the FAQ said it would.
No strange stuff, now.
Firefox in private mode worked fine. Something with NoScript was messing with the login process in regular Firefox.

Hi all,

Full disclaimer - I’m EXTREMELY new to all things BMC/IPMI.

I have one goal here, control my case fan speeds. This has always been trivially easy in the past via q-fan etc. however now it seems to do this I need to go via this IPMI/BMC system.

Have I got these steps right?

  1. enable BMC support in BIOS - Server MGMT
  2. Config IPv4
  3. Lan Channel 1
  4. Static IP
    192.168.1.75
    255.255.255.0
    Router IP: 0.0.0.0
    Router Mac Address: 00-00-00-00-00-00
  5. Log into windows and then type IP address into web browser (edge)
  6. https:// 192.168.1.75

I have tried this and all I get is ‘can’t reach this page’ or ‘connection has timed out’. This is trying on the computer itself and via another laptop connected via lan. Also the other thing I wanted to confirm is that I can log into the BMC via the machine itself or do I need to actually log into it from another machine via LAN cable??? (I’ve seen this suggested elsewhere)

Last piece of the puzzle is that when I enable BMC in BIOS the MSG_LED glows amber and holds. According to the manual this is caused by a BMC abnormal event.

Thanks to all in advance. Pardon the ignorance to a lot of the topics discussed.

1 Like

On my system BMC was enabled by default, not changes in bios needed. It obtained a IP address from DHCP ( or it was hardcoded to 192.168.0.67 ) The system IP address and the BMC ipaddress are on the same NIC by default.
I can access it from the same computer or another on the same lan.
It seems to work better with chromium browsers than firefox, although it may be some of my firefox settings.
The bios information about the management interface will provide the ip address.
Once you get in to the BMC, download and apply the 1.14.0 BMC firmware.
It has better error handling for sensor data.

Thanks for the info Mark!

Does your motherboard also have the amber MSG_LED light on constantly? I’ve got the green flashing BMC_LED but I’m wondering if the amber BMC LED is something I should be worried about?

When I try to ping the static IP address I have assigned to the BMC I get no response.

When I’m setting up the BMC network configuration in BIOS should I be leaving the router IP and MAC address as their defaults? They’re currently
Router IP: 0.0.0.0
MAC: 00-200-00-00-00-00-00

I don’t plan to ever be able to access the PC via another computer. I just need to access the IPMI so setup my fan curves because currently they’re constantly at max speed.

Thanks!

The BMC led is flashing green, the others are off.
The amber light may be the result I used to see because the original BMC firmware reported erroneous sensor readings from the chipset fan speed that were setting alarms.
The updates stopped that, unless there are other issues with the system.
Before you try setting the BMC stuff in the BIOS, why not just try Dynamic/DHCP which will probably pick Lan Channel 1. Just to see if it works, and then change it. Just to see what the errors might be, and to update the firmware.

Hey all.

UPDATE

I was able to get BMC working.

I changed the BMC settings to DynamicDHCP and then found the allocated IP address of the BMC in windows using angryip.

My problem was that I was under the impression that the machine could communicate from the motherboard to the BMC chip within the machine itself. Once I connected the PC to a router I was able to then identify the IP address and then log into it as normal. I’ve tested using firefox, chrome and edge and they all work.

Thanks Mark for helping point me into the right direction.

Cheers,

I’m also having a problem accessing it. Any idea where i could get the VGA 16p to 15p to see whats going on?

Thanks!

I also had problems to control fans speed in my new built based on asus WRX80E-sage se wifi. Originally, I had only wifi connection via built-in adapter, no ethernet cables plugged in. OS (windows) was installed with all drivers but BMC was not accessible and there was totally no control over fans, which was frustrating.

The first problem was in BMC switch (located near SATA ports) which was OFF. In this case BIOS was reporting “bmc self test status failed”. After turning it ON, I was able to assign a static IP address for the first BMC interface (say, 192.168.254.1 with 255.255.255.0) in “Server Mgmt” menu. But still I was not able to access BMC in windows. By the way, connected WRX80E wifi was in different IP subnetwork (10.x.x.x).

Next, all I done is just physically connected WRX80E with ethernet cable to another running PC (this can be router, too, and network settings there are not important unless they interfere with BMC network settings) to make one of WRX80E ethernet interfaces UP. In windows, on that network interface I also prescribed static IP address different from the BMC one (192.168.254.3, 255.255.255.0 mask). And I then was able immediately access BMC via https_192.168.254.1.

1 Like

Hello, I am yet another person with the great IPMI troubles trying to control fan speeds. I have the BMC switch, the IPMI switch, and the bios BMC setting enabled. The BMC light is blinking green, and I have both Ethernet ports connected to my router. My BMC is set to autoDCHP the IP address, which is currently going to 192.168.1.3 according to the bios and my router.

All that being said, I am unable to ping 192.168.1.3, nor am I able to login to it using these three methods:
192.168.1.3
192.168.1.3:443
192.168.1.3/#login

I am running the latest bios for the motherboard, but the BMC is stuck on 1.10 due to my inability to access it.

Update I found the solution, the IPMI REQUIRES you to add the “s” to https://192.168.1.3/

If you don’t it won’t respond. For anyone who has these issues here is a summarized guide:

  1. Turn on the BMC and IPMI switches

  2. Enable BMC in bios under server management

  3. Look at the network setting and set whichever lan channel you have connected to to autoDCHP

  4. Restart computer, and go back into server management and network settings and see which IP address it was assigned

  5. Go to a browser and type in the IP address, making sure that https and not http is being used.

2 Likes

Trying to control my fans too on this board, did you find a solution?

Guess who’s got a brand new WRX80-SAGE and is 5 seconds away from calling an orbital strike on Asus headquarters ? This guy :face_with_symbols_over_mouth:.

Am I the only one who finds it inadmissible that it should take a freaking engineer a whole evening of Googling to access a lowly management interface ? It’s one of the most expensive motherboards in existence and they couldn’t spare someone to actually write a manual ?

Anyway, I can confirm a few things :

  • You need the board’s Ethernet to be connected to something. If it’s not up, no way to log into the IPMI even though it’s on the same computer.
  • The IPMI is slower than my grandma’s laptop. Be patient. I’ve seen websites load faster back when I was still using a 56K modem in the 90’s. I mean WTF…

The alarms you get by default on this board are all fan-related : you see, the “geniuses” at Asus put a server BMC on a desktop motherboard without thinking for a second that desktop users don’t run datacenter-grade jet-engine fans. So virtually any chassis fan you use that doesn’t run faster than 1700 to 3500 RPM is going to make the BMC shit itself.

I’m so done with that piece of garbage. Takes entire minutes to start while preventing my own OS to boot, and all I get for that is basic fan control ? No thanks. I’m turning that pending cybersecurity vulnerability off and replacing it with a custom solution as soon as possible.

Please let us know when you find an alternate solution :no_mouth:
Cheers

Re: slow access to BMC… I connect directly via a laptop and everything is instant. Fans respond instantly to adjustments to fan curves.

Re: GPU issues… As others suggested, I had to set PCIe mode to gen 3 for my old GPU’s (this setting is buried deep in a BIOS submenu).

PS: two days ago I plugged in 3 x 3090 Ti… love this board!