Return to Level1Techs.com

ASUS PRIME X370-PRO BIOS update

FINALLY! ASUS’ latest BIOS update 3803 solves my Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz C15 Memory Kit - Black CMK16GX4M2B3000C15 inability to run higher than 2800MHz no matter what I did and even then some reboots would fail.

NOW with this new update I was able to just enable the D.O.C.P. profile and 3000 mHz is THERE as the first choice!

F10 and boom! it boots with no reboots immediately.

Base components, total at the time was ~$800 for parts minus PSU:

https://pcpartpicker.com/user/mj34hig44/saved/JG3qsY

6 Likes

I’ll have to give it a look, I have never been able to run my 3200MHz 32Gb kit running at anything over 29-somthingorother.

1 Like

I’ve updated the BIOS since 902 I believe it was, probably 5 times, some were even pulled by Asus after I updated. None of them solved the speed above 2800 MHz problem.

This one finally did, good luck with yours.

A small improvement but not the best result.

  • 3000MHz is stable.
  • 3066MHz is OK
  • 3133MHz booted once but failed a second time
  • 3200MHz no boot.

I’m sure that if I had a 16GB kit it would be fine but 32Gb would appear to not to be possible or at least not possible with my skill level. I do love my Ryzen PC but I really did not do well with the silicon lottery, my CPU is not stable much above 3.8GHz. Being the cautious type I run it at 3.7GHz and now the RAM at 3000MHz.

Thanks for the post about the firmware update. Well worth a look even if I couldn’t get the full speed of my RAM.

2 Likes

Good to hear! I’ve downloaded it but haven’t flashed yet.

1 Like

I’ve had bad luck with my board I’m leaving it alone till my next upgrade with a MSI board. Hopefully TR2 or Ryzen2.

Sorry to hear that, my board has been flawless other than the RAM speed issue. Now it’s as expected.

I think I should have spent a bit more money on my motherboard than I did. Ordinarily I have gone for something a little more premium from ASUS. This Prime has been a bit of a disappointment. I had hoped that ASUS would have made a WS Ryzen board, but I think they have stopped making workstation range of boards.

A lot of this has more to do with the IMC on the first gen Ryzen chips and is far more RAM specific than motherboard specific from what I’ve seen. I would expect that Zen+ has a large improvement in this area.

1 Like

wow I really hope all the motherboard vendors will be having another round of memory compatibility which adds corsair lpx 3000 cl15 kits. I have this kit on 2x 8GB config and on my B350 Mortar MSI board its just not possible to run over 2400mhz cl14.
Congrats though dude this is great news

1 Like

x370 prime pro owner here. My boards had some improvements, my E-Die 16gb 3000mhz trident z rgb use to refure to work at 2933 at 3.9ghz but now it does. I’ll try to go higher and see what the results are.

1 Like

An FYI:

A warning for those that this happens to also, when updating the BIOS and the system is at the “Success system will restart” point, there was a long black screen pause I’ve not experienced just before the ‘press F1 to enter setup’ screen.

It was just black for maybe 3 minutes which seems like an eternity when you’re in this space thinking, “crap, did my board just brick” but fortunately patience prevailed and all was fine so if this happens just wait.

2 Likes

first rule when changing bios give your self at least 30min of down time. if you think its bricked wait 30 min and come back if no response after 30 min then its a quasi safe guess that something went sideways.( dual bios boards are a god send)

Well I did upgrade as well to 3803

it did not work automatically at the 1.35V of the profile at 3000Mhz for my 32GB kit

But althought I am please to see the 3000Mhz option, I only managed to get it work by rising the voltage and even tried 3036Mhz which stayed unobtainable

So after restoring manually my setting (yes I did save them, no the restore did not work)

I am actually back to my previous 2933Mhz stable config

it might seem faster to boot thought, or … am I just whishing …

In the end all is still working, so I should be happy

Well not is all working as well as before (3404),
got a weird issue with the FAN2 control in PWM being bugged, it stays at about 1024 rpm ( instead of the 770 before in iddle according to my curve) and ignored the changes in the curve in PWM mode, so the work around is to set it to DC to adjust it.

at least we are testing the BIOS, not so sure about ASUS quality control those recent “rush-a-BIOS” weeks

not happy

I have the same motherboard, but a kit of two 8GB HyperX Vengeance sticks. I had problems at first getting over 2400MHz, but since BIOS v. 806 I have been running the full 3200MHz via D.O.C.P. with no problems.
I also discussed this in another thread here when I got it to work. Anyway, thanks for the info. I have not been following BIOS updates since :wink:

The XMP profile for my RAM listed above is 1.400 volts. I’m going to try lowering it step by step but up to now the stock settings are rock solid.

Older saved UEFI profiles will not work on updated ones…

FYI one thing I found that seems to be specific of Asus motherboards not saving settings is after updating the UEFI > load optimized defaults and it reboots to the operating system you then need to do a full shutdown then reenter the UEFI and tweak your settings.

Just rebooting has caused problems with settings saving in my experience.

It is strangeley good to know that i am not the only one with the issue :wink:

However, i did save the config to the USB stick as well and it refused to restore the settings from the USB stick, that, is making me unhappy

They should include a paper notepad and a pencil in the Motherboard package, for that is what I am reduced to

Of course there is the F12 print screen to image file on the USB stick option, but you need a working computer to read it :desktop_computer:

Just save the screen capture to the cloud like Google Drive or email it to yourself and view it on your phone.

When I refer to settings about if I wasn’t talking about profile settings from one UEFI to an updated one, I wouldn’t even expect that to work, I was referring to settings not saving in a current UEFI upon reboot Etc. Asus motherboards like to be shut down after a UEFI update.