Return to Level1Techs.com

ASRock X570 Phantom Gaming X - Help Windows 10 won't install

Have been trying for several days, on and off to install Windows 10 on this ASRock X570 Phantom Gaming X motherboard with a Ryzen 9 3900X CPU and 32GB of G.Skill Trident Z RGB F4-3600C17D-32GTZR RAM.

I have installed multiple copies of Linux and even macOS Mojave using OpenCore with no issues whatever. Windows 10 Pro refuses to get past the second stage after the re-boot process; it goes into a boot loop finally giving the following error code after several reboots:

Things I have tried or noticed:

  • I have checked that the install is creating the partitions correctly (under Linux)
  • I have created different versions of WIN10 ie 1903 & 1909 on different USB sticks and verified that they install on an Intel motherboard
  • I have tried several versions of BIOS’s now using the latest 2.70
  • I have tried different RAM (always in A2 & B2) positions and have run four passes of memtest86 with no errors
  • I have run prime95 stress for around 2 hours with no errors reported under Linux
  • I have tried to install on 3.5 4TB drive, 500GB SSD and also 500GB NVME
  • I have booted with either my Vega 64 LQ and RX580 GPU’s
  • I have checked to make sure that no heatsink compound has spilled past the CPU which is using an AIO cooler
  • I have tried XMP and non-XMP settings in BIOS
  • I have checked in Linux using dmsg for any errors, non-found other than a Bluetooth firmware missing message
  • I have removed all non-essential hardware, ie the bare minimum required to boot a system
  • I have noticed that when installing that the part where it detects devices never goes past 40-70%, ie it never shows 100%.

I have noticed that in the hardware monitor in the BIOS that the CPU voltage is sitting at 1.4xx Volts, is this normal? Could the CPU be crashing whilst in the install phase before proper power management takes hold? If so how to fix?
Is the motherboard broken in some subtle way that Linux and macOS overcomes?
Am I missing something obvious?
Is there a way to run a debug mode of Windows 10 to log errors?

Not relevant to this problem, but for others trying thunderbolt I have had my Gigabyte Titan Ridge TB3 working under Manjaro Gnome and connecting to my OCW TB3 10GBe as well as my Razor core eGPU with this mobo.

1 Like

Try unhooking your linux drive and making sure the install drive is detected. Make sure secure boot is shutoff. Take a look in bios boot at settings. Maybe a temp shutdown ?

Yes I have done that. I have installed as a one drive system. Secure boot has been tried on and off as well as turning off all things not required eg WiFi and Bluetooth and also no PCIe cards other than aforementioned GPU cards.

I kind of assumed that but I had to ask :slight_smile: Boots in linux so I would say your install media is corrupted in someway. Trying build an up to date windows install usb stick.

No as stated previously, I have rebuilt the USB and used it to install on an Intel system (I have many computer and drives) with no problems.

Do any research on your Bios updates to see if there is any issues. Might try reflashing the bios or rolling it back.

Yes… I know but sometimes bios updates can be funky.

As stated I have tried several versions of BIOS’s with no difference. Can’t find any issues reported regarding non-booting of Windows.:sunglasses:

So you have taken a look at temps in bios and set up fan curves and looked at temps and auto shutdown settings.

Hardware issue/install media/settings. I am thinking… or doing a search.

Good question. Because ASRock is running the vcore of CPU at 1.4xx+ just with the CPU idling in the BIOS setting screen it hovers around 55C. I’m using a Corsair AIO cooler that controls itself, but I haven’t looked at the fan curves etc as I’m using (once booted) a Corsair Commander Pro to handle all of the other fans etc. I’ll go and check to see if there is any settings I can check.

Only thing I can think so far is reducing the ram . Try installing with less ram. I am still digging.

Okay, reduced the RAM to one 16GB stick in the A2 slot (correct for one SR or DR Stick) and set the CPU to critical temp of 95C from 85C, clean install onto SSD (only drive connected) and get same error.
When it goes through the configuring devices screen in the install it only goes to 20% the rotating circles stop, and it re boots into the install and then after a few reboots comes up with the same error as my first post.
When it goes through device and completes device discovery it should then NOT reboot and then display a “gathering information” screen.
I think this is the problem, it crashes in device discovery and does not setup the files correctly for booting into windows. It only finds the UEFI boot loader and some files and then craps its self.
The funny thing is I only need Windows once in a blue moon as I mainly use Linux or macOS on my builds.
I have reduced (turned off) in the BIOS as many hardware items as I can. I think either this mobo has a hardware problem or there is something I’m doing wrong which is possible but unlikely as I have been doing PC’s and hardware since they first came out. This is the only mobo I’ve had that has given me this strange problem.
Not sure what to do next.:no_good_man:
Any suggestions anyone??

I agree It does seem strange…ah

Unhook all but the install drive. Default bios settings and be sure to pull install media when you see it reboot. Do not change any settings and be patience.

I kind of think that it is possible you flipped a setting that may not translate well to windows.

I have been running searches but all it turns up is supernoob stuff.

I have seen installs were the install indicator was not where it was actually at. Mostly in regards to nvme speeds usb c 3.1 3.1 ect…

Thanks but I have done this so many times I have nearly worn out the CMOS reset and the PC reset button.
I’ve just noticed though that when I do a CMOS reset, it is not clearing the date (battery backed up) and other settings. I’ve double checked the user guide and I’m doing the reset correctly.
I’ve tried both the internal jumper shorted for 3 seconds and with the rear clear CMOS switch.
I have just removed the battery which is a PITA to get to as you have to remove the southbridge cover to get to it, but will do a complete CMOS reset with default settings F9 in BIOS and see where it goes. Thanks for helping me @thevillageidiot:smile:

I try and this seems like something missed. God knows I have fumbled around only to discover it was something simple and I knew better…lol

It is the point of being frustrated that I often overlook something simple.

1 Like

ah… the windows dual boot rule.

this one cause me to pull some hair.

Yes that’s an old gotcha. Have learn’t a long time ago that you have to pull all drives other than the one you are installing Windows on in UEFI mode, as if the other drives are GPT drives windows gets confused and clobbers the other OS’s EFI boot folder.

Personally I think this must be a MS & Intel conspiracy, just like the removal of the Thunderbolt port on the Gigaybyte X570 Master mobo as reported on this Forum!

Asrock steel legend myself. I have yet to play with the thunderbolt style header .

If you can boot to linux ? You should be able to boot to windows. Its crazy :crazy_face:

A setting in bios… if error is found stop or something along that lines. Or stop on error ? Not versed on gigabytes bios so I do not know how it is layout. Windows will generally boot slop as long as it kind of okay. Device errors should not stop it as long as it is not something critical unless you told it to.

I am pretty much at my limits…

1 Like

If my hair wasn’t already white, it would be now! Lol

Booting with a vanilla install did nothing different. Just trying a different approach, using my HDMI instead of DP from my RX580. Grasping at thin air now!

Yep, it’s stalling on the “Getting Devices Ready 40%” message, and yep it’s rebooted…
And it’s in the reboot loop…

I keep on worrying about the voltages I’m seeing in the hardware monitor section. Look at the vcore voltage.

What are your voltages in your BIOS and what CPU are you running. I read somewhere that AMD says never to go over 1.4 and here it is at 1.472V!