Return to Level1Techs.com

ASRock X470 Taichi Ultimate - General Discussion


#42

running Archlinux with at the moment kernel 4.17.11

yes, but the cooler heatpipes are cool to the touch while in UEFI (not so under stress as just tested)

EDIT:
just tried a stresstest (PrimeGrid on 4-8 cores 100%): i can bring the temp1 (k10temp-pci-00c3) up to 84 °C (for stome reason Asrock CPU fan regulation does not change speed) and the temperature makes sense. the nct6779 CPUTIN climbed from -62 up to -11 °C - so it is definitely a wrong setting somwhere reading the chip to determine this CPUTIN temp.


#43

I’ve noticed Asrock UEFI’s are quite poor at temp reading.
Showed 60C idle when testing my 2700x with the stock cooler. But everything in windows said 40C.
Similar situation on my z170 k6.


#44

Asus C7H also reports 40s to 60s in UEFI. And it’s easy to spike the temps by scrolling rapidly. These are just 2 data points, but so far seems par for the course for UEFI behavior.


#45

i decided to play a bit with manual settings (till now UEFI OC was just on “ASRock” and all to “auto” except the ram timings).

automatic settings, the CPU was running at max 3700 MHz and in UEFI i got normally 60 °C.

i changed: cpu f fixed to 3950 and cpu voltage to 1.21250 (just guessed the values, didnt do much detailled testing as every new value set needs a reboot and retest stability which i do not care at this moment
however: i see now in bios the cpu temp being around 42-48 °C and in OS (k10temp) reporting idle temp lower than before (idle 31-33 vs before 34-40). another thing: the RAM i am using i had to loosen the timings (16-16-16-36 instead of XMP 15-15-15-35) in the auto settings and now in the manual freq and Vcpu i can run them at 15-15-15-35 at 3200 as by XMP.

i dont remember the old cpu voltage set by the asrock auto settings, however the only explaination was that the cpu voltage was too high causing issues.

anyone had some similar experiences?


#46

Well, it is fine if you don’t care about the last bit stability at this moment. However if you are a motherboard maker … you do. I would say the core voltage was adequate to run stock clocks stable even on lower quality silicon.


#47

you assume the MB producers expect the silicon to be bad and also very diverse in quality?

i did some further playing with numbers and it seems the cpu voltage you can put under the frequency has maybe the effect of defining the rough voltage, but the system will run anyway slightly different cpu voltage (according to bios and nct6779-isa-0290)… but in any ways, specifying the stock frequency to a fixed value makes the system run faster and much cooler.

stability: actually i realised that if i run the RAM (4x16gb) at XMP (15-15-15-15-35 @ 3200) i have stability issues (segfaults in linux at some rare random occasions) but if i loosen the timings to 16 and 36 and slow it to 2933 it is perfectly stable even under heavy load over hours.

next i turned on the precision boot to see how it behaves, for now i dont realise any issues


#48

I expect them to run higher voltages than most chips need for that very reason, yes.


#49

Has anyone had any trouble with the ASRRGBLED utility? It flips out any time I try to open it. Gives me an access violation error and overwrites the settings on my G.Skill memory, turning them to red. Sometimes the app will partially open.

But most of the time it just gives the access violation error and I have to kill the task in the task manager. I can’t even turn the LED’s off. I’ve tried doing it in the BIOS but that didn’t work either.


#50

I tried google and couldn’t find any information so if possible please post the iommu groups for the ASRock X470 Taichi Ultimate board?


#51

While I don’t have the groupings, here’s what items are in seperate groups

All motherboard chipset items but two USB ports and the security TPM chip are in the same group. This makes sense to keep them in their own group, as you would need a USB port for encrypted key to load to boot with the TPM chip turned on and setup. These items include:

  • All USB ports except for the 2 USB ports next to the 1gb NIC
  • Both NICs
  • All SATA ports
  • Lower M.2 slot
  • Bottom PCIe 2.0 x 16 (x4 electrically) slot at the bottom
  • HD Audio
  • The 1x PCIe slots
  • Wireless NIC and Bluetooth

Items that are in separate groups are:

  • Two USB ports and the Security TPM chip
  • NVMe drive
  • The top and middle PCIe 3.0 slots

Using ESXi, I was only able to passthrough the items that are in the separate groups list, but none of the motherboard chipset items. Honestly I feel that KVM + QEMU or Proxmox would be much more friendly about passing through certain items, but I have no experience with these hypervisors, so I can’t really say. At the least, KVM + QEMU running in Linux would be able to use the Aquantia NIC, as it has Linux drives (Aquantia NICs are not support by VMware and thus have no drivers, which SUCKS). Additionally, I was not able to do any Raw Device Mappings for hard drives to VMs on ESXi due to the SATA/RAID controller (presumably) not having a SCSI serial number, which makes sense for a consumer board. Sucks, but makes sense.

If anyone has any experience working with this board in Proxmox or KVM+QEMU on Linux, I’d love to hear if you were able to passthrough those main motherboard chipset items.


#52

Thank you for the reply.

I am actually thinking about getting the plain ASRock X470 Taichi, non ultimate board. I have to compare specifications again to be sure.

I think I will use Unraid for my Hypervisor and run Everything else in VMs with one passthrough VM for gaming on Windows 7 or maybe 10 if I decide to upgrade. I beleive I could also create a Linux gaming VM using pass-through. I just watch a video where an NVMe drive was passthrough to the guest OS, Win 10. I need to learn more about NVMe drives as this is new technology to me. I’ll also want to pass USB ports for mouse and keyboard.


#53

I found this video maybe it would help passing through “those main motherboard chipset items.”

A little about Passthrough, PCIe, IOMMU Groups and breaking them up


#54

NVMe drives are just PCIe drives, similar to PCIe 4x slot drive cards that have been around for a while (Fusion-IO drives), just in the M.2 form factor. Think of them as PCIe devices, and you’ll be fine

Also, looking at the x370 Taichi board’s IOMMU groups, there is an encryption and USB 3.0 controller in their own group, so it should be able to pass through the USB ports in that group (assuming the x470 and x370’s groups are the same)


#55

Thanks again for the reply.

If I didn’t have two SSDs all ready I might spring for one. As it is I don’t need one. Maybe a future upgrade.

I’ve decided against Unraid because I have discovered Unraid isn’t a raid.


#56

Xen server is a pretty decent as a hypervisor, I’d suggest trying that for your project, though I’ve heard that setting up PCIe passthrough is a bit more involved in it. ESXi from personal experience has been reasonably easy to setup and use for passthrough, though it is closed source and not the most friendly to using whatever hardware you want. Also, you wouldn’t be able to do any Raw Device Mappings on X470 with ESXi, so Xen may be best for compatibility reasons


#57

Thank you for the tip! It saves me from asking in the forums for suggestions.

I’ll check out Xen Server. I may decide for Debian but I prefer a hypervisor.


#58

i bought the taichi ultimate for media and storage purpose, and
have a questions for anyone who Owens the board :
1)- in asrock website they listed in the motherboard Specification
" 2 X PCI Express 2.0 x1 (Flexible PCIe) "
what do they mean by flexible pcie ?

2)- the second pcie 2.0x1 “i think it is labled pcie 4”
where dose it get the lance cpu or chipset ?
i’m planning to buy & put a 4 ports sata card in the second pcie 2.0x1
will it suffice ?
the first one i will plug a dvb card in it

i will use
2 nvme (pcei not sata )
1 gpu ( for now, maybe add another in the future for vm)
1 4ports sata card or hba ( the 8 ports on motherboard ain’t enough ! )
1 dvb pcie card
am i out of lances and will face difficulty or i’m good and can
proceed with my plan ?
thanks in advance


#59

The 2 PCIe 3.0 16x slots and the NVMe drive are the only slots getting their lanes directly from the CPU. Everything else is from the chipset. Additionally, everything in the chipset is in the same IOMMU group EXCEPT the TPM chip and 2 of the USB 3.0 ports (makes sense, as you’d want the USB key to unlock the TPM chipset in the same group). Not that important though if you’re just going to install say FreeNAS and not a full blown hypervisor.

If you put the 2nd NVMe drive in the bottom slot, then the PCIe 2.0 x 4 slot will not work (it will also only operate at PCIe 2.0 x 4 mode in that NVMe slot). Saying that, based on your current cards that you want to use, this shouldn’t really be a problem.

I’d get a Perc H200/H310 and flash it to IT mode instead of the 4 port sata card, as it would avoid any bottlenecking concerns with connecting 12 HDDs, an NVMe SSD, and DVB card through the chipset, and only costs about $30 on ebay.


#60

thanks!
i will research a little about the perc ( never used or tried one before)
i dont know if the (pcie 2.0 x1) bandwidth will be enough for 4 sata Hard drive or at least 2
unfortunately my motherboard stuck on boot loop after updating to bios 1.50
through windows i think it broke!
fans go full speed for seconds, then it slow and powers down then it repeat again


#61

Take out the CMOS battery to clear the BIOS settings. That may get you back into a functioning system

PCIe 2.0 x 1 has about 500MB/s of theoretical max speed or there about. Realistically it’s around 460-470 in practice

Here’s a guide to flashing the Dell Perc H200/H310 if ou want to check it out