ASRock WRX80 Creator R2.0

no, I managed to connect via KVM fine but the IPMI settings in the portal claim there’s a VNC service running on port 5901 by default. I was trying to see if I could connect to that to get a bit better interface than the serial console.

Which page on the BNC UI do you see that? I can’t find anything about VNC mentioned on mine.

Edit: found it. It’s under Settings → Services. “VNC” is shown as “active” on port 5901. Yeah, not sure about that. FWIW, the HTML5 remote viewer works great for me, good quality and no latency.

Settings → Services. it’s the last one on the list.

enabling the serial console makes reboots unbearably slow though, and I’m having weird issues accessing ttys/ptys in linux (I think literally all of them are getting allocated to the serial graphics device??). so I was hoping this would be a less intrusive alternative.

I have seen folks claim they got Passmark memtest86 to work. Latest version v10.00 version, and it just hangs at getting memory controller details. I waited for hours. Tried an older version, and it was waiting on gathering memory details. I was able to get memtest86+ to work, but i am more familiar with the Passmark version and the better control.

My intended application is a desktop workstation, so have no need for server or remote access functions. I want to out the computer to sleep, but there is no option to do that in Windows 10 Pro. Power Options just allows shutdown and restart. I can understand no sleep for a server, but can’t find any settings in BIOS to enable sleep. AsRock tech support has been useless, pointing me to windows settings and told to contact Microsoft! They ignore my questions as to whether there are BIOS settings to make. Yeah, thats why i spend $1000 on their products, for this level of support! Has anyone gotten sleep to work with the R2.0 version? Have a single gtx 1660 super installed with latest nvidia drivers.

And finally, how does one control and monitor fans? I have set them to full speed in BIOS and disabled BMC, but they aren’t running at full speed! Dont see anything listed in HWMonitor section, though I seem to recall seeing stuff listed at some point. Also the AiTuning utility in windows shows nothing under systeminfo tab.

TiA for any help!!

how does one control and monitor fans?

For monitoring:

In BIOS. Under H/W Monitor tab:

In the BMC. Under Sensor → Normal Sensors:

For control:

In BIOS. HW Monitor → Scroll down:

In BMC. Settings → Fan Settings → Fan Mode:

I have set them to full speed in BIOS and disabled BMC, but they aren’t running at full speed!

Make sure you have DC or PWM mode set correctly for each fan header. After that, you can use either BIOS or BMC to control the fan RPM.

2 Likes

Yes this option is there for 8x8x or 4x4x4x4

I also had issues with fans when they were set to Auto. My fans did not spin up under 40% speed and since I got Noctua IndustrialPPC 3000 rpm, they’re already “a bit” loud at 40% so it was really problematic. Switching all fans to PWM mode solved an issue and now everything is quiet. Well… as quiet as industrial 3000 rpm fans running at 1000 rpm can be…

I have the exact same problem with the lack of support for sleep mode.
In the manual it shows 2 options, “Suspend to RAM” and “Deep sleep”, but at least in the current bios 6.09, these 2 options are not present.
I have already contacted support but I am still waiting for their reply.
I even reset CMOS to ensure that I wouldn’t have a random option conflicting with the sleep mode, but it didn’t solved it.

Just got reply from ASrock saying that suspend to RAM is not supported “in hardware by design”.
I would be mindful if you are planning to buy this motherboard. Depending on what type of usage you are expecting to have, this might not be the board for you. If you planning to use it as a workstation (that I would guess it is the prevailing way) then do not buy it.
If you are planning to use it as a server and need to use all x16 slots, I also be careful. I am still waiting for their reply on my issues on slots #5 and #7. My current guess is the the pcie traces are not good enough (since I can run capture cards that are x4 gen2 without issues) to sustain Gen 4 x16 (could be redriver issues?).
If it was now, I would go for the Gigabyte WRX80-SU8-IPMI (if you managed to get one and need TB support).

How did you change the NPS? I cannot find this option in BIOS. I tried to activate the Game Mode in Ryzen Master to do that, but for some reason, W11 doesn’t want to boot after that.

Headsup I see the wrx80 ASRock creator has a bmc firmware upgrade which mentions a fan fix

It says “The uploaded image is a different version of the existing device firmware”. So there’s likely very little new in the update (sans the “fan fix”)

I finally figured out how to do custom fan curves. It’s not as intuitive as it probably should be, and isn’t easy like a consumer board UEFI with pretty graphs.

First, go to the BIOS under the H/W Monitor section and set fan Control Mode (DC or PWM) as mentioned previously. Leave the rest of the controls as-is, as they will be controlled via BMC UI.

Then hopping back into the BMC, there are 3 control modes for each fan:

1) Default (“auto”/BMC control)
2) Manual (fixed)
3) Customized (fan curve)

  1. Default is straightforward. Let the BMC control the fan based on hardcoded defaults in the firmware. You probably should never use this one, except for the Southbridge / Mosfet fans.

  2. Manual is simply a fixed speed. The “Duty (%)” maps to either Voltage (DC fan) or duty cycle (PWM fan). First set the fan in the mode table above to “Manual”, then adjust the desired fixed speed in the Fan Duty table. Don’t forget to press Save for BOTH tables!

In my case CHA_FAN1 is connected to a HBA cooling fan, so it’s appropriate to run at fixed speed continuously.

  1. Customized mode is the dynamic fan curve, and the least intuitive.

a) First go to Open Loop Control Table and create a new table, in my case “Table 1”. Set the desired temp (C) vs Duty (%) curve. This is our fan curve. Below, I’m setting fan speed in increments of 10C from 40C to 90C.

b) Then go to Temperature Sensor and Corresponding Fan Table and create a new Table. Below, I’m creating “Table 1” (not to be confused with our “other” table 1.)

For the table, select an input sensor, below “TEMP_CPU”. Then select the fan curve we created earlier (in my case Table 1). Then select which fans this customization affects, in this case, CPU_FAN1 and CPU_FAN2.

In my case, CPU_FAN1 is connected to the CPU fans and CPU_FAN2 is connected to a fan hub, which connects the case intake fans. I want the case fans to ramp up with CPU load to give fresh air for the CPU.

c) Finally, go to the Fan Control Mode table and select “Customized”. And voila! Don’t forget to press “save” long the way for each step. Now run Prime95 or other CPU load test and verify the custom fan curves are in effect.

1 Like

Has anyone gotten SEV/SME to work with their Zen 3s on this board? I was under the impression that the TRs had this feature. I submitted a ticket to AMD and they responded that the Threadrippers do not support SEV/SME, but on their product page (https://www.amd.com/en/processors/ryzen-threadripper-pro) it clearly states that they have “AMD Memory Guard” which seems to suggest they do.

Something seems pretty sketchy here… Like AMD changed their minds at some point and told the board vendors to disable it, or did it though microcode. I can’t find anything in the BIOS related to enabling it.

EDIT:

So I emailed AMD and they claimed the Zen3 TRs don’t have SEV/SME support. I also emailed ASRock and they said:

"The current motherboard BIOS does not support SEV/SME

Please stay tuned to our website for the next BIOS update"

Looks like this is a BIOS issues then and ASRock will possibly be implementing it later?