Return to Level1Techs.com

A little teaser of what is to come :)


#609

Incase anyone is trying on ubuntu 16.04 and I think maybe 17.04 might be affected there is a bug on apparmor or snapd that is currently in the process of being resolved


https://bugs.launchpad.net/ubuntu/+source/snapd/+bug/1734038?comments=all
Apparently the issue with snap and apparmor was supposed to be resolved with the latest snapcore version but that is not the case.


#610

just a quick edit on above for ubuntu, the bug is actually on this link:
https://bugs.launchpad.net/ubuntu/+source/apparmor/+bug/1733700


#611

Skip 4.14 and go straight to 4.15 if you need to use AppArmor.


#612

you can do that on ubuntu? how? I could not find anyway on ubuntu to do that.


#613

Use the mainline kernel .deb repository:

http://kernel.ubuntu.com/~kernel-ppa/mainline/


#614

Ahhh, fps is 60 but ups is max 35, on intel gvt-g, what could be cause for that? I tried different drivers,resolution and lg options but UPS wont go above 35. :frowning:


#615

@somenoob Since your CPU has an integrated gpu and it supports gvt-g, you don’t need to pci passthrough it. You should have 3D benchmarking on the guest as high as on the host.
Also, the gpu is shared between them so you can use any graphics program at the same time on both guest and host.
Could you check this?


#616

That is all good, I am sharing igpu, 3d works like it should even quicksync, but I dont have output for vm, so I need Looking glass to work well, even parsec did better than LG.


#617

thanks but 16.0.4 does not support the 4.X train. So Ubuntu 16.04 users will have to wait to use this until apparmor is patched, that being said it might be resolved on 17.10. Also disabling apparmor will not work since libvirt requires apparmor on ubuntu.


#618

So for those ubuntu users out there who are running into the same issue, here is what I found and did:

  1. Follow the steps in https://stackoverflow.com/questions/38799366/using-ivshmem-with-libvirt-virt-manager
  2. if aa-complain gives you an error then comment out line 15 on /etc/apparmor.d/snap.core.3440.usr.lib.snapd.snap-confine, and restart apparmor service

that being said I am running into 1 final issue:
-device ivshmem-doorbell,chardev=ivshmem,vectors=1: ‘ivshmem-doorbell’ is not a valid device model name

This I cannot seem to find much on this, how do I get around this issue?


#619

How old is your qemu? or is IVSHMEM disabled in the Ubuntu build?


#620

QEMU emulator version 2.5.0 (Debian 1:2.5+dfsg-5ubuntu10.16), Copyright © 2003-2008 Fabrice Bellard

How do I check to see if ivshmem is disabled, I put in a workaround in which instead of using ivshmem-doorbell, I have the line:
<qemu:arg value=‘ivshmem,chardev=ivshmem,vectors=1’/>

Also just to confirm, the windows build looking-glass-client is https://looking-glass.hostfission.com/downloads

I ask because when I run the looking-glass-host.exe I get 1 error message. failed to load the NvFBS library: 126 - C:\WINDOWS\system32’NvFBC64.dll


#621

Yes, it’s correct. NvFBC is part of the NVidia driver package, if you don’t have a Pro NVIDIA card (Quadro, Tesla, GRID) then don’t worry. It’s just probing for the best available.

If plain ivshmem works, then your qemu build is broken or old, it has been deprecated and shouldn’t let you select it. The only two valid options are ivshmem-doorbell and ivshmem-plain

Please share the entire commandline section you are using.


#622

this is it after the edit:
qemu:commandline
<qemu:arg value=’-device’/>
<qemu:arg value=‘ivshmem,chardev=ivshmem,vectors=1’/>
<qemu:arg value=’-chardev’/>
<qemu:arg value=‘socket,path=/tmp/ivshmem_socket,id=ivshmem’/>
</qemu:commandline>


#623

there is a chance this could be on version 2.5 on ubuntu 16.04 I having been debating moving to a non lts version which has a more upgraded version of kvm


#624

To get any kind of decent performance you will need to, that’s a very old version of qemu.


#625

aha so using https://launchpad.net/~jacob/+archive/ubuntu/virtualisation to upgrade to 2.6.2 now resolved that issue

Once I get this up and running I will probably have to write a full guide on this for ubuntu 16.04 users


Looking Glass - Guides, Help and Support
#626

OK so all of the ubuntu work is completed, I am running into 1 final issue and that is with the windows client. I have all AV/Firewall turned off.

So I get a command line prpomp when running the looking-glass-host application alpha9 saying
Unable to configure a capture device
An error occured, rerun in forground mode -f for more information
In forground mode after failing on the NvFBC and using DXGI
I get 2 error messages:

  1. ivshmem.cpp:198 | IVSHMEM::GetMemory | DeviceIoControl Failed:658
  2. Service.cpp:72 | Service::Initialize | Failed to get IVSHMEM memory

#627

Did you install the windows IVSHMEM driver?
Is it running already? (Check task manager)


#628

yes the driver is installed, I see in my DM under System Devices it says IVSHMEM Device, also the process is not running, it fails to run at boot as well