Return to

A little teaser of what is to come :)


Pretty much yeah


As long as it’s outputting any signal, it doesn’t need to be digital.


on ubuntu I am unable to run the command:
sudo -u qemu ivshmem-server -p /tmp/ -S /tmp/ivshmem_socket -l 16M -n 8

It says user does not exist

I tried running it as libvirt-qemu but that also got denied
I get the following error message:
cannot open shm file ivshmem: Permission denied
cannot bind

Does anyone know why?


libvirt doesn’t run qemu as qemu, it first runs I believe as libvirt, and then changes to qemu. Try running ivshmem-server as the libvirt user.


It’s official, we now have an IRC channel on FreeNode, the prior owner (gnomethrower) has kindly relinquished the channel to us for Looking Glass.

Join #LookingGlass on FreeNode :smiley:


these are my only 2 libvirt usernames and neither work, I get permission denied on both

libvirt-qemu:x:122:130:Libvirt Qemu,:/var/lib/libvirt:/bin/false
libvirt-dnsmasq:x:123:131:Libvirt Dnsmasq,:/var/lib/libvirt/dnsmasq:/bin/false


It was off the top of my head, an educated guess would say to give libvirt-qemu a try.


I managed to do a workaround using my username, however I am getting the following error message now:
error: Failed to start domain WINDOWS
error: internal error: process exited while connecting to monitor: 2017-12-19T02:58:11.314996Z qemu-system-x86_64: -chardev socket,path=/tmp/ivshmem_socket,id=ivshmem: Failed to connect socket: Permission denied


who owns the file /tmp/ivshmem_socket?


my user account


You need to ensure libvirt launchers qemu as a user that has access to that socket file… you will need to experiement. Nobody has yet documented the procedure for this under Debian/Ubuntu.


@wendell, you should mention this in the news tomorrow! I find this information very pertinent to maintaining a successful project!


So so far has only the testing been on fedora?


Nope, I run Debian… but I don’t use libvirt, and I don’t have time to write documentation like this and develop the project at the same time. If someone want’s to write a guide then sure!


Ok so I think I found some confusion
On the quickstart guide, if I go to this link (which is the ubuntu guide), and click on Configuring libvirt for Looking Glass
It takes me to
However if I click on Configuring libvirt for Looking Glass on the guide menu, it takes me to this link:


Ahh! someone made an error when linking, thats the fedora one… I have fixed it, thanks!


Thanks m8


what does this mean for people who has an eGPU setup that uses 4Gbps mPCIe or expresscard?
will we get better performance with limited bandwith ?


It depends on your resolution and target refresh rate, this tech is too new to give a definitive answer.


I just tried it on intel gvt-g with i5 7200u, it works very well.