32GB of ram installed but 15.9 useable?

I can’t see where you went wrong. Low profile, 15 CAS, 3000 MHz kit. Should be good for 2666 at 32gigs.

I never underestimate the Ryzen gods. I wonder if the Windows /UEFI handshake is where the memory is lost.
Better bet is the ram would work in 6 out of 9 other Ryzen boards or CPU combos.

I had the same nightmare with my 1700, turned out to be a bent pin on the cpu which was easily fixed (thank higher being).

Frankly I was amazed it posted at all with the pin bent that way… but it did and just gave me funky memory issues.

I now have 32gb running at 2800mhz (kit is 3000 but wont post at that speed).

all in all, very happy with my 1700, hope you are experiencing similar awesomeness.

I could not see it on the QVL list.

I found CMK16GX4M2B3000C15 all right but not the 32gb kit.

Yes, I am amazed that your CPU worked with a bent pin. When I re-seated mine I checked and it all seemed ok, didn’t look like there were any bent pins. Glad to hear yours is working well though =)

Oh I see if you search for CMK32GX4M2B3000C15 , it does indeed say a 16GB size despite the 32 in the model name, I wonder if that just means that it doesn’t matter how many dims you put in 16GB is the maximum supported with this kit.

It does have the dots in the columns that suggest you could have 1/2/4 dims installed, so that’s also confusing as it would suggest that my setup should work, but then why have 16GB in the size column and not have the multiple as it does against other sizes in the list.

I wonder if should have just done my research first and got a kit from that list which had 32 in the size column

I wonder if I hold out for another bios update it’ll perhaps support my kit?

Yeah I didn’t appreciate what a dark art memory compatibility and ryzen is , the BIOS reports two 16GB modules, and then says the total memory is 16GB so maybe it’s the UEFI itself? I can hope for an update in the future to support my full kit? who knows.

It looks and sounds like a pin or socket issue.

Does Asus have DCOP settings on Prime boards? If it does, select the DOCP speed and check in the manual settings if the MB is recognizing its XMP profile correctly and posting proper timings in UEFI, also voltages. I am not saying to try to post at this, just if the ram is even recognized properly.

Yes, the DCOP checks out though as you say, it won’t post at those speeds.

Download and run this utility. Then post a screenshot. It is a mobile version so will not permanently install. It could be SPD corruption though doubtful, this program in advanced version could tell you that.


Hmmm windows defender says that file has a trojan in it, “Win32/Fuerboos.A!cl” is that a false positive?

It probably shows that for what it does. It is a common utility that is used to see if ram contained Samsung B die to help purchasers seek such ram in early days of Ryzen. We all used it at Overclockers.net without issue. It is a new link because the old one is dead because it is a updated version. Same local.


Could you try going to DRAM Timing Control and disabling DRAM Training or w/e it’s called in the X370-series BIOS. At the bottom of the DRAM Timing Control submenu.

I had a similar problem with 2 different sets of Corsair quad channel DDR4 on my X99-Deluxe that would work properly with the retailer’s test bench memory but not on either of my Corsair kits.

Hmmm can’t seem to find anything that looks like training in the ram menu sorry

There is a setting there that ignores errors from memory training. If you can see all sticks properly by ignoring the errors it’s easier to deduce if your motherboard is faulty.

Ahhh yes I recall something that looked like that. I’ll try it tomorrow when I get back from work. Thank you for the suggestion!

Sadly I think I’m just going to have to put up with using half the ram until there’s a bios update, thank you for your help! I’ve learned more about diagnosing memory issues.

Have a look at what voltage the memory is currently running at. If it’s 1.2V then according to the Corsair specs they have tested it up to 1.35V.
In order for my slightly older type of memory (CMK32GX4M2A2666C16) to run stably I had to raise the voltage from 1.20V up to 1.30V, using the same model of motherboard. Not that I’ve specifically experienced halved reported capacity, but anyway.

Other than that, the next BIOS update should not be too far off.

I’ve tried manually setting it to 1.35V as it suggested but still no luck! I think the 16GB number on the qualified list is just going to be the max I can use for now.

Thank you for the suggestion

Well what crack now with it? Did you get the issue resolved?