32GB of ram installed but 15.9 useable?

Hello there, I’ve recently built a new PC and despite the BIOS and task manager understanding that it has two 16GB sticks of ram it will only appear to address slightly less than half of it. This is reminiscent of the old 32bit problem, but apparently windows 10 home limit is 128GB .

memory wut


what I’ve tried

re-seating the ram, changing the configuration of the ram, trying every combination of both for the 4 slots.
clearing CMOS
updating to the latest bios
praying to the tech gods.

every other form post I’ve seen from my search, one combination of the above fixes it but apparently I’m just lucky.

Is there anything simple I’m missing?

unfortunately as it’s the only DDR4 system I have I don’t have another kit to test to see if it’s that, other than spending money on another kit just in case it’s that I’m not sure what else I can do to diagnose the problem.

Thank you in advance for your time and consideration!

Can you take 1 dimm out and boot then do the same for the other dimm to check they are both recognised in windows individually.
Which dim slots have you put them in alternate or next to each other?

The manual says put them in slots 2 and 4, though I’ve tried every combination and swapping which I put in each, the results being either not posting or the same.

I’ll try another clear cmos and try each stick individually now,

thank you for your suggestion.

Hmmm doesn’t seem to want to post at all with just one stick,

but other than only using half the memory it seems to work flawlessly with two sticks.

perhaps it’s a motherboard issue? perhaps I’ll try regressing to a previous bios.

Are both sticks identical? And by identical I mean they both came in one 32GB kit. I had some trouble with two “identical” 16GB kits being unstable. I had to drop the XMP speed a bit before they’d play nice together.

Is the XMP profile enabled in the UEFI? The fact that the memory shows up as “unknown” is probably not good. The speed might be OK, because that’s close to half of 2133, the base DDR4 speed.

I’d verify which slot a single stick is supposed to be in and test each individually. Run memtest86 for a few hours on each module.

yes the two sticks are part of a dual channel kit.

XMP is disabled, if I turn it on it won’t post at all.

the single stick slot is slot 2 according to the manual, and with either it won’t post with one stick in that slot or slot 1 (I thought I’d test slot 1 anyway)

apparently the internet updater on the bios only updated the firm ware to 810, I’ve manually downloaded 905 and installed that, but still the same issue =(

Will it post with one or two sticks in slot 3 and or 4?

That screenshot says 32GB dual channel “unknown.” This leads me to believe it’s the memory, itself.

Try creating a live usb of fedora or some Linux distro and see what it shows for memory when you run free -h

Sounds like bad RAM or maybe the CPU needs re-seating as the system should post with one stick in slot A2.

weirdly yes, despite it saying that the second slot away from the CPU is the one for a single stick, I’ve gotten back to windows and it seems to be working fine with a single stick in slot 3

Strangely it doesn’t boot with a single stick in A2 but it does in B1

and I’m not posting from B2, I’ll try the other stick now in B1 and see if that boots

Try reseating the CPU like @billgatez suggested. While it’s out check for bent or missing pins, unlikely but possible. You might also check behind the motherboard just to see if anything is shorting out. Standoff in the wrong place, anything. Small chance, but you never know.

If it still does it, run memtest86 on each stick, one at a time, in whichever slot will let the system boot. This will help determine between a bad stick or a bad motherboard.

Now posting from Stick 2 in slot so it would appear that both sticks are at least (mostly functional)

I’ll now try re- seating the CPU

Ok putting both sticks in 3 and 4 lead to the the system recognising all of the ram yay! but then it crashed.

put the two sticks in the recommended 2 and 4 and reseated the CPU -> back to the old 15.9

definitely zeroing in on the problem =) thanks guys for all your suggestions

I’ll now try memtesting each bank individually

The windows memory diagnostic tool, I’m not sure how thorough it is but it found no errors in the memory

It would appear that I can recognise all of it if I have it in B1 B2 or slot 3+4 but then it’s in single channel mode

If I have it in the suggested A2 B2 ( 2 + 4) then I get dual channel mode but only half of the memory is recognised.

What vendor is your ram from? Do you know if it’s on the QVL?

the ram is corsair

vendor code:

and it does appear to be on the QVL