Return to Level1Techs.com

ZFS on Linux, version 0.8.3 released (with SIMD) fixes

  • Linux 5.0 compat: SIMD compatibility

Looks they’ve managed to get things in order prior to the next LTS debian/ubuntu window closing.

That said, it’s always a good idea to let others shake a release down for a month or two before committing your own data.

6 Likes

Excellent. I’ll give it a go this weekend.

1 Like

im updating meow! (my alternate machine; not my primary one

image

I can’t hear you over the sound of me shipping this to my production machines.

6 Likes
5 Likes

after rebooting…

image

Zfs module wouldn’t load

1 Like

huh, issue tracker says CentOS and Fedora 31 DKMS had issues… for two users at least

1 Like

I was F30… just kicked off upgrade to F31…

so make that 3 users!

image

1 Like

Got it working.

dkms is still fucked tho.

image

1 Like

cries in production

Hi everyone,

thought that I’d start a question here.

I am running Fedora 31, kernel 5.4.13-201.fc31.x86_64 and I installed ZFS 0.8.3 by following the instructions @ https://github.com/zfsonlinux/zfs/wiki/Fedora. However, the zfs modules never load.

[[email protected] ~]$ zfs status The ZFS modules are not loaded. Try running '/sbin/modprobe zfs' as root to load them.

I am not sure how to deal with this. I have tried dracut -vf --kver uname -r but I do not see that zfs modules get included. Does anyone have any ideas? Is there a way for me to get the older ZFS version?

Output of cmd

dkms status

Hi @nx2l,

I just tried a fresh install in a VM but the results are the same as a physical system.

[[email protected] ~]$ dkms status zfs, 0.8.3, 5.4.13-201.fc31.x86_64, x86_64: installed

[[email protected] ~]$ zfs status The ZFS modules are not loaded. Try running '/sbin/modprobe zfs' as root to load them.

I also tried installing zfs on PopOS 19 and am not having any trouble. That said, I would really like to get everything working on Fedora because not ready to distro hop just yet.

Did you do modprobe zfs?

It does laod when I do modprobe but I just can’t get it to load automatically on reboot. I don’t think that it is the intended behavior but Is that intended?

[[email protected] scripts]# lsmod | grep zfs
[[email protected] scripts]# modprobe zfs

[[email protected] scripts]# lsmod | grep zfs zfs 4239360 0 zunicode 335872 1 zfs zavl 16384 1 zfs icp 311296 1 zfs zcommon 98304 2 zfs,icp znvpair 94208 2 zfs,zcommon spl 131072 5 zfs,icp,znvpair,zcommon,zavl zlua 176128 1 zfs

Currently loading it on arch. Let’s see how it goes.

@catsay

Loaded Fedora 30 VM. Same story the modules just don’t load.

Did you create a zfs target?

No. Is that a requirement?

It seems to be working on PopOS 19 just after following the install instructions. The pools seem to survive reboot as well except for the first time where I actually had to run zpool import zp0

[email protected]:~$ uname -a

Linux pop-os 5.3.0-7625-generic #27~1576774560~19.10~f432cd8-Ubuntu SMP Thu Dec 19 20:35:37 UTC x86_64 x86_64 x86_64 GNU/Linux

[email protected]:~$ cat /etc/debian_version 

buster/sid

[email protected]:~$ zfs list

NAME USED AVAIL REFER MOUNTPOINT
zp0 636K 5.28T 96K /zp0
zp0/movies 96K 5.28T 96K /zp0/movies
zp1 1.28M 3.51T 60K /zp1
zp1/music 60K 3.51T 60K /zp1/music

Hi @catsay,

did you have any luck on Arch?