Yubikey with nfc help

I’m trying to add my yubikey to some of my accounts. I have a regular USB a nano for my desktop PC. But I thought I would get an NFC version that I’d keep on my keychain since that’s practically always with me.

And it seems to me that NFC doesn’t work for me. If I use a NFC tools type of app on my phone, it can detect the key. But outside of that, I can’t use use NFC with my phone to log into twitter or git hub for example.

After logging in with email and password, it asks “Choose how to use your security key”, and when I choose “Use security key with NFC”, the next screen says “hold your key flat against the back of your device until it stops vibrating” (it doesn’t vibrate at all). And with this hassle, I’m kind of just thinking I should have bought a USB C nano instead, or maybe just the USBC+nfc.

On PC, it requires that I press my finger on the gold circle. Sooo is NFC is not working because I can’t touch the gold circle ( as there is no power when not connected to USB A). This doesn’t sound like how it should work but I don’t know what else to assume.

For what it’s worth, I have a oneplus 7 pro. NFC in general works as I’ve been able to pair peripherals with nfc. But this is the first time I’ve ever tried a security key.

You don’t need the gold circle when using NFC, all you need is to bring it to the sensor and it goes “bloop” and vibrates for a second.
Having said that it is a bit screwy on Android.

Try logging in to something in browser, Chrome if you use it just to rule out OS/hardware level issues.

Try rebooting and having NFC on before you go to authenticate.

See if your phone detects it without apps, just with NFC on. Bring it close to the sensor and it should vibrate and complain about unknown tag.


You can also try and download YubiKey Manager and check if NFC has U2F enabled, could be that too. IIRC USB and NFC can have different protocols enabled.

1 Like

Thanks, it finally worked… but I’m thinkin I’m probably just gonna get a USBC version. Save myself a little hassle.


Just a bit screwy I guess :slight_smile:

1 Like

It doesn’t poll the NFC instantly. It only polls the Yubikey every so many seconds. So, you just have to hold it there until it gets scanned. Might take a few seconds. I have the same phone and key, and I have the same issue. Appears to be normal behavior. Just be patient with it.

1 Like

Keep in mind that the YubiKey is 100% powered by the NFC transmission. It needs to power up its controller from zero and then respond to the request from the phone. You need to hold it still over the NFC area on the phone. If you move it, it can lose power and has to start again

1 Like

I think the main problem was I wasn’t 100% sure where the zone was on my phone, and with my keyring and case, it made it hard to get into position without removing it from my keyring.