YouTube Video Processing - 4k still stuck 360p a day later... :(

I produce a lot of 4k content for YouTube and today I’m witnessing a strange issue worth documenting.

Yesterday I uploaded a 20 min 4k video to YouTube… I think that went live around about 6pm. Normally a video like this would be available in it’s original 4k resolution in a matter hours, but not this time. A day later my video is still stuck at 360p resolution… and it gets weirder.
Some of my YouTube fans couldn’t view the video at all this morning! What’s going on! The video was working last night, although I don’t know what resolutions where available.

The video I uploaded was a regular H.264 file preset. I’ve used it without issue for about a year now.

I’m preparing slightly different replacement video file to re-upload. Hopefully YouTube will fix itself before I have a new version rendered and uploaded

This may be related, I get this when I tried to play your video on the forum
Other YouTube videos play fine in the forum

Yeah, that’s something to do with it.

On YouTube when you click on the resolution gear there’s 360p… and “Missing Options?” When you click on missing options it takes you to a page saying your browser is the problem… however, I get that same error message using Google Chrome.

I’m thinking YouTube borked something, maybe try re uploading?

1 Like

Agreed. It will take a while due to the size, but I am doing that now.

That sucks since you’ve already gone through this but I can’t imagine anything you’ve done that could cause that.

Disclaimer: I don’t upload videos to YouTube I’m just a shit poster

Using Firefox quantum on windows 7 it runs but it is in 360p. Share the reupload to check again. Probably the new way youtube will treat videos it doesn’t like. This is not confirmed I just pulled it out of my ass but I will be not surprised if they do it.

1 Like

I see this error all of the time when I’m not using Chrome on Windows. I don’t want to draw any logical conclusions which could be interpreted as me making any accusations.

Try to encode the raw video in different software if you can. The pattern I usually see with this error is that certain browsers and versions of Flash or the equivalent will only let you watch it in very low resolution for the first few days or even 1-2 weeks.

I used to watch Tek Syndicate videos in 360p on their upload dates all the time. After a week, they would suddenly be 1080p/1440p/2160p. Sometimes on other channels, I would get the error. Other times, it would be low quality for a short period of time.

Yeah, for some reason some videos will not encode in VP9. And unfortunately that’s the default now. The reason it’s only 360p is because that’s the VP8 encode! Somehow, your file was not encoded in VP9.


Got that too🤔

For reference here are my video encoding settings.
I know from previous experience YouTube won’t accept duplicate video files (YouTube automatically deletes them), so on the second render I ticked the “Fast Decode” option. In theory this shouldn’t do anything but make my video file larger… hence making youtube think it’s a new video.

Anyway, the second render is uploading now… (fingers crossed)

1 Like

No idea why youtube is behaving like that on this upload but I did enjoy the video anyway. I’m a relatively new gun owner myself and it was a good food for thought video.

1 Like

Hallelujah!!! The video make it to 720p!


So the YouTube video processing is taking ridiculously long, but it is working. I notice the embeded video plays in this forum as well without a problem.

I’m aborting my second upload.


Forgot to clarify but I’m on mobile and still get this
Definitely some YouTube fuckery

Yeah, that’s the H.264 720p MP4. It still hasn’t made it to VP9 encoding at all.

If it helps you feel any better, his stories make me want to invest into a small arsenal. The content is high quality. :rofl:

What browser do you use ? And os and version?
I am on android 7.1 with Firefox quantum and it plays the video nicely.

A post was split to a new topic: YouTube Help