XCP-NG Intel NUC 11

Hi all,

Finally got my intel NUC 11 after being on backorder for what seems like forever. I tried to install XCP-NG on it but when the installer loads i’m presented with a black screen with a white cursor. For what it’s worth I’ve done a bit of googleing and most suggestions revolve around booting into legacy BIOS which the NUC 11 cannot. Any suggestions would be greatly appreciated.

Thanks!

Efi mode works fine for me?
https://xcp-ng.org/docs/install.html#iso-installation

It’s an issue with the NUC 10 and 11. It doesn’t even manage to show the grub boot menu.

The answer on the forums is, as you said, to use legacy mode. When that worked they didn’t care anymore. They might actually have to look at it now as more companies start to remove the Legacy BIOS mode.

I also tried with a Xenserver 7 image from xenserver dot org and it has the same issue on my i3 NUC 11.

maybe try ventoy? It’s like a chain loader. You put ventoy on a usb and it can load an iso. so ventory works, it’ll then load the xcp installer. sounds crazy but it’ll probably work. just copy the iso to it.

you may also need to disable secure boot since that might be interfering, come to think of it

I have the xeon nuc and it worked fine

2 Likes

I gave Ventoy a try and funnily enough it’s boot menu appeared perfectly. As soon as I selected the XCP-NG ISO from the list it went to the same black screen with cursor as before.

Secure boot was the first thing I checked was off. Every other distro/usb boot I try on this machine works just fine.

1 Like

I hadn’t heard of ventoy, that’s awesome.

Just an update on this, a dev on the XCP-NG forum has found the answer.

Turns out there were some bugs that meant 64 bit UEFI framebuffer addresses could never work as they got passed to the Linux kernel as truncated 32 bit addresses.
The fix in the past had been to force people to use CSM mode in the firmware.

There is now a test iso on the XCP-NG installation forums that fixes the issue and should help a lot of machines that weren’t working with UEFI boot once it goes into a released version. I’m very happy to have my NUC 11 working at last.

3 Likes

thanks for the post - good to know why and that there’s a workaround. Any chance you have a link to the specific test ISO that worked please?

For those looking:

There has been activity within this month on this issue in the GitHub repo, hopefully it will eventually get into nightly, then into main iso builds.

Alternatives:

  • The drivers for vga appear to be in the full install-- so if you install XCP on the drive using UEFI on a different machine and then put it back in the NUC-- that has been noted to work. But I used the custom iso and didn’t try this.
  • Some users had success using console redirection. (I did not have success with this.)

You may need to use caution with upgrades while on the custom patch.