Return to Level1Techs.com

X570 Phantom Gaming-ITX/TB3 Waterblock compatibility

Hi all,

First time poster here so nice to meet you all.

After watching Wendel’s TB3 video on AM4 I decidec to get the Asrock ITX board and a 3950x.

The board is great and the cpu can do 4.3 stable on 1.3v with temps on VRM’s mid 60s and CPU high 70s under full in Adobe Media Encoder.

I have also bougt a QNAP QNA-T310G1S 10GB/S SFP+ card which runs over TB3 so I can make use of my my full 10gb/s home internet connection instead of being limited to the onboard 1gb/s NIC.

  • One issue I experienced with the network adapter was that after every reboot of windows I would have to physically unplug the thunderbolt cable and plug it back. The workaround for it to be detected after every reboot was to disable security in the bios thunderbolt settings.

Now my question for you guys as I want to do a full custom loop:

This board uses 1151 mounting holes for cpu cooling and I am unsure of what waterblock will fit, it looks quite a tight fit around the socket. Today I have a Corsair H100i which fit’s no issues.

So anybody ever put a waterblock on the motherboard ?

Looking forward to hearing back from you all :slight_smile:

Oh and here is a photo of my build:

hey there! Welcome!
So, one question:

What motherboard?
Is it the system listed in your profile of something else?

I am going blind, it seems.

Presumably the one in the thread title :wink:


Check out the websites and/or contact the support of the companies whose blocks you are looking at. Sometimes they’ll have fitment lists for the blocks.

Thanks guys :slight_smile:

Just fired of a mail to EK support to see what they have on offer for this board as there configurator seems to be wrong and shows me a list of AM4 waterblocks. Will post back and let you know when I get some news.

Edit: After a bit of searching I have come across this photo on Instagram of a Bykski CPU-XPR-A-MG block, looks to be the perfect fit: https://www.instagram.com/p/B0IjKK5gg-h/?utm_source=ig_web_copy_link

Any idea how 115x block perform on the new AMD chiplet design ? I suppose it couldnt be any worse than a H100i ?

Hey man, did you finally install a block?

I have the same mobo. And went with the following.

Corsair XC7 cpu block
Corsair XG7 gpu block
Corsair XR5 radiators (240mm and 120mm)
Barrow mini pump res
Ryzen 9 3900x
2080 Ti
Nzxt H200i

The GPU block works great. 52-57c under load.
The CPU temps are HORRIBLE, 90++c under a Cinebench R20 10min run. I’m now running my 3900x in Eco Mode with SMT disabled. I’m guessing it has to do with the cpu mount. I’ll take it apart again next week, and before that wanted an opinion.

BTW my previous cpu cooler was the H100i as well. And it kept things at 70-72c max under load too!

Sorry for the late reply, I installed the EK-Velocity, temps are not brilliant, if I unlock power limits then cpu will be around 90c whilst pulling 200w with a single 240mm rad and fans on full.