X570 master no power?

Shut my computer down last night and it started the process then hung. Forced shut down by holding the power button. After it shut down, I rebooted and then shut it down normally - all seemed fine.
Next morning the pc will not turn on at all. no led’s on the mobo.
tried the PSU fan test button - fan spins fine, so psu has power.
tried the BIOS dip switches - nothing
tried cmos reset - nothing
tried removing RAM, and GPU and HDD - nothing
tried different plugs on the PSU - nothing
tried different power cable to psu - nothing

I think the mobo is dead (the hell if I know WHY though) but warranty process is a pain here so are there any other things I should try before sending in for warranty?

system specs:
AMD 3800x (not overclocked)
GSkill 3600mhz 16gb x2
adata 1tb ssd (SATA not M.2)
GTX 1080
Corsair HX1000i psu
Gigabyte X570 aourus master
corsair link
corsair h150i pro CLC
Win 10

Whole system is only 4 months old.

Still this does not really tell me if the psu is still good or not.
If you have a second psu laying around,
then that would be the first thing i would try.
Or test the psu in a different system.


Take another look at PSU - swap the PSU for another if possible.

Last time I had a PSU fail it was less than 6mos old and I was like, Really? and was refusing to believe because of some of the same reasons - it had a fan test button - and Fan spun. It showed voltage when reading with a meter - even had LEDs on main board but no fans would spin when powering up and it would immediately shut off. I was sure it was main board or CPU… I finally drug a PSU from another machine over and it started right up… That system is still going strong 3 years later.

I feel for you and hope you get it sorted out. You have a nicely spec’d system - good luck!

1 Like

Managed to get a hold of an old PSU that i know works. I only connected the 24 pin cable, but still did not power on at all - not even any of the onboard LED’s, no fans, nothing.

Just tested the PSU from my new system in a friends PC - it starts and runs fine - so I am pretty sure the PSu is not the issue.

I have some comments but I am not here to drill you - just hoping to assist. First - the 24pin only is not a test you need to also plug in EPS (CPU) power. 24pin only will not work. When you swapped your PSU into friends PC - did you use your same cables from your PSU (24pin and EPS) ? You want to rule out a bad cable.

At this point (its some work but needs to be done) you’ll want to remove possibilities that there are no grounding or shorting issues and this will involve removing the guts from your build and doing some bench testing using the minimal set of components needed to verify CPU/Motherboard/PSU at first. Then slowly working your way back up.

Put the board on the box it came in to use it as a make-shift test bench.
Socket the CPU and cooler plugging a fan into the CPU Fan Header. For this test use the stock cooler if your CPU came with one - Double check that CPU is oriented properly. Line up the little triangle on the chip with the one on the socket. The Chip should just fall into place without and pressure applied. Close the lever.
Install your Ram - make sure its properly seated.
Install a GPU - make sure its properly seated.

Make sure the rocker switch on your PSU is in the off position

Plug in the 24pin from PSU to the board make sure its fully seated - both PSU side and Motherboard.
Plug in a EPS 8 PIN (4x4) to one of the EPS headers. (Only need to use one) Make sure cable is fully seated in both PSU and motherboard
Plug in PCIe power 6 or 8 pins to the GPU depending on your cards requirements.
Connect graphics card to a display
Turn on display

Power on your PSU

Press the Power button on the motherboard
IF everything is alright she should boot to a post screen. Your CPU fan should be spinning, The lights on the IO Shield will light as well as the debug readout and diagnostic LEDs and LEDs for the bios (indicating which bios is active)

This should help to verify that CPU/Motherboard are good. - If it doesn’t still - then I would actually pull the CPU from socket check for any bent pins etc and then re-seat it , remount cooler and retest. (may just want to do this step first actually as step 1 above)

If it still doesn’t power/on post I would still try using a different PSU / cables just to be sure - IF same result then I’d probably try the same setup using a different motherboard.

IF it does Post - then you will want to start adding the rest of your components back to the setup (still outside of the chassis) one at a time (powering off completely, add component, power on re-test) until you have all components back in the test setup as you used in your chassis, and system is powering on running as expected.

Before adding things back into the chassis you want to double check that your motherboard standoffs are positioned correctly - that none of the wires for fans etc have obvious signs where they may have been pinched etc etc. Just the common sense stuff.

You could just try replacing the motherboard first but you pretty much have to tear down your system anyway to do that so I feel its worth the time/effort. Especially if you go through all that (replace mobo) and you end-up with same issue -

1 Like

Apologies for the late reply, but I wanted to try everything properly first.

  1. Tried PSU from my new system in my old PC, with everything hooked up. Runs fine.
  2. Tried PSU from new system in new system on a test bench, no power to mobo at all, no led’s, no nothing. Fan test on PSU works fine.
  3. Tried old PSU in new system, still no power to mobo at all, no led’s - nada.
  4. Tried new mobo with new PSU with nothing connected. No gpu, ram, cpu or anything. No led’s light up at all. PSU fan test still works.
  5. As above with old PSU - same result.

I dont have access to a different CPU or RAM to try in my new mobo, but at this point I’m convinced that its the mobo.
I dont have access to different cable for the new PSU, but as it runs my old pc just fine, I’d say the psu is not the issue.

1 Like

sounds likely, so that would be an rma.


This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.