X520 82599ES: Unable to allocate bus resource: memory

Hi Community!

I’m using a Intel X520 Dual SPF+ Nic on a SuperMicro A2SAV with 8 GB of RAM. I’ve installed TrueNAS-12.0-U8.

In the network interface list I’m not seeing the network card and when checking dmesg I see following messages:

lo0: link state changed to UP
ix0: <Intel(R) X520 82599ES (SFI/SFP+)> at device 0.0 on pci9
ix0: Unable to allocate bus resource: memory
ix0: Allocation of PCI resources failed
ix0: IFDI_ATTACH_PRE failed 6

The error message indicates some sort of issue with memory, but I suspect it’s not about the system memory. I did some google searching and the card seems to be either not supported or there is some bios setting that I could change, however I didn’t come to any conclusion.

Any tips and hints on what to try or debug?

1 Like

I have an X550-T2 and to make it work I needed to go into the UEFI and activate ARI support and set it to enabled, and I needed to set the kernel parameter pci=realloc. After setting the kernel parameter you need to regenerate your initramfs or distributions equivalent of that. Then your NIC should work an be able to use its SR-IOV capabilities. Please let me know of this was of help to you.

1 Like

I needed this as well to get my x520 working on an older x99 based system.

1 Like

Thank you both for your tips so far. I’ve tried following:


  1. Adding: hw.pci.clear_bars=“1”
  2. Adding: hw.pci.clear_buses=“1”
  3. Adding: hw.pci.realloc_bars=“1”
  4. Updating BIOS to 1.2c

So far I was not sucessfull. The BIOS update introduced however another problem:
sdhcipci0-slot0: controller-timeout which I was able to resolve with hint.sdhci_pci.0.disabled="1" in /boot/devices.hints.

The Intel card however has still the same problem.

Did the card previously work in the system? If you boot something like the Ubuntu desktop live image, does it work?

Can you try a different slot?

Intel removed the card from their Windows driver package, but that’s not going to affect *nix, unless Truenas is doing something funky with driver modules.

I don’t have any other troubleshooting advice.

Does your BIOS have a “Above 4G decoding” option that you can enable?

Yes it does, but that didn’t help either.

Did you set the kernel parameter and UEFI option as I asked. If so did anything change?

I would also trying to add some more RAM first. 8GB is very low for truenas and the Intel NICs seem hungry for it. If you have a number of PCIe devices, then they, along with the OS/ZFS, might be competing for allocation.

Edit: I might be totally wrong about how all of this works, I am just guessing.

Edit2: OK I might be totally wrong but do try with more RAM if you have available.

It also seems like it could be a BIOS issue. Make sure you are on the latest BIOS version. Similar issue with HP microserver: https://jira.ixsystems.com/browse/NAS-108878?page=com.deniz.jira.similarissues%3Asimilar-issues-tab-panel

Unfortunately I did all of that already, however the mainboard supports only 8 GB maximum.

Yes, see my previous post.

Sorry I was wondering what you did there. I just understood that you seem to have installed TrueNAS bare metal, am I right? The the kernel parameters I provided won’t work because you have a system based on BSD. I think you figured as much, since you seem to have adopted the parameters. At least following the BSD hardware compatibility list the NIC should work. Maybe you should ask in a BSD related forum or mailing list. I personally, and it seems most people on here, only have limited BSD knowledge. My personal experience with the X550 was based on a Linux host.

If you search for “Unable to allocate bus resource: memory” you will find some posts on netgate or truenas forums, both are BSD based and might be of help.

Just as a last troubleshooting step, I would temporarily try to disable any PCIe devices I could through the BIOS and see what happens.

Also, it seems like your PCIe slot is a PCIe Gen2 x2 electrically, I am sure that the Intel NIC doesn’t like that at all.

Edit: One last thing. Try to disable all C States and power saving settings as well.

Thanks for all your help. I think at this point it’s probably a limitation of this (old) mainboard. Currently I’m running it using the built-in 1 GB NIC, and I’ll try all the suggestions once I get to it.