X399 Taichi NVME not in /dev

I’ve a new system with an Asrock x399 Taichi mobo and a 480GB Adata XPG PCIE NVME M.2 drive. I want to load Ubuntu Mate 18.10. The system boots from a thumb drive, but I don’t see the NVME drive. When I look in /dev, there are no nvme devices listed, and lsmod doesn’t show an nvme module. Any ideas?

Is the drive seen by the UEFI? It should show up under the Storage page.

Also what m.2 socket did you install the drive in?

The 2 480GB ADATA nvme drives I see on the QVL for the Taichi are ASX8200NP-480GT-C and AGAMMIX S11-480GT-C is yours one of those?

It’s the AGAMMIX. I tried all the sockets. Right now it’s on M.2 1. That’s the one closest to the top of the board. I’m getting an error in dmesg flailed to set APST, and consequently, /dev/nvme0 doesn’t get created.

And yes. It shows up on the storage page.

I have just build new system with TR 1950X + 128GB 3000 Mhz (8x16GB) and 240 GB ADATA SX8200 M.2 NVMe SSD.

I have the same problem with Ubuntu 18.04.1 LTS. Installer don’t see my disk.
I have installed Windows 10 1809 without any iproblem.

I have one system build several months ago with Samsung Evo 960 250 GB and there was no such issue.

BIOS: P3.30 (CSM disabled)
Ubuntu installation USB created with Rufus as always in GPT UEFI (non CSM)

Have you tried putting the drive into another socket?

I think on the X399 Taichi the m.2_1 slot is shared with the U.2 port, so maybe try the m2_2 or m2_3 socket. Maybe Linux is seeing the U.2 connector and somehow this is disabling m2_1? Just a guess.

It also seems there might be some issues with the kernel 4.15 Ubuntu 18.04 ships with and NVMe drives. This looks very relevant, https://bugs.archlinux.org/task/57331 and https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1759893

The bug reports are saying to add the kernel flag ‘pcie_aspm.policy=powersave’ to fix the issue, but I’m not 100% sure how you could do this for the installation medium. Maybe press E at the boot menu and manually type in the option? I believe the Ubuntu installer has GRUB so you can add a kernel flag at boot time.

It is in M2_3 right now. Tomorrow I will try with M2_1 and M2_2 slots.

With Samsung 960 Evo in two previous systems, I have used M2_2.
Maybe it has something to do with ADATA beeing NVMe 1.3 vs Samsung 1.2 ?

P.S. I hate Linux because of that :stuck_out_tongue:

You could also try a different distribution that uses a newer kernel, maybe you would have luck with that. It might be that kernel 4.15 doesn’t like that drive for whatever reason.

I think we need to disable APST. From what I can tell, it’s one of those lingering kernel bugs that gets fixed then broken over and over. There may be a command in sysctl.conf to turn off APST. So that can’t be done in the iso. Someone suggested pressing E at tee boot menu then adding pcie_aspm.policy=powersave top grub.conf. Then I should be able to format the nvme drive, after which it may become available for installation. At least that’s the plan. I’ll let you know if it works.

What I have found:

Debian 9.6 have no problem with recognizing and installing. FFS

Any news?

Today I have installed Ubuntu 18.10 on three Ryzen 7 1700 + ASRock B450 Pro4 + ADATA SX8200 systems just like that. So it seems that X399 Taichi and ADATA SX8200 don’t like each other.

Still waiting for any help.


Seems like command nvme_core.defauly_ps_max_latency_us=0 works !

You need to edit grub and put above after “quiet splash”. Next you will have to make it permanent by editing grub config file:

sudo gedit /etc/default/grub
Change line GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash” to GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nvme_core.defauly_ps_max_latency_us=0”
Save and exit.
sudo update-grub

1 Like

I returned the system. Now I have an Aurus Elite X570, and it works much better. It has it’s own problems too, however, but I can live with them.