Return to Level1Techs.com

X399 Fatal1ty not recognizing Crucial ECC UDIMM in memory slots A1 & A2

Hi everyone,

I just returned 2 ASRock X399 Professional Gaming boards along with 2 AMD Ryzen Threadripper 2950X because no matter what I tried I could not get the motherboards to recognize ECC, UDIMM Crucial memory (https://www.crucial.com/usa/en/ct16g4xfd8266, 64GB, 4x16, ECC, UDIMM, CT16G4XFD8266, Crucial 16GB DDR4-2666 VLP ECC UDIMM). Both motherboards and processors were brand new. The motherboards were running BIOS version 3.5P. I tried the following:

  1. Re-seating the processor
  2. Swapping processors
  3. Clearing CMOS
  4. Removing and Re-installing the CMOS battery
  5. Flashing BIOS again
  6. Re-seating all memory
  7. Trying different compatible crucial DIMMs that work in other boards

No matter what I did I could not get A1 & A2 slots to be recognized in bios. The boards would recognize the same memory in all other slots. This is very strange. It is especially strange that 2 boards in a row have this issue.

ASROCK support told me that this is probably a board issue and had nothing else to suggest. I asked as to whether if given a serial number, there is a way to determine if the boards were part of some bad batch. The answer was no.

Am I doing something wrong here? Did anyone else experience this sort of issue? I really like the x399 Fata1ty board because it has the 10GB NIC. But now I am pretty anxious about ordering more parts.

You can mail it all to me and I can try and work it out. It should be fine? You using both CPU power connections? The cpu power wires routed away from memory?

I’ve built a lot of tr systems and haven’t seen this type of thing except from reseating stuff

1 Like

Also double check the cpu socket.
Maybe there is a damaged pin or whatever.

Hi Wendell,

Thanks. I returned the boards before I posted the thread but i would like to order another. So, would it be possible to workout the shipping details when I work up the courage to get another board and CPU? Would you be wanting to see the entire rig or just the board and CPU as this is related to another one of my threads where I am trying to re-purpose a BOXX case (https://forum.level1techs.com/t/repurposing-3dboxx-chassiss-to-zfs-nas-need-cooling-and-front-panel-suggestions/139676)

You using both CPU power connections? The cpu power wires routed away from memory?

I was using both CPU power connections and the wires were routed away from the memory with the exception of the actual 8 pin port which I only mention because I don’t know if that could effect the outcome. I also tried to completely remove the CPU cooler fans leaving just the heat sink. I also tried using only the 4 PIN CPU slot. Same result all the time. PSU mounts at the top of the case but those wires were no where near the memory. Maybe this still make a difference?

I also spoke with ASRock tech support again and they offered to replace the board. They also said that, if the replacement board would not work, then I should check my other hardware, but there is nothing to really check except for power supply and video card which are both working.

Yea I checked the cpu sockets on both boards and I checked the CPUs too. Nothing looked out of place:(

don’t need the whole machine, but would need ram, cpu and motherboard. Do you know what brand of chips is on the crucial? Hynix can be super grumpy. Micron and Samsung generally ok. I understood samsung was what you had, that is what I had, but I wasn’t sure.

I’m chuggling along just fine with 128gb cucial (its in the videos, I forget, micron I think?) and I gave eric raymond the exact same kit of memory and he’s been really hammering his system, and it’s been fine. Gigabyte aorus extreme, designare and Asrock fatality used with those heavily. I have not used ECC with the MSI MEG however yet.

Hey Wendell,

Micron and Samsung generally ok. I understood samsung was what you had, that is what I had, but I wasn’t sure.

It looks like Micron chips. I got 64GB to start with but was going to order more once I got everything going. In the videos you did recommend micron so everything seems to check out on the memory end and all DIMMs are being recognized in a Dell PowerEdge T130 and the memory test on that machine shows no errors.

So now, I guess it would be a choice between the Gigabyte Aorus Extreme and the ASRock Fata1ity because I want that 10gb NIC.

Is there any benefit to going with Gigabyte because I really settled on the ASRock so will try it again once all my returns and refunds go through.

you might boost the voltage to 1.35v, it doesnt hurt anything. And sure, asrock should be fine. The aorus extreme is a newer revision “lessons learned” are in it but the fatality was a really good board

Have you tried this Micron memory with the Aorus? In as far as voltage, not sure about how to do that. Is that something I can do via the BIOS?

Hi wendell,

I figured this one out. It seems that the power supply was dying. Still not sure how it was powering on everything except for 2 slots (coincidece I suppose). I changed the HX850 (i.e., the failing one) to a new Seasonic FOCUS. I also changed the MB and build somewhatt too:

  1. AMD 2700X
  2. ASROCK Taichi Ultimate x470
  3. 64GB, 4x16, ECC, UDIMM, CT16G4XFD8266, Crucial 16GB DDR4-2666 VLP ECC UDIMM
  4. Samsung 970 PRO NVMe
  5. Seasonic Prime 850 Titanium
  6. EVGA 760 GeForce 4GB
  7. Noctua NH-U9S, Premium CPU Cooler with NF-A9 92mm Fan
  8. BOXX Case

So far, so good. The only thing that I can’t figure out yet is whether the ECC is working or not because the BIOS does show the memory as ECC memory.

2 Likes