X370 Taichi Post code d2

Hi, I have just received parts for a new build. After building, I’m getting the post error code d2. This error code is not listed on Asrock’s support site.

I’ve removed the SSD and GPU from the system, unplugged everything besides power, and re-seated the memory. I’ve also tried clearing the CMOS. Nothing seems to change this result. Am I missing something big?

Parts list:
r7 1700 (stock cooler)
x370 taichi
2x8GB G.Skill tridentZ
Asus rx 580
Samsung 960 evo 250GB
Seasonic 850W fully modular PSU
Fractal design define C


Contact ASRock and ask. All I can find so far is other forums with people asking about it.

Reseat your cpu.

Their manual leaves something to be desired.

Try one stick of ram at a time.

I’m going to try doing that now.

Might also have a bad stick of ram.

It is a dual channel kit of ram, I’ve tried the sticks individually. If one is bad then they are both bad.

Rare but possible… remember to clear cmos also

After reseating the CPU and clearing the CMOS, I’m getting weird behaviour. The case fans spin up when turning the system on, but the CPU fan does not. Also, there is nothing being printed to the debug indicators. I think I may have a bad board.

Reseat cpu and ram again, clear cmos. Then ya…rma it. In past it has taken me a couple reseatings to get it right. Make sure the socket is clean. Hit it with some air maybe dust or metal flake. Assuming the pins are okay on the cpu.