Would an out of date Bios lead to a black screen?

Putting together a PC for my nephew
Ryzen 2600
ASUS Tuf b450 gaming-plus
16 GB vengeance 3000 MHz ram
256 GB m.2
1 TB firecuda sshd
Saphire Nitro RX 570 4gb
Evga 650w bronze certified psu

It’s not the GPU I put a working 1060 in. Checked the processor no bent pins. The motherboard is lighting up I don’t see any glaring post codes. Swapped the ram. But no matter what I turn on the PC and I get nothing. I am plugging directly into the GPU.

I just received my new thermal paste so I was planning on switching out the processor to make sure my cpu isn’t dead.

I assume when you checked the GPU, the monitor worked? Would be annoying to find the monitor beeing bad after swapping through every component in the PC.

How long has the PC been left running? First boot may take a minute or two.

1 Like

Left if booting for about 5 minutes. Monitor is good, it’s my daily setup. Tried separate cables

1 Like

No, unlikely that a B450 with Ryzen 2600 and old bios would result in black screen, as B450 was supposed to support Ryzen 2xxx on release.

However, if the board isn’t new, it could have been set to iGPU only/first - try clearing the CMOS.

Outside of that, try a different slot for the GPU (maybe it has a dead pcie slot).

If you have a disk with a working OS on it, try boot from that and see if you can ping it - or otherwise detect that it has booted?

Definitely going to try this

I Don’t know. I finally got back to troubleshooting it today. I put the 2600 in my wife’s machine and I got nothing. Just an EZ Debug double red on my MSI Mobo. Ok so, the CPU and bad. There’s not bent pins, just doesn’t work. Then I moved on to troubleshooting the Motherboard. I put her 1600 in there and nothing, no video from the 1060 that I know works. Ok… I also bought a tester kit for like $30 I figured it would be fun to plug it in. Tried the first PCIe port with the included card…nothing, the second PCIe slot…nothing. I thought it would be unlikely to have both a bad cpu and mobo but I’m sure it happens. I did buy them on sale at Microcenter, $118 for mobo and cpu combo.

So I guess I’ll begin the RMA process.

I also tested the PSU and no problems all green. I’m also getting nothing from the RAM slots. I have 2 sticks of Blue vengeance led RAM and tried all the configurations. Back to putting my wife’s computer back together

Maybe try the new parts one last time out of the case just on a cardboard box?

@Seventy_3 it sounds like you have the same problem I have with my new desktop. Santa for Christmas gave me the parts I needed to build a new desktop. It has been three years since I had a desktop, have been using a laptop (with its limitations) instead of a desktop. I to put all the parts together tried to get it to post. The motherboard lights up and all the fans spin but after 20 to 30 seconds the desktop shuts its self off. Right now it’s at Micro Center being checked to see if there are any problems with the parts. Lucky for me all the parts were purchased at Micro Center on December 20 so if they can’t fix it, I should be able to just return all the parts and get my money back. If fixing my desktop isn’t an option I will take my refund and purchase a system from either System 76 or Puget Systems.

I forgot to ask @Seventy_3 did you ever get your problem fixed. You forgot to update your post.

I had a boot loop issue with a build two weeks ago. It was the motherboard bios and the RAM. I had to update the bios to get the RAM recognized. Luckily, I had extra RAM lying around to test and update the bios with.

1 Like

@stconquest I don’t think my posting issue has nothing to do with Ram or needing to update the Bios. The motherboard is an Asrock X570 Tachi, the Micro Center salesman who helped pick out the ram, had built a system himself using the same motherboard and ram. He also didn’t mention anything about having to update the Bios. I think the issue is either an overheating issue or the Taichi motherboard is shot (meaning Micro Center sold a returned motherboard as new)

Yes, of course. Like every car dealer always has some family member being just amazed about exactly that car you’re looking at…

Did you check the QVL?

No, I didn’t check the QVL. I just check it now and they aren’t, but I check G.skill’s web sites ram configure, and it says the ram I purchased is compatible with the Taichi. The reason I think maybe Micro Center might have sold me a returned motherboard by mistake is there wasn’t an antistatic bag covering the Tachi when I opened it at home.

Sorry, I ended up buying another motherboard, and RMA’ing the CPU. Got the new one and that worked fine. I also bought the mobo through Newegg and it worked with no issues.


Thanks for your reply @Seventy_3, I will give Micro Center a chance to fix my issue if they can’t I will probably just return all the parts and purchase a Puget system desktop. I am trying to avoid doing so because I would have to invest another $1,300 USA dollars to get a comparable system and money is tight right now work has cut my hours in half compared to November and December.

Well good luck, I hope it works out

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.