Return to Level1Techs.com

Windows Not Booting from NVME Drive

I have Windows installed on a Samsung 980 pro m.2 drive and wanted to move it into a new PC. As far as I know all of my hardware is compatible. The new mobo recognizes the drive but does not see it as a boot option. Any thoughts on how I might get this to boot without reinstalling windows?

Shouldn’t have to reinstall. Clearing CMOS would be the quickest and first thing I’d try. After that take a look and verify the NVMe partition type is not MBR. If it is you’ll need to enable a legacy boot mode in BIOS.

Just tried clearing cmos and legacy boot mode. Unfortunately neither worked. Just to be clear the drive itself shows up as a boot option but windows does not.

Last easy troubleshooting suggestion I have is to disable Secure Boot. But you’ll usually get some kind of warning message if that’s the problem.

Without getting too deep in the technicalities of how UEFI works, the “Windows Boot Manager” boot entry you are missing is read from the EFI partition on the drive. If that partition exists at the beginning of the drive, then I’d venture to say your motherboard isn’t very bright and this could be an ongoing issue when upgrading BIOS or clearing CMOS in the future. Normally the motherboard will repopulate it’s NVRAM boot entries on it’s own from \EFI\BOOT.

The last suggestion I have would be to boot from a Window Setup USB → Repair Computer → Troubleshoot → Advanced Options → Startup Repair

Edit: Is there another boot drive attached to the system? If so, this will also cause an issue.

Have you looked in the bios boot settings?

What is the order of devices?

Remove everything else but the 980 and start from there.

Without having much information to go on here that’s the best I got for you right now

Some screenshots or more systems specs would be handy for troubleshooting

Good luck

Henrik