Return to Level1Techs.com

Windows Games on Steam for Linux. [Proton client Testing grounds]

Make sure you set the CPU performance Governor to performance, because the default in 18.04 is powersave and that murders Vulkan performance.

Hey can you please share the workaround?

1 Like

https://github.com/ValveSoftware/Proton/issues/37#issuecomment-415833819 I found it here.

1 Like

Your CTRL + F skills need work.

DOOM uses opengl by default, you have to enable Vulkan in game.

Specifically:

# AMD
sudo apt install mesa-vulkan-drivers mesa-vulkan-drivers:i386

OR

# Nvidia
sudo apt install libvulkan1 libvulkan1:i386 

Please read the article in its entirety.

https://level1techs.com/article/gaming-linux-updated

So I have been stuck on Windows thanks to games, I still am due to Battlefield and Destiny and Rainbow SIx Siege. I have opened up steam, some games are working, some are not. Do i Need to enable the 3.7-4 beta of proton?

Here is what I see when I try to launch Wolfenstein II in the Ubuntu 16.04 LTS with AMDGPU/PRO. It hangs.

FYI before and after I ran that test I double checked that my Vulkan Environment is o.k. and I ran a couple of tests.

I ran via:

I compiled and ran Hologram:

I also tested that Doom still runs great. I did not generate another video because I ran out of time. I pointed to the video of that further up this thread anyhow.

I am running out of time to test this any further for a while.

I need more information/ investigation regarding rolling back my mesa drivers and how I can work with https://copr.fedorainfracloud.org/coprs/amartinz/mesa-git/ on my
Fedora 28 installation. How I can remove thise mesa drivers, and how I can get the Fedora installation back on to main Fedora 28 mesa repo. I will ask for help on the The small linux problem thread.

Sorry if my questions seem simple but I have just moved from Windows to Ubuntu full time. I am ~ o.k. working within the standard Ubuntu/Fedora distros, but using 3rd party Mesa repos or downloading, compiling, and installing driver packages from https://mesa3d.org/ is outside my previous experience in Linux.

Thanks for your understanding.

I will summarize my testing results and post them to this forum as soon as I can. I need to get back to working on my main projects.

Thanks again.
Bye.

you probably wont see any huge benefits

Wolfenstein II runs great on my system but i do have nvidia so that might be why, There does seem to be a lot of that games that don’t run on AMD but do on nvidia and also the other way around. Oh and i’m also running 18.04 not sure if that matters that much though.

1 Like

I can capture video if anyone wants to see that as well.

1 Like

@colesdav

you could use this.

1 Like

I am beating my face against a wall trying to get No Man’s Sky to work. According to Phoronix it should just work with the latest mesa builds but I get the same issue in proton and lutris where I get a white screen with the hud in game. menus work though.
Antergos 4.18.4
Mesa 18.3 (mesa-git)
R7 2700X
RX 580 4GB

Hello All

With the launch of this new valve motive, i finally made the complete conversion to linux.

But i need help… I can’t get Elder scrolls Online to work.

Running:
Linux Mint 19 (Ubuntu 18.04 under the hood)
Nvidia 396 driver.
i7-4820K
32GB ram
nvidia 1080ti

My version of ESO is the standalone version, AKA non-steam.

I first tried the suggestions from @Dje4321 to try to get it to go with proton but i don’t know how to add in the launch parameters that you normally need to do with steam. From here for example.
https://steamcommunity.com/app/221410/discussions/0/1734336452575505938/

I then tried Lutris and attempted all it’s installers. From here.


The game locks up on launch or runs but with horrible black graphics glitches and motion blurring.

I tried to manually run the .exe from wine myself but i have no experience and the game does run but again the horrible graphics glitches.

Can anyone help with getting ESO to run?
Can anyone suggest some newb friendly web pages to read to learn how to GIT GUD with wine and troubleshoot issues?

Thanks fam…
Remilafo

Which version works in wine?

I haven’t gotten it to work with any wine versions.

I have focused testing on AMD R9 Fury X card. I can test Wolfenstein II on an Nvidia card on Ubuntu 18.04 LTS later. I do think videos are useful to see how the games are running, especially if you make sure to add performance metric overlays. Thanks.

Thanks I will take a look.
Wolfenstein II and Doom are Bethesda titles running Vulkan though.
Do you want me to stop reporting test results here and go work with “Contribute to FeralInteractive/gamemode development” folk instead?
Thanks.

Has anyone gotten anything outside of Steam to install under Proton? I’m trying to figure this out, but seem to dumb to do so.
Can i create an additional Prefix under Proton to run my own Stuff?

I mean which version of no mans sky. it was recently updated, maybe the new version doesn’t work.

I am on the newest version on Steam.
But I’ve been trying for about two weeks now. Basically hasn’t worked since Next I think.

Edit: NVM Michael is just trolling me. turns out that his post from last week was wrong the NMS patch actually got merged last night along with full 4.5 compat support. https://www.phoronix.com/scan.php?page=news_item&px=RadeonSI-4.5-Compat-Profile-Hit

I’ve ssh’d home and updated I’ll test it when I get home tonight.

As a dual booter, I would stay on windows for games now since steam play valve is like no more excuse stop it. Just do it all ready for you-you can it remove yourself away from windows. Now, before anyone thinks I hate windows 10 or windows in general partially but I finally moving forward which is good. However, some of my games won’t boot on ubuntu oh lord ubuntu user just kidding anyway I hope more games are coming to Linux or hell corsair can release software for headphones and RGB anything on Linux PLEASE DO IT CORSAIR!

hyperdimension neptunia re;birth 1 is running fine no problem which is nice for myself.

Screenshot%20from%202018-08-27%2008-48-50

please check your game if able to play with steam play

I have a video to demonstration this is working

3 Likes