Windows drive mounting in Linux

Right so I am getting some wierd thing happening with my dual boot win10/slackware 14.2 system. I got each OS on its own drive. I have windows partition visible from linux and read/write permissions set proper as well as mountable. Sometimes... usually when I log into linux first from a shut down... my windows drives are not mountable... If I go into windows and then log out and directly into Slackware they are "awake" and can then be mounted. I am pretty sure this is a win10 setting in its power settings, though I am unsure which is causing this. Anyone else have this experience and find a fix for it?

1 Like

Is it saying it's an unclean file system?

Yeah, I'm not understanding what you mean here.

You first say you shutdown your computer in Windows, then boot into Slackware.

But what are you saying you're doing differently where it allows you to mount the drives later?

If it's "when hibernating/sleeping" vs "when rebooting entirely", then yes, hibernating or sleeping on Windows, then restarting into Slackware will cause the NTFS partitions to be unmountable because they are not "clean" (meaning all file transactions are complete).

It's like (this is guessing), NTFS knows when it is mounted. Sleeping/hibernating Windows doesn't clear that flag and give NTFS the "all-ok" to be mounted elsewhere. Rebooting does, however.

there's apparently some funky stuff that goes on with win10 and rebooting -- I think you have to disable fast boot and a few other settings to get the FS readable when it's down.


Fast Boot is possibly it.

@tkoham I believe this is the answer I am looking for...

apparently if I shut down the computer and leave it for some lengthy time,,, say overnight, then boot into slackware it tells me that the window drive is not accessable cause its asleep or in hibernation... however I am not sure how that makes sense, when I shut down manually every night... I will check fast boot... I did shut if hybernation in win10 too....
Thanks I will test it when I get home.

Not sure if this fixed it, however in win10 I had everything disabled for shutdown... except... ya you guesed it Hard Drives... now disabled... hopefully this stays working now. Thanks everyone for the help.