Windows clock wrong after uninstalling Ubuntu [solved!]

Hi everybody, I’ve been using a dual boot Win10-Ubuntu desktop, and after messing up and breaking both OS’s, I’ve cleared every partition and performed a clean Win10 installation.

My clock is never accurate now, and I recall having to change something in Ubuntu for the time to display accurately in both OSs, but without it I’m not sure how to ‘revert the setting’. Any suggestions of what to change in Win10 (standalone) to fix this? Thanks!

It might be because your Ubuntu installation changed the UEFI clock due to an offset for timezone.
I know that it is a thing to watch out for in linux installations and Windows gets confused by it.

I’d suggest checking your clock in UEFI and setting that right. Then check the timezone settings in both Windows and Ubuntu.

1 Like

Make sure the TimeService service is running and check your time settings for the proper timezone.

It is usually because Windows is still using local time Instead of UTC. Unlike any other sane OS. Look online on how to force Windows to use UTC time, and reboot.


+1 It’s Microsoft’s fault, and it has caused bugs in Windows relating to DST changes. History and commands for Windows to change it:

1 Like

I had this on Pop!_os. The recommendation from them is to change the encoding in the OS. It is only a few commands. Give me a sec and I’ll link the solution.

This should fix your issue:
TLDR: Running timedatectl set-local-rtc 1 in your linux terminal should fix it.

1 Like

Hi @wertigon , I think you’re onto something. While in my ‘adjust time and date’ settings everything seems right, in the registry it’s using Mountain Time instead of Central. I don’t know how to change the registry to do this though, I found examples on Google for East and West coast only. Would you know the adequate nomenclature by chance?

The UEFI seems accurate, and I no longer have Ubuntu… but the Win10 time zone is accurate.

I just created a registry entry per some StackExchange post, but I’m not sure I did it right, because I’m still an hour off. The TimeZoneKeyName is still showing ‘Mountain Time’ even though I created a new RealTimeIsUniversal = reg 00000001 to set it to UTC.

Don’t know if this is helpful, but according to:

“By default, a user doesn’t need the administrator permissions to change the time zone (unlike changing date/time). This behavior can be changed using the Local Security Settings console ( secpol.msc ). Go to Security Settings → Local Policy → User Rights Assignment . The policy is called Change the time zone . As you can see, the time zone can be changed by the system, administrators, and all users. To prevent users from changing the time zone, remove the Users group from the list of accounts in this policy.”

Thanks @Curglaff , I did have Pop!_OS installed and this may be the root issue, but my whole machine collapsed and I had to wipe all HDs and partitions … now I only have Win10 so can’t really take that route.

I think I got it, according to the resource above simply typing this command in an administrator console should do the trick:

tzutil /s "Central Standard Time"

To get an admin console, press Windows button and then type ‘cmd’. This shows the command prompt utility. Right click this → run as administrator.

That worked! Thanks so much!!!

1 Like