WIndows 10 version 1803 - freezing on update

Thought it might be helpful to share an error I observed on a Windows machine:

When Windows 10 tries to install version 1803, there seems to be a three stage process for it to give up and revert to the previous version, 1709 build 16299.492 (also called 10.0.16299.492 by ver)

Stage 1 - Initial reboot

You boot to the Windows updating itself on a blue background with the notice that “your system may reboot several times while installing this update” or something similar.

Seemingly the first of these restarts will cause the machine to freeze in what I’m calling a no-spinner hang state; I think this is right after firmware because:

Normally the OEM logo will be displayed on a black background, and then the Windows 8-style loading spinner will statr spinning right below the logo.

No-spinner hang (that’s what I’m calling it for now) is when the OEM logo appears on the black background, but the spinner never starts.

Anyway, in this no-spinner hang state, you can shut the machine down by tapping the power button, when you next turn the machine on, you will be in:

Stage 2 - try again and freeze

As the machine starts, it will make it past the OEM logo screen;

Then it will flicker a window for a fraction of a second on a coloured background (it looks like the window is completely blank from what I can tell, but Ihaven’t been able t get a good look at it);

Then it will go to a black screen with white text at the bottom saying something like “Attempting to recover installation”;

Then it will reboot and be back in the no-spinner hang state. Your only way out is to tap the power button and shut down, leading to:

Stage 3 - Error message

When you restart this time it will proceed as above:

  1. normal black screen with OEM logo
  2. spinner on OEM logo screen
  3. flicker of some kind of window
  4. white text at the bottom of an all black screen

However, this time the text at 4. will say something like, “Attempting to restore previous Windows version”.

And then it will crash with what I assume is a windows bootloader error; this is displayed in mono-spaced text with grey bars above and below it.

The error says you will need to use you Windows installer to restore the system, and mentions an error code, 0xc0000454. At the bottom there is an option to go to the Windows bootloader, or the UEFI/firmware config screen.

If you press the key to go to the Windows bootloader, it will just show you the exact same error screen, with the option to go to the Windows bootloader removed.

Stage 4 - Back to normal

Once you reboot again, you will be back to version 1709. The next shutdown/reboot will ask you to install the update again, which jsut starts the cycle over again.

Update: while the on-boot error message referenced an error 0xc0000454, the Windows Update panel of the Metro Settings application and Event Viewer reference error 0xc1900101.

Anything in the error logs? You might try deleting the update installer in the windows directory and trying to download it again or try this guy

Right after making my post, I ran Windows Update again, and it was now asking to install a different update:

2018-06 Cumulative Update for Windows 10 Version 1709 for x64-based Systems (KB4284822)

This installed successfully, and now Windows is no longer even trying to get version 1803, despite it still being a build of 1709; now build 16299.522 rather than 16299.492.

So problem solved? Anyway, if/when it does this again, I’ll be sure to try that utility.

Thank you.

So, an additional follow-up:

A few days ago, this failed update rebooting cycle appeared again on the same machine. I again saw multiple restarts in the aforementioned pattern of trying to update and trying to restore across four restarts, but I didn’t have time try updating again and observe closely what had happened.

Which brings us to today, where I finally decided to try again and see what was going on, ready to look through Event Viewer if needed; and the updates installed successfully.

Today’s update attempt

Updates to be installed

  • Feature update to Windows 10, version 1803
  • 2018-09 Update for Windows 10 Version 1709 for x64-based Systems (KB4090007)

Windows version pre-update

winver — Version 1709 (OS Build 16299.611)
ver — Microsoft Windows [Version 10.0.16299.611]

Windows version post-update

winver — Version 1803 (OS Build 17134.228)
ver — Microsoft Windows [Version 10.0.17134.228]


So the update was successful, but I have no idea why. Since I did not check the version number a few days ago when it started doing the reboot cycle; I have no idea if the updates I installed today are the same ones which failed earlier. Regardless, the computer is now on update 1803, so this issue will hopefully not recur.

I hope this thread may be at least partially helpful to anyone in a XKCD/979-esque situation in the future.

1 Like