Windows 10 ISO update crash

HELP please.........
I have been trying to upgrade my legit copy of windows 8.1 on my Sony laptop to windows 10. The update tool wouldn't start the upgrade so I have made a bootable USB with the iso. This allows fresh installs to done on PCs as well as updates. The USB works as I can do fresh installs with it. But I can't seem to get the update to work.

The process works fine and goes into the full screen install page but crashes every time at 20%. I have tried using msconfig to limit the programs running which could interfere with the process. As well as deleting update files which could be interfering.

Any pointers would be appreciated even if they are shots in the dark. As I don't mind doing trial and error to get it to work. Thanks for taking the time to read this.

The same tool you used to make the usb iso will also allow you to just update. Might have to turn off your antivirus. Mine didn't like a file in the windows update.

For the media tool to work, his Windows update must be set to update automatically. From my understanding the tool doesnt like when you have a bunch of windows update settings off.

Mine did ?

I've upgraded a few with MS auto updates set to off. The tool worked perfectly. It's something else

A lot of upgrades are failing due to the currently installed OS having issues, malware, viruses etc... Run ADWcleaner, malwarebytes. see if there is something. Run them in safe mode to get the best scan

Good idea ! make sure your system is fully updated driver wise and that it is clean.

I had the issue, that's why i made the comment. and i had someone else on the forum tell me the same thing. after switching Windows update to work automatically fixed the update.

okay ? I don't doubt you.

Thanks for the tips am trying to update using the media creation tool. I have had all the window update settings on so its not that. Also I don't think it is anything that is running in the background as I went through all of the running processes in task manager the last time I tried to install.

Run sfc /scannow from the command line as an admin. this will clean the OS up and repair damage. Run tweaking in safe mode to ensure all is well. Run UVK in safe mode, also to make sure all is well. Even if you "don't think" something is running rogue, there may be something anyways. It's always worth a check.
The upgrade is crashing for a reason. Running these tools may help..

Thanks will try this out.

I have finally managed to update to windows 10. The first install attempt I tried crashed for some reason, possibly because the server load at launch caused some downloads to get corrupted. This left a file which can only be accessed through the registry which would create a conflict when the install tried to write the file again. The file was found at "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIMMount\Mounted Images" if anyone else is having trouble. Thanks for all the suggestions.

  • try going to to the windows directory - you'll see the folder called 'downloaded program files' - delete everything in there. Retry the update.
  • be sure to run the update tool as administrator