Win10 TS3 Audio Issue [SOLVED]

I hope this is in the correct topic...

I somewhat force upgraded to win10 a week ago and since then my audio setup hates me for doing so.


Z77-Mpower with onboard sound for 3.1 setup (crappy)

Focusrite Scarlett 6i6 for headphone out and mic (XLR) in .

First of all, youtube and other web based videos played with 2x speed without any reason, which (I guess) was fixed by setting the "quality" to 16bit, 96khz. (sounds stupid, but worked)

Switching between the audio outputs was fucking up everything, but as of now it seems to work again as usual.

The Issue that hasn´t magically disappeared is that TS3 doesn´t want to use my audio interface when I am on a server.
When I am opening the program without joining my server, I can test microphone levels without any problems, but as soon as I connect to my server I can´t get my microphone to work. (It´s not a perms issue) The only error message I am getting roughly translates to: "Error, couldn´t open recording device"

Focusrite Mix Control shows correct mic levels as well and reports no errors

Fixed by playing around with sample rate....

Any Ideas?