Wifi always hardblocked on startup of ubuntu

I'm on Ubuntu 14.04, on unity DE, my laptop is a gateway NV-57H94U, and basically every time I turn on my computer whether it be turned off or suspended i get no wifi connections and have to double tap my physical WiFi switch. I've googled and have tried many different solutions but none of them have worked.. Here's what I get when i run "rfkill list all" after start up:

[email protected]:~$ rfkill list all
0: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

And here's what I get when i "rfkill list all" after I double tap my physical WiFi switch:

[email protected]:~$ rfkill list all
0: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Basically, it's not a HUUUGE problem but it's annoying having to double tap the switch everytime I start up my laptop.. Thanks for any help

I had this issue with Asus and mint. I don't have the remedy anymore but there was something you had to edit in startup so it wouldn't hard block it

edit
Found the solution that worked for me. It is specific to Asus laptops but maybe it will give you a general idea of what to try

http://ubuntuforums.org/showthread.php?t=2181558

Thanks but I actually found the solution that worked for me this morning and was waiting to post until after my class..
On ubuntu 14.04 I edited /etc/modprobe.d/blacklist.conf with gedit
and added this new line "blacklist wmi" at the very bottom