What have I missed? - No power new rig

I have been working on my first ever rig and these past few weeks have been a very painful experience. So to update, a few weeks ago I built my pc once all the parts had arrived and tried to turn in on however nothing happened. I first jumped to the thought that I had messed up significantly in selecting parts and/or during the build. So I jumped on reddit and posted a troubleshoot (should have come here first as I love the show), I went through all the classic troubleshooting; paperclip test for psu, shorting the power on/off switch incase it was the front panel connectors, just generally checking all the wiring and so forth. So after all that and nothing I decided it must have been a faulty mobo and sent it back to Aria. They sent back a message saying that there was nothing to fix or at fault and I incurred a charge and had them send it back to me. I rebuilt it yesterday and waited the moment of truth but it STILL didn't turn on. Sorry for the very long explanation. Here are some specs and images

PCPartPicker part list: http://uk.pcpartpicker.com/p/Tp8KsY
Price breakdown by merchant: http://uk.pcpartpicker.com/p/Tp8KsY/by_merchant/

CPU: Intel Core i5-4690K 3.5GHz Quad-Core Processor (£164.00 @ Aria PC)
CPU Cooler: Cooler Master Hyper 212 EVO 82.9 CFM Sleeve Bearing CPU Cooler (£24.98 @ CCL Computers)
Motherboard: MSI Z97 PC MATE ATX LGA1150 Motherboard (£61.50 @ Aria PC)
Memory: Corsair Vengeance 8GB (2 x 4GB) DDR3-1600 Memory (£59.98 @ Amazon UK)
Storage: Samsung 840 EVO 250GB 2.5" Solid State Drive (£83.99 @ Amazon UK)
Storage: Western Digital Caviar Blue 1TB 3.5" 7200RPM Internal Hard Drive (£37.14 @ Aria PC)
Video Card: MSI Radeon R9 280X 3GB TWIN FROZR Video Card (£222.34 @ Scan.co.uk)
Case: Fractal Design Define R4 (Black Pearl) ATX Mid Tower Case (£67.19 @ Aria PC)
Power Supply: EVGA 600B 600W 80+ Bronze Certified ATX Power Supply (£43.50 @ Amazon UK)
Optical Drive: Lite-On iHAS124-04 DVD/CD Writer (£11.98 @ Amazon UK)
Wireless Network Adapter: Edimax EW-7612PIn 802.11b/g/n PCI-Express x1 Wi-Fi Adapter (£12.47 @ Scan.co.uk)
Keyboard: Gigabyte GK-KM6150 Wired Standard Keyboard w/Optical Mouse (£9.35 @ Scan.co.uk)
Total: £798.42
Prices include shipping, taxes, and discounts when available
Generated by PCPartPicker 2014-08-27 20:29 BST+0100


Sorry that imgur link is a little old so the molex is now plugged into the front panel along with the fan control.  

Any help would be great :)

Can you post a high res pic of the inside of your PC so I can take a look? (looking straight down on the mobo)

Derp I see l the pics let me look

a few things things first in the pic the heat sync looks a bit crooked is it possible that the CPU is not seated correctly?

Second I would try removing the graphics card those 12volt rails look like they are sharing a channel. There is a slight chance that it is causing an under-voltage problem.

lets start with that. If that no works them we try more fings.


With the pics you've given we can say: your CPU power is plugged in - upper left near I/O. Your 24pin motherboard connection is in - good. Your GPU is seeded in fully?... and has been plugged in - good. 

I always, as a cardinal rule, build the machine OUTSIDE of the case before placing items into the case. This way you know it POSTs, before you have it inside the machine. As, its a PITA to get your hands in there and work when you're trying to POST first time. It also gives you the chance to POST with the stock cooler for your first post. Once you know everything works - you can get it onto a custom cooler and start assembling inside the case. Its fairly easy to just have it on a surface, with PSU nearby and GPU does not need to be plugged in for first POST you can easily use onboard video to ensure the Mobo and RAM and CPU are all working together.

Questions: you did determine the PSU is okay right? Did it kick on when you tripped the power pins with your clip? Does the computer do ANYTHING, when you press power? 


You're certain you didn't put the CPU into the socket in an incorrect orientation? Your shop would've said so if you had, but it went to them and then back to you - i hope you didn't seed it incorrectly on your second build attempt. 

Dunno - but TBH, if you brought it to a shop they would have it disassembled so fast so they can test the Mobo/CPU/RAM/PSU without anything else - and a monitor/keyboard/mouse to do a post test.

+1 - POST test without GPU.

Bare essentials mate: MOBO/RAM/CPU/PSU.

Yeh I am pretty sure I seated it correctly there were some semi-circular parts which would have made it hard to put onto the pins if I had not! I am going to upload some higher res pics now. The PSU has only got 2 PCI-E connectors from one cable. I will go ahead and remove it and get back to you. 

Yeh made the mistake twice of building it inside with the massive CPU fan! I tested the PSU with a paperclip and it spun up fine. The power switch trip did not work tho. There are no LEDs on and nothing happens when I press power. I am pretty certain I didn't seat it incorrectly. Yeh I am leaning toward going to a pc show with it. Right I will get back to you on the GPU. The cable management is abysmal so sorry about that but here area  few more higher res pics if it helps http://imgur.com/a/iA7Ge

http://imgur.com/a/iA7Ge :) hope this helps 

Ok just tried without GPU and nothing happened. I will get back on this forum tomorrow afternoon as I have the afternoon off so I will try building it outside the case and testing it. Maybe even use a multimeter with the PSU connections. Also will swap out the hulking CPU fan cooler and run it bare bones. Wish me luck! 

i had this issue where my PSU would spin up if shorted but when plugged into the system nothing would power up. ended up actually being one of the modular connectors on the PSU. or the cable i was using from PSU to GPU. either way i changed the cable and the connector i was using and it booted just fine. maybe give it a shot if possible

Are you sure you connected the front panel power/reset/LED to the right header. Make sure the ram is fully plugged in,  this weekend I put together an itx build and one stick just kept popping up. 

Are you sure that you connected the front panel connectors right?

They look abit strange to me. ☺

its hard to tell but it looks like you have your ram in slots 1 and 3. with a lot of boards this is not a problem or in some cases correct. But not always have you tried the ran in slots 0 and 2 ?