Weird tesla app problem

hey folks,

I have a weird problem with the tesla app on my android phone - on my home network when I open the app I get mobile access disabled with a subtitle of 503 server maintenance all the time. When I get in the car, it works fine - even when I’m still on the home wifi (I guess it talks to the phone over bluetooth or something).

I have pfsense with pfblocker and I’m wondering if there’s something weird going on there.

Anybody else run into this problem or just me? Googling the problem is pretty unhelpful, unfortunately.

I don’t own a Tesla.

Look in the logs if any address / domain is not blocked and if you are not blocking any communication with the NSA :wink:
I’ve never used this app so I have no idea what’s going on there. But on logic, follow the trail.

Are you on your home wifi all the time? The only thing that changes is the physical change of phone location from home to car? If the only factor that is changing is location then this may not appear to be a network problem…

Go to the car and run the app then exit and test how far you can go before it stops working again. Maybe turn off bt and see what happens.

To Use the Mobile App

To set up the Tesla mobile app to communicate with your Model 3:

Download the Tesla mobile app to your phone.
Log in to the Tesla mobile app by entering your Tesla account credentials.
Enable mobile access to your Model 3 by touching Controls > Safety > Mobile Access (see Controls).
Turn your phone's Bluetooth setting ON and ensure that Bluetooth is turned on within your phone's global settings for the Tesla mobile app. For example, on your phone, navigate to Settings, choose the Tesla mobile app, and ensure the Bluetooth setting is enabled.

Your phone and vehicle must both be actively connected to cellular service to allow the mobile app to communicate with your vehicle. Tesla recommends that you always have a functional physical key readily available if parking in an area with limited or absent cellular service, such as an indoor parking garage.

Disable all pfblocker blocking and see if it works, if it still has the same problem, you ruled that out

Who’s your upstream DNS? Maybe try switch it and see if the problem persists