Weird problem with Windows 10 only semi-registering delete-key

Hey good people!

My keyboard is the Corsair K70 RBG and a couple of weeks ago I discovered that I could no longer delete with the deletekey, backspace worked fine and after a reboot the deletekey would work again.

So the weird things starts when i test the whole keyboard with this site I found:
So while testing with the above site the deletekey IS being registered, but with this other online test (link below), it's not.

If I hold shift down while pressing delete I still get the option the "permanently delete"...

And the make the whole thing more ridiculous. While using a VM running linux, the deletekey is registered and working just fine!

So I've tried the following so far:

  • Unplugging the keyboard and plugging it into another usb port.
  • Reinstalled the "corsair utility engine".
  • Tried another keyboard, which changed nothing...

Any suggestions?

ADDITION: any clue as to why, when I log in as Norgaard (another user account which is mine) I post as Norgaard1? And now it seems that I'm logged in a this Norgaard1 :/