Weird issues running Ubuntu on new laptop

I got a new laptop (Asus A15 with Ryzen 4800H and GTX 2060) with a few months ago and recently put Ubuntu 20.04 on it. I have been having some issues with the graphics drivers. If I boot normally then the login page comes up but when I put my password in nothing happens. It recognizes that it’s the correct password because if I put an incorrect one in then the “incorrect password” error appears, but it just stays stuck on the login page.
If I switch to one of the terminals then I can log in normally and run commands just fine. Also, sometimes the normal desktop will be displayed simultaneously with either the terminal or the login page, but it can’t be interacted with.

If during boot I go to Advanced boot options and boot in recovery mode, then just hit resume, it boots up fine and I can use the laptop normally. One issue that remains is that the cpu usage by gnome-shell can be at 30% when doing nothing but watching a youtube video. I suspect the graphics drivers used in recovery mode might be very stable but not super optimized, so fixing the first issue so I can boot normally might resolve this.

Also, the screen brightness setting doesn’t work, but that’s probably a separate issue.

I’ve googled around a bit but the answers I’ve found haven’t really helped. I’ve tried installing/updating the nvidia drivers with apt. At this point the “Additional Drivers” page in Software & Updates is locked to the manually installed driver.

My issue is that I’ve got a reasonably working laptop right now and don’t really want to make things worse, see xkcd 349

Okay, so this is a hybrid graphics style, which is extremely new.

What configuration are you using? AMD or Nvidia as primary?

See, hybrid graphics are simply not well supported in Linux. Not the way Windows is.

I wish I could give you more help, but I’m not familiar with this setup yet.

1 Like

This shows your user authentication is successful and that you have updates you can apply. Step one would be to apply those updates. They may have fixed bugs that you’re affected by.

See, hybrid graphics are simply not well supported in Linux.

Unless Ubuntu has dramatically improved their framebuffer in recent releases, it looks like he’s able to run a graphical stack. That authentication dialogue looks awefully GTK-y.

Yeah, that’s true, but my whole point is the issues he’s having are likely a result of this hardware configuration not being well-supported yet.

Nvidia is the primary. If the hybrid graphics is the source of all the issues, is there an easy way to disable one of the gpus?

One other weird thing to mention is that when I go to restart from the login screen, it says “there’s another user logged in” and lists my account, almost as if the second desktop that’s being simultaneously shown really is just a separate instance of the graphical interface that’s running at the same time.

1 Like

Interesting update…

If I start normally, switch to a terminal, kill the existing login session, then start a new one with startx, it seems to work.

1 Like

You should be able to disable onboard in bios. otherwise, you will need to blacklist one.

1 Like

Could OP install an alternative login manager? Or do something fun with whatever one it is (gdm?)

Did you happen to enable automatic login during the install?

I’ve solved it. I was going to switch away from gdm to some other login manager, but in the end I just decided to switch to KDE entirely, and that’s completely resolved the boot issues.

1 Like

If GDM was the issue, then you may be able to fix it with dpkg-reconfigure gdm

Also, you may have been having an issue with Wayland as KDE does not support nVidia + Wayland yet.

But either way, congratulations.

1 Like

From what I know, GDM cannot run on anything other than the X server, at least for now.
Do correct me if I am mistaken, but regarding NVIDIA’s proprietary drivers and Wayland… seeing as nobody really wants to support EGLstreams, which NVIDIA is pushing, alongside GBM, as opposed to exclusively supporting GBM, NVIDIA support on Wayland will probably stay an open issue for a long time.

@drquantuminfinity If I had read this thread earlier, I would have asked you to present the output of journaltcl --catalog --boot after switching to a TTY to see what the log says, but since you’ve already switched over to KDE Plasma, I will not say anything more.

So, now I’m trying to get the backlight working.
With my current settings, the only directory listed in /sys/class/backlight/ is acpi_video0. I believe it is actually linked to the integrated AMD gpu.

the acpi_video0 link points to the following:
acpi_video0 -> …/…/devices/pci0000:00/0000:00:08.1/0000:06:00.0/backlight/acpi_video0/

which matches the bus info’s listed in lshw for the AMD gpu.

*-pci:5
description: PCI bridge
product: Renoir Internal PCIe GPP Bridge to Bus
vendor: Advanced Micro Devices, Inc. [AMD]
physical id: 8.1
bus info: [email protected]:00:08.1
version: 00
width: 32 bits
clock: 33MHz
capabilities: pci normal_decode bus_master cap_list
configuration: driver=pcieport
resources: irq:31 ioport:c000(size=4096) memory:fc200000-fc5fffff ioport:d0000000(size=270532608)
*-display UNCLAIMED
description: VGA compatible controller
product: Renoir
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: [email protected]:06:00.0

If I add “acpi_backlight = vendor” to the grub config, the backlight isn’t recognized at all.

I think I need to add a xorg.conf file with 'options “backlight” ’ added to the nvidia device section, but the xorg.conf file generated by nvidia-xconfig causes X11 to hang when trying to launch, I believe because the laptop has two gpus, and the “Xorg -configure” command seems to fail with an error saying “Number of created screens does not match number of detected devices.” I’m guessing for the same reason. I didn’t even know what an xorg.conf file was until today and I haven’t been able to be able a good example of what it should be for a hybrid gpu setup.

GDM does support Wayland on nVidia hardware. Red Hat put in the work on this because “customers”. As an extention, EGLStreams is supported in Gnome on Wayland. It is still buggy but there is official support as the GBM and Wayland developers have left it up to the DE developers to support EGLStreams or not.

I am all team Red so I don’t use EGLStreams. Since OP mentioned Ubuntu and Canonical defaulting to Gnome, I just wanted to make sure that OP was using X instead of Wayland since that is what would give the best support of nVidia graphics and Bumblebee, or Prime, or whatever is being used to support onboard GPU + NV discrete GPU.

Also Canonical’s implementation of Gnome has been interesting considering they had to rip out a lot of the MIR stuff that they had built into their spin. There are some known issues of using Gnome on Ubuntu compared to using Gnome on other distros.

Yeah, GNOME on Ubuntu (3.36.4) does not support NVIDIA’s proprietary drivers. I guess that GDM just goes back to X when I enable the NVIDIA dGPU through prime-select.

I really need to get this new laptop opened up and get back to Gentoo

1 Like

Hm… did you try using prime-select to switch between the different modes of operation for the dGPU?

Using prime-select doesn’t seem to have any effect on anything.

It does for me though. Weird…
Did you make sure to use the appropriate environment variables with specific applications when in on-demand mode?

Edit

Did you make sure to use sudo?

Ya, it just says something like:

Info: selecting the intel profile

but nothing actually happens.

You need to then reboot. If you want to use both concurrently, the use the on-demand profile and use environment variables in the command line for the programs which you want to run on the NVIDIA dGPU.

For example: __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxgears