Return to Level1Techs.com

Weird behavior on new build Asus Prime X470 Pro/Ryzen 2700X- need help


#1

Hi guys!

I’ve got a strange problem that went for several weeks now. I’m trying to build a new system, here are the specs:

CPU: Ryzen 2700X
MB: Asus Prime X470-PRO
RAM: 16gb (8x8) Corsair Vengeance LPX @ 3200MHZ
Drives : SSD ADATA SP550 240gb
WD Blue M.2 3D (3D nand one) 1TB
PSU : Corsair RM 1000i
GPU: Asus NV GT610 (currently installed)
Gigabyte RX480 (not installed)

I’m trying to install Windows 10, each times I try to install it, I’ve got several error: 0x80070057, 0x8007001F, 0x800706F8, 0x80070006 or just Windows cannot install required files. Please make sure that all files required for installation are available and restart the installation without error code, or sometimes it just another new random error code… Even had a BSOD during a try.

I’ve try several usb keys with several Officials windows Iso (1703, 1709, 1803, 1809…), burned them with the Windows Media creation tool and Rufus… Nothing seems to works.

I’ve tried several drives, all perfectly fines, nothing.

I’ve even investigate that maybe the Ram was faulty, but MemTest86 didn’t find anything.

The bios have been updated to the last version, I’ve try various bios setting (forced UEFI, disabled secure boot, lowered the frequency of the ram, various CSM setup…), cleared the cmos frequently between test, nothing help it…

BUUUUUT ubuntu have been installed without a problem on the Adata drive. I’ve done several stresstest (with stress on all 16 thread, the ram and the disc) without any Kernel Panic or any problems in general. I’ve also try to install Fedora, but without success.

I’m starting to think that maybe the Asus board have a defect, but I can’t pinpoint the core of the problem and I’m out of solutions or tests to do… I will be more than happy to provide any more informations! Everything is currently on a test bench.

I’m currently smashing my head on every keys of my keyboard and slowly starting a Windows induced PTSD…

Halp!


#2

I’m assuming you tried to install it with rx480 in place of the gt610


#3

I didn’t have the rx480 on hand yet. But I can quickly find one. Do you have any Idea if this isPCI-E related problem? I’ve use this GT610 for debugging purposes for a while now and everything have work so far :thinking:


#4

I’ve just bravely fought the Canadian Winter to get the RX480 of one of my friend, unfortunately, nothing, just an error 0x80070570…


#5

Interesting… Not sure why windows can not get the necessary files. Can not remember does windows pull from their server during the install or is everything on the USB install media?
Edit: Terrible run on sentence


#6

If you have a dvd burner, then burn an windows 10 installation dvd.
And see if that works.
If linux works fine, then its likely not hardware related.


#7

@sanfordvdev all the iso come either from the Windows site or from the Windows Media Tool.

@MisteryAngel good call, I may try it tomorrow!


#8

Well I meant more for during the install process


#9

Do you have ethernet with internet connected during the installation process?
I think that’s what @sanfordvdev meant.


#10

@sanfordvdev @anotherriddle oh sorry, no the system wasn’t connected during the installation, you may have a point! I Just got a new cable (all my tools have burned down a few months back… the luck is on me guys!). I just made a first try but I’ve got another 0x80070570. I’m trying a new iso and let you know! This definitely make a lot of sense that windows need a bunch of driver for the x470 platform.

@MisteryAngel Unfortunatly, even an installation dvd have failled with the same result


#11

Maybe it sounds silly and unrelated but have you updated the bios?


#12

@SoulFallen Yes I have :slight_smile:


#13

I wonder if the gpu (the GT610 not the RX480) being a non UEFI card is causing windows to freak out during install?


#14

At this point, everything is possible… I can get another card to do another run of tests.

I have the board connected right now on my router. Weirdly enough, I can’t even ping nothing inside the debug windows prompt. Ipconfig /all show nothing so it can’t even get an IP address during the installation process. Thats the further I can go right now…


#15

Would definitely try swapping the card next then Win10 doesnt always play nice with legacy hardware. Hardware wise I have no other suspects as what you’re dealing with is not normal, except for maybe in the case of a drive being on the brink of failure.


#16

Make sense, I will also try to install it on HDD just for the test.


#17

So here are the update.

I tried with the RX480, same as usual, nothing boot, no Ip address… At some point, I’ve tried the “Windows Troubleshooting” procedure and I got an Ip address afterward, but no, the installation failled anyway with the same result. At one time, I’ve got an 80004001 error.

Everything in the bios is back to default, cmos cleared.

On one of the last test (2 ram slot loaded, RX480, and the single m.2, ethernet connected), the installation went to a BSOD with the mention PAGE_FAULT_IN_NONPAGED_AREA.

I’ve done a final test with a WD red 4tb, the installation went to 40% and crashed again with a 0x80070570.

I’m thinking more and more that the board have a defect, which is absolutely weird as the board run fine on linux and have no memory error related at all!

I’m still open for more options, but I will try to call Asus monday for more support…


#18

disable iommu in the bios and try again.


#19

Good Idea, but unfortunately its the same result…


#20

Page fault in non-page immediately makes me thing RAM. There’s a chance it’s not depending on where it’s looking up the memory (could be in CPU cache/VRAM depending on what it’s looking up) but this error basically means that it’s trying to get a value out of memory and cannot.

In the past when I’ve encountered this issue, it was either due to bad memory or a bad memory configuration (like mixing different speeds and timings).

It’s unlikely that both RAM modules are bad. Maybe try the install with just a single one?