WD PC SN520 Disk not recognized anywhere

Hi,

I’m having a problem with a dead laptop Acer A515-44 from which I would like to recover data from the WD PC SN520 M.2 disk, which came installed with the laptop. I bought an external M.2 enclosure, and connected the adapter to my PC via USB C.
The adapter itself gets recognized, but the disk doesn’t. I tried also with another M.2. WD blue 250Gb disk, with the same adapter, and everything works fine, it recognizes the disk immediately. I also tried with a second adapter and no luck.

I’ve also tried to boot directly from the disk, and had no succes, nothing is being recognized.
I also have a second Acer A515-44, and I’ve tried to switch the M.2. disks between them and everything boots and works fine. Later on, I also tried to read the disk on a Linux Ubuntu 22.04 device, and had no succes as well.
The OS on the disk is Windows 11.

I have never had such problems with disk readings, and I am quite experienced with IT and PC hardware. To me it seems like the WD PC SN520 M.2 disk doesnt have a controller on board,

and there for it doesnt get recognized at all. Is that even possible, what do you guys think about my issue?

Any help would be much aprichiated.

I added the pictures from Disk managment and the disks which I’ve used.


So in your photo the top M.2 drive has a SATA interface while the bottom one is NVMe. They are two different technologies but share the same M.2 form factor.

I suspect your USB enclosure only supports SATA and this is why you are unable to read the drive. Most adapters are either SATA or NVMe, but not both. But the Acer motherboard supports both NVMe and SATA and this is why it works with either drive.

Edit: NVMe drives are normally keyed different to prevent this type of confusion. Strange that Western Digital used a B&M key on it.

2 Likes

That’s what I was thinking too. I checked the picture and was like “naahhh…same key, isn’t a SATA vs NVMe problem” and went on. But good thing you paid more attention to the labels

And I agree. Putting them directly into the M.2 slots on the motherboard should do the trick.

1 Like

It’s only because I read the bottom drive’s label first… then I started questing my sanity when I saw the key. My first thought was that the label was misprinted until I found more pictures on Amazon. Such a bad design choice

Thank you guys, now it all makes perfect sense.
Best wishes,
Alex.