Return to Level1Techs.com

[W10] System lockout + startup repair ineffective + cannot bypass password + 0xc0000017


#1

Dear reader,

I have been tasked with the joy of fixing yet another Windows 10 related problem of my father’s PC, but cannot figure this one out on my own. I won’t put the full story down, only the most important things (semi-TL;DR).

System
Windows 10 32b Home
Microsoft account login

The original issue:
PC works the night before. No updates. Shut down correctly. Following day, cannot log into account with incorrect password message, despite the password being correct (using Microsoft account) and no network connectivity. Problems remains, no changes.

This is not a unique problem, more people have had this issue. Windows had a brainfart, blocks Microsoft login (password incorrect > password reset does not help) AND disables (presumably) network driver.

The symptoms:
No wired internet connection (limited network access / yellow symbol), cannot test wireless (PC does not have antenna). Both wireless and wired do work on other systems on the same network. Boot is normal, BIOS works, Boot priority can be changed. Microsoft login password not accepted (even though it IS correct).

Issues preventing me from fixing this:

  1. Startup repair does not work from bootable USB.
  2. Cannot use system restore point (see X).
  3. Cannot use command prompt (see X) to create administrator bypass net user administrator /active: yes. Even if it worked, I would not know after (see topic).
  4. Cannot bypass Windows password using system recovery via sethc cmd trick (see 2).
  5. Cannot force startup repair via USB by using cmd of that USB and typing:
    Bootrec /fixmbr
    Bootrec /fixboot (fails)
    Bootrec /scanos (0 drives detected)
    Bootrec /rebuildbcd (fails - write only disk)

X) an older, existing problem of not enough RAM memory being able to be created (0xc0000017). This blocks me in trying the usual workarounds. I also cannot fix that error as well, as I cannot get into Windows desktop itself in order to implement the workarounds for this error code.

Safe mode does not help.

Things I will check tomorrow:

  • Router settings
  • Use dedicated network card, hoping pre-installed (if any) drivers work

I hope someone can aid me in this matter, before I am going to perform a clean install.

Kind regards,
JB

EDIT:
I’m afraid to use third-party software, such as PCUnlocker, without knowing if it’s safe to use.


#2

Have you tried using the replace sethc with cmd trick to create a new user and give it admin rights instead of using it to enable the built in admin account?

Net user <new_user_name> <password> /add
Net localgroup administrators <new_user_name> /add
Replace <new_user_name> and with your something like recovery or whatever.


#3

Press power on system
Get to win logo and flip surge power strip off
Do this 2 more times and windows kernel will autoload recovery options
Try system restore


#4

Thank you for your reply.

No I have not, because I cannot start cmd prompt from the system itself. It freezes up and spits out the 0xc0000017 error, saying that there is not enough memory available to create a RAMdisk.

I’m not that acquainted with these type of actions and using cmd (or pre-desktop actions in general), so what I’m saying next could be incorrect. If so, please correct me.

I can however start cmd from the bootable USB. But as far as I know, this is not the same (as it also states with its directory being X:/something/something (the boot USB) and not C:/WINDOWS/system32 or whatever the admin cmd is supposed to be). Am I correct in saying that performing any actions on the X:/ command prompt, does not affect the actual Windows drive of the system itself? And by that I mean, creating a new user like that won’t work?


#5

Thank you for your reply.
I see now that I have used the wrong term in my OP, I have changed it. I have tried system restore, but as mentioned, it spits out an 0xc0000017 error. This prevents me from doing any restore point or cmd related fixes, from the system’s recovery mode itself.


#6

Found this on microsoft

How to: perform a repair upgrade using the Windows 10 ISO file by Andre Da Costa and check if it helps.
http://answers.microsoft.com/en-us/insider/wiki/insider_wintp-insider_install/how-to-perform-a-repair-upgrade-using-the-windows/35160fbe-9352-4e70-9887-f40096ec3085

Also refer to: http://windows.microsoft.com/en-us/windows-10/windows-10-recovery-options


#7

I thank you for your input, but I’m already past these guides. As stated in the OP, these ‘normal’ fixes don’t work.

The first problem I mention is that cannot perform a repair upgrade. It prompts the message that repair cannot fix the issue. There are workarounds, but they require you to either be in the desktop environment, i.e., be logged in (which I obviously cannot do), OR open the admin cmd, which spits out the 0xc0000017 error on this system.

Notice the endless Windows disfunctional loop I’m in?


#8

Ok so after trying, I was incorrect, good to know. I was actually able to perform the sethc trick. Meaning that I can change files on this system via the system image recovery.

However, StickyKeys is actually presumably disabled on this system, as nothing triggers when pressing Shift multiple times. I’ve tried to adjust it via regedit, it does not include the necessary (sub)folders that include the settings to change StickyKeys values. At first I thought this was because but that command is done in the bootable USB’s command prompt (X:\Sources)(because it does not work on the system itself), but after finding a way to open cmd on the C:\Windows\system32 (via System Image Recovery), that regedit also did not include the necessary folders.

So if someone knows a way I can change StickyKeys settings via System Image Recovery, either changing it via textfiles or admin cmd command (either bootable USB or system), that would be nice. Regedit does not work.


#9

Ok, so shortly after my last post I was able to finally get into the system. I managed to successfully make the Administrator account ‘visible’ via modifying registry from recovery environment (link how to). Something that failed using admin cmd and typing net user administrator /active: yes .

Internet works as it should.

Turns out there apparently was an update installed, as I got the whole “Windows is even better now” “All files are untouched” bla bla bla bullcrap welcome screens after logging into the administrator account. But looking at the update history, nothing has been updated or installed in recent days. Because of the 32bit system and having only 4GB of memory, this system always fails to update to any new build of Windows. So… ???

However, the problem of not being able to log into the Microsoft account still remains, as well as the unresponsive Easy of Access button. I would have thought that having a working connection would allow me to log into the Microsoft account, but no.

If anyone has any tips on fixing the Microsoft login account, let me know (besides password reset, as that does not work). Tips on enabling the StickyKey via cmd or whatever would still be nice, for future use.

Otherwise I will mark this as resolved.


#10

get yourself a linux live USB of kali (you dont need kali, you can use just about any distro but kali has it and works) and use chntpw. You can reset any local account password (or blank it out)

http://www.chntpw.com/author/admin/


@Zibob has had issues where NOT taking the updates causes the internet to break until the updates are installed. I’ve seen it happen where I could prove that was the case only once myself.


#11

Yup can confirm. Twice now windows has not quite disabled the WiFi in my case, but “forgot/blocked” just my actual home WiFi connection, other showed up but my one that was set did not exist and could not be made to until I updated windows.

Still no reason as to why but it happened, also caused problems with Bluetooth. Same where it was working and could see other devices but my devices did not exist and could not be connected. After a windows update it was like it never happened, no explanation.


#13

Thank you for the additional information.
Of the information on that website, method 2 looks promising. I assume, given by the amount of referrals to PCUnlocker, that it is software that can be trusted. Will the free version suffice in this situation?

All the data on the Microsoft account is accessible from the administrator account, of course. Someone else has recommended me to change the user folder to [name].old, delete the account, create a new account on the same credentials and copy the folders with media etc (not appdata). Installed programs etc. won’t be affected as far as I know.


#14

I’ve never used pcunlocker so I cant give any advice there. chntpw has been my go to for some time now. I dont recommend using a microsoft account linked to the local PC unless you need it for windows activation, which in most cases you dont.


#15

My unsupported assumption is that it affects some of the drivers for some reason. As it still needed to do some post-login screen OS-related processes during those welcome screens (it said, please don’t turn off PC etc.), and only after that the connection was stable.

Even IF you do take/accept/enable the updates, this system cannot handle them. It always comes back with an error that the updates could not be installed. This has something to do with insufficient memory for creating the RAMdisk, leaving the failing update process in a never-ending loop. Security updates do work.


#16

My bad, I overlooked the fact that the software carries the same name. I thought it was just the website, confusing me a bit on your first piece of advice regarding the USB.

I never recommend MS accounts on simple home-PC’s as well. Maybe if you’re a heavy Onedrive user and/or switch systems a lot, I could see its use.
And the argument of the activation/digital license is understandable, but even that does not always work correctly. I’ve had two instances where a supposed linked license to my MS account should have worked, but in practice failed to activate my windows after hardware switches.