Volume level changing by itself

Hello everyone.

I am using an OpenSUSE Tumbleweed with Gnome DE on a laptop probably no one of you know (a “JDM” machine I’ve bough during my vacation, a Mouse convertible without proper name, partnumber BC-MB1485UD11A-191), and it is surprisingly good experience except for some minor problems I’ve already worked around.
BUT one issue persists, and it is quite annoying: volume level changes itself up and down all the time. It’s not pulse flat-volumes, it’s like reacting to me pressing a volume up/down hotkey, except that I am not. Showkey and similar software shows a corresponding hotkey being pressed and lifted by itself, when I just leave my laptop lying to see what happens.
I’ve came across Arch forum thread where they had a somewhat similar problem and traced it down to peaq_wmi and input_polldev modules, but that bug was allegedly fixed in 4.14.smth kernel, and I am on 5.3.12-2. Blacklisting that 2 modules didn’t change anything for me.

So, where should I look next?

Like, a machine from the company Mouse?

Please do a review on it I’ve been so interested in those bastardized contraptions they like to call laptops.

Hmmmm… Could there be a metal chip under the keys? Have you physically checked the springs?
Have you checked to make sure there isn’t still a bunch of gunk in there from manufacturing?

This could also be a bug in the audio chip, bios, or the keyboard is just faulty. This isn’t an OS issue tho I don’t think. The OS is just doing what its told.

Have you tried external audio gear to see if it IS an OS issue and it persists on other hardware thru your laptop?

Hmmm, interesting. It could still be an interaction between hardware and software if that was a case in the past. Reintroduced bug with new variants?

BT headphones, still occured.

I actually preferred it over the Dell XPS 13 while holding both and do not regret the choice to this day. Only real downside is the battery life, which is important, but I wasn’t able to test before purchase. It’s good enough in this regard though.

do you have any USB audio interfaces? BT is probably good enough though.

Are the volume controls independant or integrated? Meaning are they separate buttons or part of the keyboard logic.

I have at home, but I really do not think this is affecting the situation in any way.

Showkey tells that keypress with codes 154/153 corresponding to “volume up”/“volume down” are being registered. There are 2 standard ways to send them, via Fn+F7/F8 or via dedicated volume up/down buttons on the left side of the chassis (makes sense since it’s a convertible). Keycodes registered are identical for both variants.


Why do I want to say try unplugging the side buttons.

I really do not want to disassemble it since tearing off it’s rubber legs that hide screws and gluing them back after is a pain. I would rather blacklist this keycodes and just use the GUI slider (yea, inefficient, but I rarely need to do anything other then mute/unmute sound, which I can leave a hotkey for freely) if there will be no progress.

1 Like

I want to say its a physical problem.

I think it isn’t. Looks like I’ll have to resurrect Windows on this machine and even use it for some time to see if this happens there (I used it to download the OpenSUSE iso and don’t recall such behavior though).

I’ve ran it under Windows for about an hour, and there were zero instances of volume level jumping around, while on Linux it does so every 2-5 minutes.
Makes it pretty easy for me to insist that this is not a hardware problem.


Fuck, I’m stumped.

If somebody else encounters this issue, I got some help on it in OpenSUSE Bugzilla:
The cause is intel-hid and keyboard devices both handling events for side volume buttons simultaneously.
Blacklisting intel-hid seems to get rid of this, and I did not see any other functionality affected yet.

I have a PC that does this, but only with one specific keyboard attached.
I feel your pain!

I just read your bug report and my issue is different. Mine changes volume after an unrelated keypress, or a keypress on a second keyboard, a mouse click, or sometimes after no other input activity at all.
It must be sunspots! :dizzy_face:

Then maybe your issue is more like stuff Arch users described on a forum which I mentioned here.

It helped them to blacklist peaq_wmi and input_polldev modules, rebuild initrd and then reboot, give it a try.

EDIT: Be careful though, I did not lose any functionality without that modules, but I am now not able to add peaq_wmi module back after removing it with modprobe -r. Fine in my case, but you might lose some actual keyboard hotkeys (or might not).

Thanks so much for the feedback!
This is a new home-built keyboard, so I need to finish auditing my firmware first, before looking at Linux.