Return to Level1Techs.com

VMWare install fails. Could it be

When I try to install VMWare Player 15.1 on opensuse Leap 15.1 it fails …

Could it be that opensuse leap 15 is to “new” for for VMWare to install?

[email protected]:~/Downloads> sudo ./VMware-Player-15.1.0-13591040.x86_64.bundle
Extracting VMware Installer…done.
User interface initialization failed. Exiting. Check the log for details.

And the log file …

[2019-07-10 20:28:27,961] Installer running.
[2019-07-10 20:28:27,961] Command Line Arguments:
[2019-07-10 20:28:27,961] [’/tmp/vmis.WIBRxc/install/vmware-installer/vmware-installer.py’, ‘–set-setting’, ‘vmware-installer’, ‘libconf’, ‘’, ‘–install-component’, ‘/tmp/vmis.WIBRxc/install/vmware-installer’, ‘–install-bundle’, ‘/home/george/Downloads/./VMware-Player-15.1.0-13591040.x86_64.bundle’, ‘’]
[2019-07-10 20:28:27,976] /tmp/vmis.WIBRxc/install/vmware-installer/python/pygtk/gtk/init.py:69: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)

[2019-07-10 20:28:27,977] Unable to initialize gtk: could not open display
[2019-07-10 20:28:27,977] Could not set up curses… Falling back on null term type.
[2019-07-10 20:28:27,980] UI Initialization failed.
Traceback (most recent call last):
File “/tmp/vmis.WIBRxc/install/vmware-installer/vmware-installer.py”, line 293, in main
ui.Initialize(options.ui)
File “/tmp/vmis.WIBRxc/install/vmware-installer/vmis/ui/init.py”, line 77, in Initialize
exec ‘from vmis.ui.null import *’ in globals()
File “”, line 1, in
File “/tmp/vmis.WIBRxc/install/vmware-installer/vmis/ui/null.py”, line 13, in
from vmis.ui import console
File “/tmp/vmis.WIBRxc/install/vmware-installer/vmis/ui/console.py”, line 9, in
import curses
File “/tmp/vmis.WIBRxc/install/vmware-installer/python/lib/curses/init.py”, line 15, in
from _curses import *
ImportError: libncursesw.so.5: cannot open shared object file: No such file or directory

I’m not familiar with OpenSUSE, it’s been years, but do you have the ncurses package installed? If so is it version 5.x? You may have ncurses 6.1, or nothing at all.

1 Like

VMware installer is failing to find libncursesw.so.5

Unsure which package or software has this library, but you’d likely need to install it prior to rerunning the VMware installer

1 Like

Yep it appears to be version 6.

libncursesw.so.6 is there.

So back to the question…

Could it be that opensuse leap 15 is to “new” for for VMWare to install?

Yes, it’s possible.

You can get VMware workstation to install on recent and/or unsupported platforms but as above you’ll need to install packages manually, and likely compile kernel modules yourself from the open-source vmware kernel modules repository.

I do this on fedora 30 for work, but unless you’re a bit of a masochist or need bleeding edge linux for something else, you’d be better off running an officially supported Linux for vmware.

Anything kernel 5.0 or newer is too new for out of box vmware workstation/player.

Thank you.
That is what I thought. But figured it was better to ask to make sure before I tried something else.

The reason I was looking at VMWare is because VirtualBox is subjectively slow ( a video that runs fine on bare metal stutters in the VM, among other things ).

1 Like

Unless you’re running an AMD GPU (and even then, i’d seriously think about it - performance isn’t THAT bad) you’re likely better off just running ubuntu 1804 for VMware, Steam, GOG, etc. support.

For those things, Ubuntu 1804 will “just work” for the most part.

I’ll say I was able to install and load VMware Workstation Pro 15 on Manjaro just fine using this guide about a week ago

Yeah, it’s not that difficult to do it on a non-supported distro, but the pain in the ass factor every vmware upgrade or kernel upgrade (on say, fedora 30 - or any other kernel 5.x distro) may or may not be worth whatever benefit(s) you get from going to a non-supported distro.

In terms of getting work done, there’s zero difference in functionality between say Fedora 30 and ubuntu 1804 in my case for example. The only reason I’m currently rocking F30 is to re-acquaint myself with RPM based distros and Redhat flavour(s) in particular as i have RHEL in the environment on the server side now.

1 Like

" … Unless you’re running an AMD GPU …

I am.

" … performance isn’t THAT bad … "

Depends on your definition of “bad”, and in the case of the video I was trying to run, it was that bad.
Not to mention the boot times and a couple of other things.

" … better off just running ubuntu 1804 … "

If I have a choice, and I do, I’d rather not be able to run VMWare then run Ubuntu. So I guess I’ll just suffer with VirtualBox.

" … it’s not that difficult to do it on a non-supported distro … "

And yet after trying several times, over a couple of weeks, it still won’t install.
And yet after fallowing several guides on the internet, and installing many, many suggested packages, and now having a load of extra crap on my system, it still doesn’t install.

So in fact, for me it has been that “difficult”. But in spite of that I intend to keep trying. I don’t like having my ass handed to me by inanimate objects.

Well because of all the things that I’ve done ( installed ), I’m thinking about going a clean re-install. Seeing how that I’m running Manjaro in VirtualBox, maybe I’ll just give Manjaro a try on bare metal. And see if it will meet my needs ( OBS Studio, Kdenlive and a few others ).

Thanks for the link! :slight_smile:

1 Like

Hello Georgezilla

I an Running Leap42.3 with stable kernel which just paste the 5.2 mark :slight_smile:

I cannot say my setup is standard :wink:

do you run the out-of the box kernel ?

I do have the Vmware-player 15.1 running, for which I followed rglinux web site as he is kind enough to share his beeding edge kernel installations (mostly on fedora), and have been able to re use the same fixes

The Suse 15.1 update is coming home soon, I have the latest version running in a virtual machine for evaluation, so I am interested in your issue.

Could it be that it is related to Wayland? (I ams still with Xorg) the “cannot open display part” of your error let me think of it

Could also be an access denied issue,I found that for the installation, opening a (X)terminal, as normal user, and then “sudo su -” gives me the proper graphical root window, that way the graphic installation UI show on the same screen

Cheers

Dominiquew

Well, ubuntu, out of box with Vega works just fine. I was a launch day vega adopter… have been running it on various distros since release, haven’t noticed that much difference in performance to be honest, from Ubuntu 1804 to Fedora 30 current…

With regard to the VMware install… I’d say you need to check vmware’s installer log, then find out how to drive the package manager of choice on your distro to find/fix the missing dependencies. Most likely the installer log will complain about being unable to open some shared library. You need to figure out what package in your distro provides that library, and install it. It’s how i fixed mine on Fedora.

If you’re unable to do that (or your distro doesn’t include said library in any package management) then i guess your choices are

  • run a vmware supported distro
  • switch to KVM
  • figure out some other method of installing the required dependencies

Also, be aware that if you have the dependencies installed, maybe vmware is looking for the 32 bit or 64 bit version and your version is the other architecture.

Well, as Leap42.3 is out of support,

I have re-installed my setup with Leap 15.1 (upgrade did not work for me)
and I do have VMplayer 15.1 running, on the 4.12 default Kernel, almost a standard install except for EXT4 instead of btrfs)

i do have some gtk warning starting the UI from a terminal, but the installation went smoothly and runs now for a week.

CPU AMD 1700x, video is a GTX1050ti

Honnetsly, Not my best Suse experience, but no technical issue with VMware under Xfce or GDM (which is my actual Windows Manager)