Virt-manager/qemu-kvm laggy mouse/video

I created a VM with virt-manager and used a disk image of a guest Windows 7 VM that I’ve used with VirtualBox. It boots and works, but the mouse and video playback (eg youtube) have lag/stutter/screen tearing. I have no such issues with VirtualBox.

Is some configuration needed, maybe in the “Display Spice” or “Video QXL” setions of virt-manager? I just assigned CPU cores and RAM.

Did you install the virtio windows guest drivers?

http://www.linux-kvm.org/page/WindowsGuestDrivers/Download_Drivers

No I didn’t.

Reading the Fedora documentation it seems the virtio-win package is supposed to be installed on the host? From VirtualBox, I thought guest-additions get installed… in the guest.

In any case, I don’t notice a difference.

you need both host and guest for virtio to work

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/6/html/virtualization_host_configuration_and_guest_installation_guide/form-virtualization_host_configuration_and_guest_installation_guide-para_virtualized_drivers-mounting_the_image_with_virt_manager

So I have to install the virtio-win package in Fedora (host) and also install (which?) device drivers from the virtio-win iso in Windows 7 (guest)?

The VM disk image was made by, and still used with, VirtualBox, though not simultaneously. Would the virtio drivers and VirtualBox guest additions conflict?

no idea if they’ll confilct, but to my knowledge they’re just drivers in the case of virtio, so i’d say it’s a safe bet to try. snapshot or copy your image first though

Which devices need virtio drivers? Can multiple drivers be installed for the same devices?

Also, can VirtualBox snapshots work with virt-manager?

typically you’d just install all of them, but I have no idea how you’d manage them if you’re using vbox at the same time

not something I’ve ever done

You’re only supposed to install the virtio-drivers in the guest.

However this only applies if you setup any virtio devices (via virt manager for example) in the first place. Otherwise qemu + libvirt emulate well known windows devices.

Have a look in windows device manager on the guest and see if there are any devices that are missing drivers

Aside from that, look what happens if you add a USB mouse device in addition the usual default PS2 device that Virt Manager uses.

Not a passthrough USB mouse - just the one that emulates a USB mouse.

In my case I’ve noticed that this resolves the input lag somehow.

I tried adding a “generic USB mouse” from Add Hardware but it made no difference.

Noting that video playback is also laggy, I saw this orange warning triangle next to an unchecked OpenGL option under Display Spice, with the tooltip (not shown in screenshot) “Spice GL requires virtio graphics configured with accel3d.” Not a clue what that means but could it be related?

please read the virtio documentation – you have to set the driver for each device to virtio for it to make a difference

Ok, after rereading the documentation I think I understand a little more. The virtio-win package installed on the host provides the driver iso (in /usr/share/virtio-win/) to be mounted as a CD and used for driver installation in the Windows guest.

Installing the virtio serial driver maybe helped somewhat, but it’s still nothing like native or VirtualBox performance. If I use the “redirect USB” and select my mouse, then it works great like native, but the mouse is gone from my host. I guess that’s the passthrough option.

Also, I did not see any of the other devices for which the documentation mentioned installing drivers. Though I do have a non-descript PCI device that I don’t know what to do with…

Are the options in virt-manager explained and discussed anywhere? For all I know it’s just a matter of setting the right options.

For example the disk bus was set up as IDE. I changed it to SATA since that’s how I have in VirtualBox. But I’m just stabbing in the dark.

Aaaand right after typing all that I semi-solved it: installing QXL drivers for the display adapter worked. Mouse pointer and video playback are much much smoother now.

But… playing HD still drops a lot of frames, while VirtualBox has no issues. It’s strange, I thought qemu/kvm was supposed to be best for performance while VirtualBox sucked.

I got the idea from the Fedora documentation’s list of what drivers are included in the driver ISO, which is more than what is mentioned in the RedHat documentation.

It’s so nice that Fedora/RedHat have so much documentation but sometimes a little extra “interpretation” is needed for those not already familiar with what they’re looking for.


Now, is there anything like seamless mode?