Return to Level1Techs.com

Virt manager Permission denied when installing VM on secondary ssd

#1

Hi guys I’m trying to move from virtualbox to virt manager to manage my VMs because I want to virtualize more sensitive stuff like pfsense freenas… but I cannot manage to have my vms installed on a secondary ssd I always get the same error message saying Permission Demied. I tried to reformat the ssd ext4 ntfs… but I keep getting the same error message. Does anyone got any cues?

here’s the error I get

Unable to complete install: ‘internal error: qemu unexpectedly closed the monitor: 2019-05-13T08:43:19.981721Z qemu-system-x86_64: -drive file=/home/gandalf/Documents/VM/FreeNAS-11.2-U4.iso,format=raw,if=none,id=drive-ide0-0-0,readonly=on: Could not open ‘/home/gandalf/Documents/VM/FreeNAS-11.2-U4.iso’: Permission denied’

Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/asyncjob.py”, line 75, in cb_wrapper
callback(asyncjob, *args, **kwargs)
File “/usr/share/virt-manager/virtManager/create.py”, line 2122, in _do_async_install
guest.installer_instance.start_install(guest, meter=meter)
File “/usr/share/virt-manager/virtinst/installer.py”, line 415, in start_install

0 Likes

#2

Copy the iso to /tmp
Reconfigure iso location
Try to power on again

1 Like

#3

It worked thanks for the tip.

1 Like