Vetrical strpied BSOD after updating amd dispay drivers

I decided to update to 13.12 from 13.11beta. First I opened Driver Fusion to delete my current drivers since I heard that previous versions could conflict with the new. I restarted and ran the exe i got from amd's website (i did select correctly). When started up again i saw the noraml desktop for a sec or two then got the BSOD i couldn't do anythong so i had to force a shutdown. Launched windows in normal mode just in case it was a one time thing, but it happened again. Next time i launched in safe mode, then opened driver fusion, deleted my display driver, restarted and got no BSOD. I tried installing 13.12 two times and the same thing happened, then i tried going back to 13.11beta, but i still got BSOD.

You can see my pc specs on my profile.

I think the reason this happened was because i was playing bf3 (bf4 is bad) and got a directX error which crashed the game and made some other applications braindead (nothing a simple restart of them couldn't fix). And i believe it might have fucked with my display driver too.

Sorry for any typos, I'm on my phone  

try the program display driver uninstaller from  guru3d. and re-download the amd drivers, if not, use the non beta version, i think that one is more recent than the beta one.

Thanks a lot I'll try it tomorrow. 

Didn't work, however i did fix the problem by just restoring from a backup.

yeah, the WHQL drivers are more recent than the beta. probably won't last for long tho