USB ports and Wi-Fi card randomly turning off when hardware is in heavy usage, what's to blame, motherboard, Windows or usb hub?

On my setup, i have an Orico A3H10 USB hub mounted to my desk, all my peripherals are connected to it, every once in a blue moon, when my hardware is in heavy usage (playing a demanding game, for example), the USB ports on my machine randomly turn off, sometimes my Intel AX200 wi-fi card follows suit and turns itself off as well.
I cannot have this setup without a hub, due to the length of the cables on the peripherals, my table is very big, they simply cannot reach the rear panel of my computer, i thought about using a Thunderbolt KVM like Linus does, but its too costly for me.

Thing is, i haven’t been able to replicate this issue on my own, its completely random, just often enough to annoy me but not often enough to be diagnosed and analyzed, and i don’t know what to blame, “fixing” the issue when it happens is not that difficult, i have to turn my PC off for some 10 minutes, connect the hub to another port, restart the system and reconnect the hub to the old port.

I’ve been taking some things in consideration:
The hub: its old, its battered, i’ve been using it since 2016 and it refused to work at all some months ago, until it magically came back to life and has been working ever since. I tried ordering another similar usb hub twice, but on both occasions my package was lost in transit, and i ordered it again today, hopefully third time’s a charm.

Windows: early 2021 install that was converted to Windows 11 when it became available, i chose to do a clean swipe back then, but i also had to revise some TPM configs when i upgraded my CPU last December, i think its possible Windows Update messed up some drivers while at it.

Motherboard: X370 i bought in 2019, not that old, but also not that new, there doesn’t seem to be anything wrong with it, but i think it could be a dormant issue, that rears its ugly head occasionally.

What do you guys think? I’m gonna do a clean install of Windows 11 this friday, but if the problem still persists, do you guys think the culprit is my motherboard or my usb hub?

Is it a powered hub? If not and if the port stops working it could be drawing a bit too much power? Or maybe the hub randomly shorts power to ground?

Yes, its powered, it has laptop style power supply, the new one i ordered is powered as well.

This seems possible…

Any chance this is power related? Not sure if you draw too much power from the PC power supply if you might have subsystems fail instead of an entire system failure.

It seems unlikely that a truly random failure would primarily occur when heavy usage such as gaming is occuring. Perhaps there is some sort of correlating factor though.

Not much, by my calculations my system barely exceeds 450w on max load, and my PSU is an 850w unit, which is also brand new, changed last month, and it also happened with the old one as well

1 Like

May be heat related, there’s a chance it’s the hub some are not the greatest under heavy loads or sustain activity like file transfer etc and crap out.

1 Like

I would definitely be inclined to blame the hub. I’ve tried numerous powered and unpowered solutions, and none of them ever kept a stable connection.

Only thing I could recommend if you’ve got a USB-C port available, is a hub like a Dell D6000, which miraculously doesn’t seem to struggle in the same way.

1 Like

I’ll look into getting something like that, it’s not cheap but definitely worth it if it fixes my problem.

Have you upgraded your motherboard’s BIOS? There were some weird USB issues on some AMD motherboards due to an older AGESA version.


I’m on the latest stable version, haven’t tried the Beta ones yet

Can pick up ex business ones quite cheap on eBay

1 Like

Hmm, perhaps I’ll order one trough a proxy, I only found brand new ones here in the country

Just reinstalled Windows 11, lets see how its going to behave for the next weeks

Yesterday my new hub arrived, giving me the chance to properly inspect the old hub.
What i found inside was this:

I’m no hardware designer, but i can spot that there’s 3 VIA VL813 hub controllers, looking at the spec sheet for them, it seems they’re only able to control 4 USB ports at a time, considering this is a 10 port hub, i believe they’re either working on a 4-3-3 or 4-4-2 configuration.
I believe that, maybe due to old age or a simple matter of lack of compatibility with Windows 11, these controllers are not working properly in tandem and were causing the issues i was having.
The new hub that replaced it has a similar configuration, but with 3 Realtek RTS5411 controllers instead, hopefully those won’t cause the same issues.

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.