USB DAC problems on Fedora

Hi guys! I’ve been a lurker for a long time, and finally decided to post.

I finally got the time to fully switch from Windows to Linux. I’m liking it so far, but I noticed that my USB DAC has skipping and popping in Fedora when it doesn’t in Windows. HDMI audio output from the GPU works fine in Fedora.

I tried bypassing Pulse and went straight for ALSA output to my DAC and it didn’t help. Using tsched=0 also didn’t help.

The DAC Is a FiiO Q1 MK2.

Any help is appreciated.

If I had to guess, I’d say some part of the system is getting the sample rate wrong. Like 48,000 vs 44,200. If only 44,200 is written and it plays it back at 48,000 there will be missing samples all the time.

But I don’t know how to fix that.

I’ve used three different USB audio devices on my Fedora and Ubuntu systems and they all worked, so I never had to debug it.

1 Like

What are the chances that the DAC by default uses some non standard sample rate like 96kHz

I’ll try look into it, that’s a great idea actually.

1 Like

If anyone finds this in the future, I fixed it by changing my frequency scaling algo to schedutil. Seems that my R5 2600 wasn’t scaling frequency fast enough.

Very late edit: Another solution I found was connecting the DAC to the USB2.0 slot instead of 3.0 on my motherboard.