Return to Level1Techs.com

UPS Monitoring woes (FreeNAS and pFSense)

#1

Hello all, I’ve been trying to get my APC Smart-UPS to shut down multiple computers on my network for about 2 weeks. So far I can get either my FreeNAS Box to shut down by itself, or literally everthing BUT my FreeNAS Box to shutdown.

Some specifics, I have a total of 5 devices on my network that I would like to have shutdown when the power goes out. 1 FreeNAS Server(High Priority) 1pFSense Router (Medium Priority) 2 Windows 7 desktops, and 1
Windows 10 desktop(Low Priority). Also this UPS powers my Switch and Modem (Basically my whole network)

Here is what I have done so far. Originally I had the UPS connected to the FreeNAS Server with a USB cable using the UPS Service to monitor and shutdown the server. And this worked great by itself, FreeNAS shutdown when it was supposed too and sent me nice informational E-Mails to boot.
My problems started when I tried to use the server part of NUT to shut down the other computer connected to the UPS. No matter what I did it would not communicate with the NUT server on my FreeNAS Box, soo I gave up.

Now I have just installed a pFSense router on my network and thought hey why don’t I try the apcupsd package in pFSense? So I swapped the USB from the FreeNAS Server to my pFSense server and after some tinkering I got pFSense to see the UPS AND the other windows machines on my network could see it too.
I was quite happy at this point because now I could set up a staged shutdown of the pc’s on my network based on priority leaving the pFSense server for last (because its the router for my whole network).
But alas my FreeNAS server will not talk to my apcupsd server setup on pFSense. And as I am sure most of you know having a FreeNAS Server shutdown safely when the power goes out is VERY important.

As of right now when I SSH into FreeNAS and type “upsc [email protected]:3551” I get “Error: Server disconnected”. This was after several hours of searching and tinkering with the settings.

If anyone knows how to get FreeNAS to talk to the apcupsd service on pFSense I would be very thankful.

P.S I tried the NUT package on pFSense, however due to my incompetence I couldn’t even get that to see the UPS on the localhost.

0 Likes