Updated Win Server 2016, killed desktop+taskbar


I have a VPS running Windows Server 2016 and today I had to restart to apply some Windows updates. After the restart there were no desktop and no taskbar, so I am basically stuck with launching stuff from the Task Manager. My first thought was to launch “explorer” but that does nothing.

Then I tried to call Microsoft support but apparently there’s no support included with their Server products so they want an absolutely insane 500 USD for providing any assistance! What the actual fuck!!!

Have any of you experienced the same issue or have any suggestions as to what it may be, how to solve it etc?
I’ve tried to search online for this problem but haven’t found anything that seems related at all.


You could try reinstalling the desktop experience.

Powershell should be:

Install-WindowsFeature Server-Gui-Shell -Restart

1 Like

Thank you for the suggestion. I actually tried this earlier but forgot to mention it here. It was the closest I could get from all the google results.

However trying this gives the following output:

PS C:\Windows\system32> Install-WindowsFeature Server-Gui-Shell -Restart
Install-WindowsFeature : ArgumentNotValid: The role, role service, or feature name is not valid: 'Server-Gui-Shell'.
The name was not found.
At line:1 char:1
+ Install-WindowsFeature Server-Gui-Shell -Restart
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo          : InvalidArgument: (Server-Gui-Shell:String) [Install-WindowsFeature], Exception
+ FullyQualifiedErrorId :         NameDoesNotExist,Microsoft.Windows.ServerManager.Commands.AddWindowsFeatureCommand

Success Restart Needed Exit Code      Feature Result
------- -------------- ---------      --------------
False   No             InvalidArgs    {}

What version of powershell are you on?

On 5.1 :slight_smile:

The option to swicth between Server Core and Desktop Experience was removed from Server 2016 due to its adoption of the Win10 GUI - So that is probably why that PoSH command does nothing.

it almost sounds like it has configured itself for tablet mode - which seems insane for a server product!

Yeah that would be absolutely insane if that had happened, who would use a server product on a tablet…

Been fiddling around for some time now and still pretty damn lost. Installed the security patch, rebooted and it had fucked itself up.
Tried to remove the patch and that has now resulted in about 2 hours of the server trying to sort itself out and concluding it couldn’t remove it so it’s rolling back the changes. Just managed to logon and desktop/taskbar still missing… I guess I should just get rid of Server 2016 and use 2012 instead, likely the same early diseases as Windows 10 is still suffering from :pensive:

Thanks for clarifying with regards to core / desktop!

So a bit of googling suggests that tablet mode is there on Server 2016 - mostly to offer it for remote desktop etc. Maybe you should get into the settings and check that, just in case.

I would test this, but all my server 2016 deployments are core without desktop mode - for my stuff the GUI is pointless on servers :slight_smile:

No luck on tablet mode.
Just tried to go to the “reset” feature but clicking that gives me “explorer.exe - class not registered” - hmm…

It makes a lot of sense running servers without GUI, I do that with Linux all the time, but I had to do this Winblows setup at work where a bunch of mechanical and electrical engineers need to be able to access it and they need a GUI and so does the software that needs to be on it.

1 Like

Sorry, never had a chance to come look at this yesterday. I really don’t have much else where to go, I’ve never heard of an issue like this before with 2016. 2012r2, yeah, but not 2016. The fix was resetting the GUI in powershell for 2012r2 so I was hoping that would resolve it.

You might try to run an sfc scan or something.


I’ve found a “solution”.
Got rid of the 2016 Server VPS and set up a dedicated box instead with ESXi and a Windows 2012 R2 guest. Then the hardware has to fail for anything to take more than a matter of minutes to fix so I think this is a better solution in the long run. Also not having to pay 30$ a month for the 2016 license makes the dedicated box cost just around 15$ more per month which is nothing considering all the benefits and flexibility it adds.

Ohhh you were in ESXi? I’m willing to bet that was a vmware tools graphical driver issue then. We get loads of those.

No, I wasn’t using ESXi with the 2016 Server… Or maybe I was, I’m not sure - it was a VPS so I don’t really know exactly what host config it was on.
Moving to from the VPS with just the 2016 Server to a dedicated box where I’ve set up ESXi and 2012 R2 plus whatever other guest we’ll eventually be running alongside it.

Well since it was virtualized the possibilities of what it could be go up. Glad you got a solution though.